Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-04-2004, 07:28 AM   #1
LQ Newbie
Registered: Feb 2004
Location: L'viv
Distribution: ASP Linux 9.0
Posts: 8

Rep: Reputation: 0
NTFS write suuport

Please help me to set the full write supprot! the kernel don't support full write support !
Old 03-04-2004, 07:44 AM   #2
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
dont do it. NTFS write support is not yet flawless.
Old 03-04-2004, 07:54 AM   #3
LQ Guru
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
NTFS write is not properly supported in the Linux kernel driver. You can try Captive-ntfs to get write support.
Old 03-04-2004, 07:56 AM   #4
Registered: Mar 2004
Location: Pakistan
Posts: 49

Rep: Reputation: 15
but if u still want to do then u need
to rebuild ur kernel
well i am a RH user
i can tell u with RH refrence
during recompiling ur kernel
make xconfig
it will open the options and as well load the old config.
then from there click filesystems
then find "support ntfs filesystem (Read only)"
when u click this option to make it compiled as module or
with kernel
another option with"ntfs support read/write (DANGEROUS)"
click it and then compile ur kernel
Old 03-07-2004, 12:57 AM   #5
LQ Newbie
Registered: Mar 2004
Location: New Zealand
Distribution: Linux Redhat 9
Posts: 11

Rep: Reputation: 0

What's the simplest way to put this...


Enabling NTFS support can be done by rewriting the kernel, simply dont do it, it's not only flawed, writing to a mounted NTFS drive can cause permanent damage to your hard drive.

is the way to go!'s a suggestion, make an extra vfat partition on your HDD and mount it under linux with the command beneath this, use it to transfer files between windows and linux.

to mount the hard drive:
mount -t vfat /dev/hda1

replace hda1 with the hard drive you wish to mount, replace vfat with the file system used.
Old 03-07-2004, 01:04 AM   #6
Registered: Jan 2004
Location: /dev/random
Distribution: Gentoo amd64, CrunchBang amd64
Posts: 350

Rep: Reputation: 32
Another suggestion: If you are moving smallish files and have a memory card reader use that as your intermediary for transferring files to Windows. NTFS read hasn't given me any problems besides the fact it forces me to be root to do it.. go figure.
Old 03-07-2004, 02:43 AM   #7
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
You may want to try external application to enable ntfs write support.

I never used it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
write to ntfs paulmedic555 Linux - Newbie 10 11-22-2004 11:04 AM
Are the QT suuport STL? Barq Linux - General 1 11-18-2004 11:20 AM
how do i write to NTFS zaicheke Slackware 7 07-25-2004 08:28 PM
cannot write in ntfs alaios Linux - Hardware 10 04-17-2003 12:16 PM
Has anybody actually tried NTFS write? bax Linux - General 8 10-04-2002 02:49 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration