LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ntfs kernel problem (https://www.linuxquestions.org/questions/linux-newbie-8/ntfs-kernel-problem-448020/)

jojojo 05-24-2006 06:05 AM

Ntfs kernel problem
 
I have installed the ntfs kernel kernel-module-ntfs-2.6.16-1.2122_FC5-2.1.26-0.rr.10.5.i586.rpm

But when i want to mount the ntfs disk, there is an error.

mount /dev/hda1 /mnt/windows -t ntfs -r
mount: unknown filesystem type 'ntfs'


I dont know whats the problem. I'm using fedora core 5.

verdeboy2k 05-24-2006 06:08 AM

run lsmod and see if the ntfs module is loaded, if not, load it with "modprobe ntfs"

jojojo 05-24-2006 06:13 AM

How to run the Ismod? What is the command?

verdeboy2k 05-24-2006 06:14 AM

run (might have to be root)
Code:

lsmod

jojojo 05-24-2006 06:17 AM

I've run the lsmod. There are no ntfs. Then i run the modprobe ntfs, there is fatal error.

modprobe ntfs
FATAL: Module ntfs not found.


I have also run the cat /proc/filesystems, but still the same. No ntfs.

Is it because i have downloaded the wromng architecture i586? Instead i should download the i386 architecture?

verdeboy2k 05-24-2006 06:23 AM

it seems that the package didn't install the nfts kernel module, or installed it into a weird place...
it should have been installed to /lib/modules/your-kenrel-name/kernel/fs
Did you install the kernel module for the kernel you have installed?
You might have to take this with a grain of salt because I don't have fedora.


All times are GMT -5. The time now is 10:11 AM.