LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   NTFS-Captive drivers, and installing (https://www.linuxquestions.org/questions/linux-newbie-8/ntfs-captive-drivers-and-installing-164220/)

JohnnyNapalm 03-30-2004 01:19 PM

NTFS-Captive drivers, and installing
 
I installed the standard .rpm off the website, but do I need to do anything extra (mounting the harddrive) to enable it?

wiBo 03-30-2004 03:40 PM

Read the instructions before installing.. :tisk:

You run captive-install acquire for identify your NTFS partitions..

After :

mkdir /mnt/NAME_OF_YOUR_MOUNT_POINT
mount -t captive-ntfs /dev/hdax /mnt/NAME_OF_YOUR_MOUNT_POINT


hdax = x is the number of your Windows NTFS partition...
like hda6 :-)

Try that :)


JohnnyNapalm 03-30-2004 04:00 PM

i did read the instructions, and did not find them to be helpful at all.

after following your instructions, i can now no longer see ANYTHING in any of my NTFS drives. How do I reverse the effects?

wiBo 03-30-2004 04:01 PM

I have due that here and no problems :/

Try to unmount

umount /mnt/mount_point

What do you want to say, cauze my english is poor :/

JohnnyNapalm 03-30-2004 04:21 PM

ok, restarted the comp, the drive is mounted as it had been.

now,

when i installed captive off of the rpm, it made two new mount points, one for each ntfs drive in my computer, so doing the "mkdir" command was unneccessary. then i tried to mount it as such:

mount -t captive-ntfs dev/hda7 /mnt/captive-extras

it returned no errors, but when i look into the folder, it's completely empty. explain?

JohnnyNapalm 03-30-2004 05:51 PM

anybody have any ideas?

wiBo 03-30-2004 06:12 PM

try with mkdir :)

sirpimpsalot 03-30-2004 06:26 PM

permissions? try adding umount=000 to each ntfs entry in /etc/fstab file.

Mr_C 03-30-2004 08:19 PM

are you sure you read the documentation??

mkdir /var/lib/captive

must contain ntfs.sys and ntoskrnl.exe of your current ntfs drive (yes they change with service pack updates)

then you mount like normal ( by default, only root can write files on the ntfs)

WITH THE DRIVE UNMOUNTED

chmod u+rw /mnt/ntfs (or wherever you mounting your drive)

JohnnyNapalm 03-31-2004 06:45 PM

ok, i got it mounted ok, but if i'm always logged into my normal account, how can i ever write to it, if that's a root only privalege

jax8 03-31-2004 07:55 PM

su to root and then wirte and read from the dirve

JohnnyNapalm 03-31-2004 09:58 PM

is there no way to drag and drop?

Mr_C 04-02-2004 10:32 AM

do the chmod on the directory (UNMOUNTED) and you can write to like a normal user...

aaa 04-02-2004 10:41 AM

With regular ntfs/fat you can use the 'umask=0' option to give everybody access... not sure if it works with Captive.
mount -t captive-ntfs /dev/hda7 /mnt/captive-extras -o umask=0

You can add it to fstab to make it permanent.

Mr_C 04-04-2004 10:18 PM

it appears not with respect to the umask00 and captive....


All times are GMT -5. The time now is 04:20 PM.