LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   nss_ldap: reconnecting to LDAP server (sleeping 64 seconds) (https://www.linuxquestions.org/questions/linux-newbie-8/nss_ldap-reconnecting-to-ldap-server-sleeping-64-seconds-781846/)

your_shadow03 01-12-2010 10:40 PM

nss_ldap: reconnecting to LDAP server (sleeping 64 seconds)
 
I have setup LDAP Client which is trying to communicate to LDAP Server(fedora DS) but displays the error while I login as one of user created at Server end.
the /var/log/secure file @ LDAP Client says so:

Code:

eping 64 seconds)...
Jan 13 15:35:27 localhost sshd[2908]: nss_ldap: reconnecting to LDAP server (sleeping 64 seconds)...
Jan 13 15:36:58 localhost sshd[2962]: nss_ldap: reconnecting to LDAP server (sleeping 4 seconds)...
Jan 13 15:37:02 localhost sshd[2962]: nss_ldap: reconnecting to LDAP server (sleeping 8 seconds)...
Jan 13 15:37:10 localhost sshd[2962]: nss_ldap: reconnecting to LDAP server (sleeping 16 seconds)...
Jan 13 15:37:26 localhost sshd[2962]: nss_ldap: reconnecting to LDAP server (sleeping 32 seconds)...
Jan 13 15:37:58 localhost sshd[2962]: nss_ldap: reconnecting to LDAP server (sleeping 64 seconds)...

And when I try doing without SSL it worked !!
Here is when I follow like this:
Code:

1.authconfig --enableshadow --enablemd5 --enableldap --enableldapauth --ldapserver=10.209.37.91 --ldapbasedn=dc=isst,dc=sapient,dc=com --enablecache --enablemkhomedir --updateall
2. I din't select TLS[]
3. Din't provide ldaps:// too..Kept it ldap://
4. You will be logged in successfully

Code:

[root@localhost ~]# authconfig --enableshadow --enablemd5 --enableldap --enableldapauth --ldapserver=10.209.37.91 --ldapbasedn=dc=isst,dc=sapient,dc=com --enablecache --enablemkhomedir --test
caching is enabled
nss_files is always enabled
nss_compat is disabled
nss_db is disabled
nss_hesiod is disabled
 hesiod LHS = ""
 hesiod RHS = ""
nss_ldap is enabled
 LDAP+TLS is disabled
 LDAP server = "10.209.37.91"
 LDAP base DN = "dc=im,dc=sap,dc=com"
nss_nis is disabled
 NIS server = ""
 NIS domain = ""
nss_nisplus is disabled
nss_winbind is disabled
 SMB workgroup = ""
 SMB servers = ""
 SMB security = "user"
 SMB realm = ""
 Winbind template shell = "/bin/false"
 SMB idmap uid = "16777216-33554431"
 SMB idmap gid = "16777216-33554431"
nss_wins is disabled
pam_unix is always enabled
 shadow passwords are enabled
 password hashing algorithm is md5
pam_krb5 is disabled
 krb5 realm = "EXAMPLE.COM"
 krb5 realm via dns is disabled
 krb5 kdc = "kerberos.example.com:88"
 krb5 kdc via dns is disabled
 krb5 admin server = "kerberos.example.com:749"
pam_ldap is enabled

 LDAP+TLS is disabled
 LDAP server = "10.209.37.91"
 LDAP base DN = "dc=isst,dc=sapient,dc=com"
pam_pkcs11 is disabled

 use only smartcard for login is disabled
 smartcard module = "None"
 smartcard removal action = ""
pam_smb_auth is disabled
 SMB workgroup = ""
 SMB servers = ""
pam_winbind is disabled
 SMB workgroup = ""
 SMB servers = ""
 SMB security = "user"
 SMB realm = ""
pam_cracklib is enabled (try_first_pass retry=3)
pam_passwdqc is disabled ()
pam_access is disabled ()
pam_mkhomedir is enabled ()
Always authorize local users is disabled ()
Authenticate system accounts against network services is disabled
[root@localhost ~]#


But if I select TLS[*]
ldaps://
It din't work and displays the first screen error.
Any idea ?

I can guess if the certificate is not properly copied at right directory at Client side
Pls Suggest.

your_shadow03 01-13-2010 12:59 PM

Anyone who can help me with this?


All times are GMT -5. The time now is 12:52 PM.