LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ns-allinone-2.31 question (https://www.linuxquestions.org/questions/linux-newbie-8/ns-allinone-2-31-question-632424/)

m.alnaas 04-02-2008 08:29 AM

ns-allinone-2.31 question
 
Hi everyone;
I'm new in this website, and i need your help.
Q which is the best version of Linux that can work properly with ns-allinone-2.31?

I have tried with Fedora 9beta and Fedora8, both of them didn't work with it.

So many errors I have got, there's something I don't know about which is gcc. One of my friend told me that your linux should include it or it won't work properly.

Plz, advice me, because this is my first time working on Linux and I need it as much as you can imagien.
Thanks

knudfl 04-02-2008 10:59 AM

Please see this thread for things required to install on fc8:
http://www.linuxquestions.org/questi...ll-ns2-421797/
And you can use the LQ search using keyword 'ns2' for more information, and remember to
look at 'Similar Threads' at bottom of LQ-pages.
What I know is that ns-allinone-2.31 compiles without problems on slackware 12 and
PCLinuxOS2007.

linderque 04-24-2008 12:51 AM

Hello...
I tried to install ns-2.31 in ubuntu 7.10
everything seems to fine. It says that "Ns-allinone package has been installed successfully"
And i also did as what in the installation step from the ns2 site (setting up the environment variables)
But when i tried to run an example from ns2,(the tcl script)eventhough i am in the correct directory....it gave me this error,

>>> maslinda@maslinda:~/ns-allinone-2.31/ns-2.31/tcl/ex$ ns wireless.tcl
>>> wireless.tcl does not exist, try again


Can someone help me to figure out this problem?

-linderque-

knudfl 04-25-2008 05:43 AM

Try this:
http://isi.edu/nsnam/ns/tutorial/nsscript5.html
Quote: If you want to download a copy of simple-wireless.tcl click here

Google is your friend: I just googled: wireless.tcl

inamullah 07-21-2008 02:35 AM

Hi everyone,
I have installed NS2 (3.31 version). Everything was successful. But When I was told to modify env variables, all but LD_LIBRAY_PATH are properly shown when I type env command. (I provided provided the variables in /etc/profile). I don't know why particularly LD_LIBRAY_PATH is not shown.
I am using Linux enterprise edition on a Sun machine.

knudfl 07-22-2008 03:17 PM

# 5 inamullah :
A permanent library path is usually added by a
line in /etc/ld.so.conf

I would try that.

( For the "bin" path I would create 2 scripts in
/etc/profile.d/
(like the scripts for java in Slackware)
1) "ns2.csh" and 2) "ns2.sh" )

Regards


All times are GMT -5. The time now is 04:08 AM.