LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-17-2011, 11:23 PM   #1
fahoud
LQ Newbie
 
Registered: Apr 2011
Posts: 2

Rep: Reputation: 1
ns-2.34 extension with ubuntu 10.10


hi
I am trying to install the ns-2 extension by using the patch file for ns-2.34
the os is ubuntu10.10
it runs
but it gives me
hunk# failed
and unexpected finish for the patch file
doing the following
make distclean on ns-2.34 directory
patch -p1 name of patch file path of that patch file
here it gives errors
so please any help will be appreciated .
thankx
 
Old 04-18-2011, 03:55 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,738

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
Welcome to LQ.

Please tell the name of the patch.
There are a 100 different patches for ns2.
( And `1 hunk failed` is not nessecaryly an error.)

For Ubuntu 10.10 / ns-allinone-2.34, the gcc/g++-4.3 should be used.
( sudo apt-get install g++-4.3 )

cd ns-allinone-2.34/ && export CC=gcc-4.3 CXX=g++-4.3 && ./install

..
 
Old 04-18-2011, 01:47 PM   #3
fahoud
LQ Newbie
 
Registered: Apr 2011
Posts: 2

Original Poster
Rep: Reputation: 1
thankx for ur replay
i did what you are saying before and it is ok now
but the patch file that i am trying to install is { ns-2.34-q2s.20101208.patch}
 
1 members found this post helpful.
Old 04-18-2011, 04:03 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,738

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
Not quite clear, if post # 3 has a question.

'q2s for ns-2.34' :
For the sake of completeness : a download link to 'ns-2.34-q2s.20101208.patch':
wget http://people.item.ntnu.no/~paquerea...20101208.patch
Documentation : http://people.item.ntnu.no/~paquerea/ns/q2s_doc.pdf
http://www.q2s.ntnu.no/~paquerea/ns.php

..

Last edited by knudfl; 04-18-2011 at 04:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Invoking extension files in Ubuntu deck99 Programming 1 11-20-2010 02:55 AM
installig files with .bin extension in linux (ubuntu 8.04) ifranklin Linux - Software 12 10-17-2010 03:34 AM
Installing Nvidia driver with '.run' extension in Ubuntu thanhooh Linux - Software 3 07-23-2010 04:35 AM
Extension Manager crash in Openoffice 3.1 ubuntu 9.04 JHONJ Linux - Software 0 08-09-2009 11:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration