LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   NOT like a Virgin to SUSE? (https://www.linuxquestions.org/questions/linux-newbie-8/not-like-a-virgin-to-suse-342126/)

Premadonna 07-11-2005 08:18 AM

NOT like a Virgin to SUSE?
 
Hi all,

I'm on suse 9.2 dying to connect an Iomega 80gb desktop usb hdd. How do I get to see it in devices so I can read and write to it :scratch:

Drive power is on, plugged it into a usb port, started the machine, saw suse recognize the device and manufacturer on bootup, went to My Computer in KDE as root. It opens up drives:/. Didnt see it there. So I right clicked, Create New, Device, Hard Disc Device, went to Device Tab, selected usbfs from the drop down box, clicked OK. Then it gives me "Writing to Drives is not supported." Did I take the right approach.

The drive has some data on it I wouldnt like to lose. Ive gone into Yast, System, Partitioner anyway to check it out... I see 2 entries with 75GB: /dev/sda and /dev/sda1 (which says formatted Win95 FAT32). Nothing under Mount, so I went to Edit for /sda1 but under Mount Point there is only /srv, /tmp, /local. Not knowing what these are for I'm totally lost.

I need to back up my downloads on it ahead of a fresh 9.3 reinstall to fix a whole bunch of problems like it restarts when you shut down. Maybe it is or isnt related to my problem, but on startup I get Error-Could not start process Unable to create io-slave klauncher said: Unknown protocol 'devices'.

tangle 07-11-2005 10:22 AM

It sounds to me like it is a permissions problem with the directory that the drive is mount in. There should a line in the /etc/fstab for it.

camorri 07-11-2005 10:42 AM

I'm reading between the lines a little here, so correct any wrong assumptions I make.

It sounds as if you have a USB external hard drive that was formatted as fat32. It also sounds as if your system recognizes the drive. If it is seeing the drive, you must have USB support in the kernal, so that is good.

I am not at all sure it is mounted into the file system. To mount a drive, you need a /dev/sda. Do you see that in your file system? If yes, then try a mount command, or edit your fstab and make an entry. Here is what my fstab looks like for a USB memory card. They look just like an external drive.

/dev/sda1 /mnt/memory_card auto umask=0,user,iocharset=iso8859-15,sync,kudzu,cod

Here is an example of mounting a fat32 drive, although this one is an IDE internal drive.

/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-15,codepage=850 0 0

Hope this helps you out.

Premadonna 07-12-2005 02:05 AM

Thanks! As I was about to do what you recommended, I noticed I forgot to switch on my usb drive before booting. So I did when it was logged on, and voila! Automatically I get a popup of the new drive in files/media, and it shows up as a device in My Computer.

I think I can guess why. In suse (I dont know about other distros) there are 3 settings for drivers to load: On Boot, Manual (command line), and --- the default for USB devices --- Hotplug. Perhaps unlike Windows plugnplay, Hotplug is limited to literally when you Plug the device in (Hotplug is Hotplug, not Hotplug+On Boot). I might be wrong, but at least now I'm singing Holiday instead of Like a Virgin.

A little trivia: I really appreciate your caring to reply. I posted this in the Suse forum first, and after having been viewed but given the silent treat I came to crosspost here. Then after you replied I got moderator rank there and that thread was locked! Of course I honor that rule now that I know it and won't do it again, but it goes to show us felllow newbies would give a minute to help each other out. I'm just asking for a flame arent I? ;)


All times are GMT -5. The time now is 02:23 PM.