-   Linux - Newbie (
-   -   Not able to install Grub on sda (Redhat) (

Chase1337 04-27-2013 11:09 AM

Not able to install Grub on sda (Redhat)
Hello. I m a new linux user and chose Redhat as my first distribution to try.

I made a bootable USB stick with UltraISO and was able to install redhat successfully on my system.
But there is some issue with the grub installtion. Bootloader was installed on sdb (USB stick) hence my system would show an error message (Could not load operating system) if USB drive is not connected, and would boot fine if USB is connected and kept as first booting preference.

I tried the installtion again and tried to review the partitioning layout. I found out that it doesnt even give me an option to install grub on sda, instead of sdb. It just gives two radio buttoned options as-
  • Grub will be installed on /dev/sdb
  • No grub will be installed

How do I installed it on sda? Please help.

Re: I have also tried booting in rescue mode and executing following:
#chroot /mnt/sysimage
#grub-install /dev/sda

But of no use. It says it installed properly, the previous error message is removed, but it just shows the boot screen again and again and doesnt boot the system.

Please tell me what to do at partioning time so that it gives option "Grub will be installed on /dev/sda"

Thank you. 04-27-2013 11:21 AM

Okay, the redhat setup clearly installed GRUB on the MBR of the first possible drive. You need to specify manually which disk to install the MBR to, so unless you have anything important on the OS, try reinstalling and see if you can do a manual or advanced config when it comes to boot loader setup.

guyonearth 04-27-2013 02:04 PM

This is a very common problem with installations from USB, on many of the RedHat-based distros, it's an issue in Oracle, too. There should be an option to select which device to install grub to, even if it's not obvious. The Anaconda installer gives the option of which device to choose.

All times are GMT -5. The time now is 05:24 AM.