-   Linux - Newbie (
-   -   Normal user cannot start KDE - root can (

tagit 12-26-2003 06:40 AM

Normal user cannot start KDE - root can
Hi everyone,

I've just installed Debian Testing (sarge) / KDE 3.1.4 and I've the following problem. I can start / login to KDE as root. However if I want to login as a normal user the screen goes black and after a few seconds the login screen shows again. If I want to startx from the console it returns startx - command unknown. The xsession-errors says:

/etc/kde3/kdm/Xsession: line 7: xrdb: command not found

I think this might have something to do with user rights but I've no clue how / which / where rights to set.
Could anyone point me in the right direction - I'm lost.


mikshaw 12-26-2003 12:37 PM

type (not as root): echo ${PATH}
check to see if /usr/X11R6/bin and /opt/kde3/bin (or something very similar) is in there. If not, that's most likely the problem

hindenbergbaby 12-26-2003 05:57 PM

I'm not the original poster, but I'm having a similar problem with GNOME and SuSE 9. It worked fine before the upgrade, and works for root, but there's no love with a normal user. opt/gnome/bin is there as a normal user... But still no dice. I know it's a permissions problem, but I'm not sure exactly what I have to change to get access. Please help... KDE stinks! Or is this a good time to learn to use Windowmaker?

Any hints are greatly appreciated!


mikshaw 12-26-2003 08:12 PM

xrdb, as well as other files necessary for x, is in /usr/X11R6/bin, or similar X11-bin directory
Type "which xrdb" to find out where it is for certain, and make sure that's in your path as well. I don't know why it wouldn't have been in your path to begin with, though, so the problem may be something else.

If your trouble is "similar" but not exactly the same, perhaps you have a ~/.xinitrc or ~/.xsession file which needs gnome added to it.
I agree that KDE stinks....I've been using nothing but Fluxbox most of the time. Next install I do I'm gonna try to see how well it works with no KDE files installed....they just slow me down and look cheesy.

All times are GMT -5. The time now is 03:35 PM.