-   Linux - Newbie (
-   -   Non-root user can't see all commands (Zenwalk) (

POW R TOC H 08-24-2008 02:56 PM

Non-root user can't see all commands (Zenwalk)
Hello. I have installed Zenwalk, but I have a problem (probably designed that way, but I don't like it ;) ) :
A non-root user can't see programs that require root privileges (in terminal). For example, when I type

'netpkg mirror'
I get

bash: netpkg: command not found
. This goes for all commands that require root privileges, which is annoying :) (can't see them, can't use auto-complete with them, etc)

In Fedora, I get an error message when I try to use a program that requires more privileges than I've got, but in Zenwalk, I don't even see those with sudo! I have to log in as root (or use su)... Any idea on why this is, and how to fix it?

Thank you in advance, and sorry if I misspelled something. My spell checker is broken too :)

Renan_S2 08-24-2008 03:03 PM

It is likely because /sbin and /usr/sbin aren't in your $PATH.

To set it, type:

export PATH=$PATH:/sbin:/usr/sbin

And/or put it into your .bashrc.

POW R TOC H 08-24-2008 03:20 PM


Originally Posted by Renan_S2 (Post 3258216)
It is likely because /sbin and /usr/sbin aren't in your $PATH.

To set it, type:

export PATH=$PATH:/sbin:/usr/sbin

And/or put it into your .bashrc.

That solved it, thank you :)

xroox 09-04-2009 11:56 PM

Hi thanks for the info solved my problem too. I really hate not knowing what commands "do" when I type them in. Would you be able to maybe explain what that did and why I needed to do that? If it's not too much trouble I'd really appreciate it.



xroox 09-05-2009 12:02 AM

woah, now when I try and pick a mirror it says:

tail: cannot open '/var/netpkg/db/last_mirror' for reading: No such file or directory


Connecting to mirror
Uncompressing meta information
Unable to extract meta information, please check the network or choose another mirror

Then nothing... I've tried several of the mirrors. Weird? No internet working yet? Not sure. Thanks.

Wim Sturkenboom 09-05-2009 12:51 AM

When you type a command, the shell will look in the directories specified in the path to find it. The command in post #2 added some directories to the path.

The *nix world has split user commands and superuser commands into different directories. The idea is/was that normal users don't have to execute those commands so don't need access to them. Nowadays the world has changed as on desktop systems there is often only one user.

At times I consider it an annoyance, but I can live with it. I can always use locate to find it and execute the command using the full path.

I can not answer your second question for sure, but if you ran that command as a normal user you might not have the permissions to access '/var/netpkg/db/last_mirror'.

xroox 09-05-2009 12:57 AM

Thanks! Ok I went to that path and indeed there was no file by that name there. I could not seem to gain SU access though, I might have skipped by something in the installation as I was only half-looking at the screen. I would have thought I put a password in during installation but maybe not.

Thanks for the info so far most appreciated this will be great once I get it going. Fun.


All times are GMT -5. The time now is 11:58 AM.