LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2016, 08:52 PM   #1
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Rep: Reputation: Disabled
No wlan0 after kernel 4.9.0 installation on Debian Jessie.


Hello all,

I was having graphics card issues with the stock installation of Debian Jessie 8. I upgraded the kernel, which fixed the graphics issue but broke my wifi. I made sure the non-free firmware is installed with:

Note: Kernel source: https://www.kernel.org/

Code:
apt-get install firmware-iwlwifi
The os can see the wifi card:

Code:
xxxxx@xxxxxxx:~# lspci -nn | grep 0280
03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 83)
The results of
Code:
ifconfig
:

Code:
xxxxx@xxxxxxx:~$ sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 28:d2:44:39:b5:d2  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:70 errors:0 dropped:0 overruns:0 frame:0
          TX packets:111 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13215 (12.9 KiB)  TX bytes:15706 (15.3 KiB)
          Interrupt:20 Memory:f0600000-f0620000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:4323 (4.2 KiB)  TX bytes:4323 (4.2 KiB)
The required firmware is in /lib/firmware:
Code:
-rw-r--r--  1 root root  337520 Jun 15  2014 iwlwifi-1000-5.ucode
-rw-r--r--  1 root root  337572 Jun 15  2014 iwlwifi-100-5.ucode
-rw-r--r--  1 root root  689680 Jun 15  2014 iwlwifi-105-6.ucode
-rw-r--r--  1 root root  701228 Jun 15  2014 iwlwifi-135-6.ucode
-rw-r--r--  1 root root  695876 Jun 15  2014 iwlwifi-2000-6.ucode
-rw-r--r--  1 root root  707392 Jun 15  2014 iwlwifi-2030-6.ucode
-rw-r--r--  1 root root  670484 Jun 15  2014 iwlwifi-3160-7.ucode
-rw-r--r--  1 root root  667284 Jun 15  2014 iwlwifi-3160-8.ucode
-rw-r--r--  1 root root  666792 Jun 15  2014 iwlwifi-3160-9.ucode
-rw-r--r--  1 root root  150100 Jun 15  2014 iwlwifi-3945-2.ucode
-rw-r--r--  1 root root  187972 Jun 15  2014 iwlwifi-4965-2.ucode
-rw-r--r--  1 root root  353240 Jun 15  2014 iwlwifi-5000-2.ucode
-rw-r--r--  1 root root  340696 Jun 15  2014 iwlwifi-5000-5.ucode
-rw-r--r--  1 root root  337400 Jun 15  2014 iwlwifi-5150-2.ucode
-rw-r--r--  1 root root  454608 Jun 15  2014 iwlwifi-6000-4.ucode
-rw-r--r--  1 root root  444128 Jun 15  2014 iwlwifi-6000g2a-5.ucode
-rw-r--r--  1 root root  677296 Jun 15  2014 iwlwifi-6000g2a-6.ucode
-rw-r--r--  1 root root  679436 Jun 15  2014 iwlwifi-6000g2b-6.ucode
-rw-r--r--  1 root root  463692 Jun 15  2014 iwlwifi-6050-4.ucode
-rw-r--r--  1 root root  469780 Jun 15  2014 iwlwifi-6050-5.ucode
-rw-r--r--  1 root root  683236 Jun 15  2014 iwlwifi-7260-7.ucode
-rw-r--r--  1 root root  679780 Jun 15  2014 iwlwifi-7260-8.ucode
-rw-r--r--  1 root root  679380 Jun 15  2014 iwlwifi-7260-9.ucode
-rw-r--r--  1 root root  690452 Jun 15  2014 iwlwifi-7265-8.ucode
-rw-r--r--  1 root root  691960 Jun 15  2014 iwlwifi-7265-9.ucode
I've tried this solution to no avail: http://www.linuxquestions.org/questi...-wlan0-333831/

My question: What happened to my wlan0 adapter after the kernel update?

Last edited by jacnj; 12-11-2016 at 10:21 PM. Reason: Adding firmware
 
Old 12-11-2016, 10:36 PM   #2
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 421

Rep: Reputation: 74
Any wlan0-related messages at dmesg? Try this:

Code:
ip link
if nothing comes up
Code:
ip link set dev wlan0 up
 
Old 12-11-2016, 11:07 PM   #3
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by c0wb0y View Post
Any wlan0-related messages at dmesg? Try this:

Code:
ip link
if nothing comes up
Code:
ip link set dev wlan0 up
here are the results:
Code:
xxxxx@xxxxxx:~$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 28:d2:44:39:b5:d2 brd ff:ff:ff:ff:ff:ff
xxxxx@xxxxxxx:~$ ip link set dev wlan0 up
Cannot find device "wlan0"
 
Old 12-11-2016, 11:31 PM   #4
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 421

Rep: Reputation: 74
Ok, so it doesn't show there. Try this:

Code:
ls -la /sys/class/net/
 
Old 12-11-2016, 11:34 PM   #5
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
Doesn't seem to be there either
Code:
xxxxx@xxxxxx:~$ ls -la /sys/class/net/
total 0
drwxr-xr-x  2 root root 0 Dec 11 22:33 .
drwxr-xr-x 55 root root 0 Dec 11 20:35 ..
lrwxrwxrwx  1 root root 0 Dec 11 20:35 eth0 -> ../../devices/pci0000:00/0000:00:19.0/net/eth0
lrwxrwxrwx  1 root root 0 Dec 11 20:35 lo -> ../../devices/virtual/net/lo
 
Old 12-11-2016, 11:49 PM   #6
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 421

Rep: Reputation: 74
It seems module is not loaded, that's why we're not seeing any wlan0. Can you:

Code:
find /lib/modules/$(uname -r) -type f -name 'iwl*'
Now if you see iwlwifi.ko, load the module:
Code:
modprobe iwlwifi
Note: no trailing .ko.
 
Old 12-12-2016, 08:44 AM   #7
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
Sorry for the delayed response, my power went out.

Code:
xxxxx@xxxxxx:~$ find /lib/modules/$(uname -r) -type f -name 'iwl*'
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlegacy/iwl3945.ko
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlegacy/iwl4965.ko
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlegacy/iwlegacy.ko
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlwifi/mvm/iwlmvm.ko
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlwifi/dvm/iwldvm.ko
/lib/modules/4.9.0-custom/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
xxxxx@xxxxxxx:~$ modprobe iwlwifi
bash: modprobe: command not found
xxxxx@xxxxxx:~$ sudo modprobe iwlwifi
[sudo] password for xxxxx: 
xxxxx@xxxxxxx:~$
I see the driver, but modprobe iwlwifi doesn't seem to do anything.

After modprobe iwlwifi and restart:

Code:
xxxxx@xxxxxxx:~$ sudo ifconfig
[sudo] password for xxxxx: 
eth0      Link encap:Ethernet  HWaddr 28:d2:44:39:b5:d2  
          inet addr:192.168.0.15  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: 2600:8800:8080:ae0:2ad2:44ff:fe39:b5d2/64 Scope:Global
          inet6 addr: fe80::2ad2:44ff:fe39:b5d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:69 errors:0 dropped:0 overruns:0 frame:0
          TX packets:113 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13061 (12.7 KiB)  TX bytes:15749 (15.3 KiB)
          Interrupt:20 Memory:f0600000-f0620000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:31 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:3315 (3.2 KiB)  TX bytes:3315 (3.2 KiB)

Last edited by jacnj; 12-12-2016 at 08:50 AM. Reason: Added ifconfig details
 
Old 12-12-2016, 09:32 AM   #8
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
I've decided to just switch back to the original kernel. I need this machine in working order, fast. I'll address the graphics issue from there later as it doesn't hinder actual use of the machine.

Thanks for the help!
 
Old 12-12-2016, 12:16 PM   #9
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 421

Rep: Reputation: 74
It's a custom kernel by the looks which I should have asked you first.

My guess is you don't have the MSI on your custom kernel. grep that from the .config
 
Old 12-12-2016, 01:18 PM   #10
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
I've already switched back. I'll give it a try though.
 
Old 12-24-2016, 08:09 AM   #11
BourneSupremacy
LQ Newbie
 
Registered: Dec 2016
Location: Somewhere around the world
Distribution: Debian Jessie 8, Mint 18*
Posts: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by jacnj View Post
I've already switched back. I'll give it a try though.
understand you already switched back but did you try the rfkill command?? If not you may want to.....
 
Old 12-24-2016, 03:04 PM   #12
jacnj
Member
 
Registered: Jul 2014
Posts: 59

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BourneSupremacy View Post
understand you already switched back but did you try the rfkill command?? If not you may want to.....
Can you explain how this will help? Thanks for the reply BTW.
 
Old 12-24-2016, 07:53 PM   #13
Brains
Senior Member
 
Registered: Apr 2009
Distribution: All OS except Apple
Posts: 1,591

Rep: Reputation: 389Reputation: 389Reputation: 389Reputation: 389
Exclamation

Quote:
Originally Posted by jacnj View Post
After modprobe iwlwifi and restart:
After restart, one would have to modprobe again
 
Old 12-25-2016, 07:05 AM   #14
BourneSupremacy
LQ Newbie
 
Registered: Dec 2016
Location: Somewhere around the world
Distribution: Debian Jessie 8, Mint 18*
Posts: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by jacnj View Post
Can you explain how this will help? Thanks for the reply BTW.
If wireless fails to work even after installing firmware, do the following:

root@masterdebian: cd /etc/NetworkManager
root@masterdebian: cat NetworkManager.conf

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

Change the last line in [ifupdown] from managed=false to managed=true; then run the following commands:

modprobe -r {firmware version installed} - in my case it was modprobe -r ipw2200, the -r is for reset
modprobe ipw2200 - will turn the wireless card on

For devices with a BCM4306 revision 3, BCM4311, BCM4318, BCM4321 or BCM4322 chip, install:
apt-get install firmware-b43-installer

For devices with a BCM4301 chip or the BCM4306 revision 2 chip, install:
apt-get install firmware-b43legacy-installer

Also don't forget to check via the rfkill list command to see if the actual hardware/software switches are turned off or on

root@masterdebian:/etc/NetworkManager# rfkill list
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
7: phy7: Wireless LAN
Soft blocked: no
Hard blocked: no

The below are the options available for the rfill command:

root@masterdebian:/etc/NetworkManager# rfkill --help
Usage: rfkill [options] command
Options:
--version show version (0.5-1 (Debian))
Commands:
help
event
list [IDENTIFIER]
block IDENTIFIER
unblock IDENTIFIER
where IDENTIFIER is the index no. of an rfkill switch or one of:
<idx> all wifi wlan bluetooth uwb ultrawideband wimax wwan gps fm nfc
 
1 members found this post helpful.
  


Reply

Tags
debian jessie, kernel, wifi, wlan0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After new installation of debian jessie prudra General 5 03-22-2016 07:34 AM
Debian Jessie Wireless Access Point - lost static address for wlan0 propofol Linux - Networking 0 02-10-2016 08:44 AM
Which kernel should i select for debian jessie installation sigint-ninja Debian 4 10-16-2015 11:47 AM
LXer: RoundCube installation on Debian 8 (Jessie) LXer Syndicated Linux News 0 09-22-2015 04:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration