LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2011, 02:19 PM   #1
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Rep: Reputation: Disabled
No Wifi running linux mint, and ubuntu 11.04 natty narwhal on ibm 2373


It's the chinese version, lenova I think. I get some action in my library, it recognizes the bpl link, but says disconnecdted. I don't mind reinstalling or what have you but it's driving me batty. I'm a writer, I've searched for answers on the net and the guys seem to be speaking anothe rlanguage. Me, I want to hit a button and have my problems solved. Any suggestions.
Thanks.
Arvediu
 
Old 11-05-2011, 01:19 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi leralongine, welcome to LQ. Please open a terminal issue the following commands and post the results here.

Code:
$ sudo lspci -v | grep -i net
$ sudo lsmod
$ sudo ifconfig -a
$ sudo iwconfig
Good luck. ;-)
 
Old 11-08-2011, 10:08 AM   #3
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
Window Results

Thanks for getting back to me. Here's what I printed. Sorry it moved about about tab wise.
Part one
arvediu@arvediu-ThinkPad-T40:~$ sudo lspci -v | grep -i net
[sudo] password for arvediu:
02:01.0 Ethernet controller: Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet Wireless 802.11b
Subsystem: AIRONET Wireless Communications Device 5000
arvediu@arvediu-ThinkPad-T40:~$ sudo lsmod
Module Size Used by
nls_iso8859_1 12617 1
nls_cp437 12751 1
vfat 17335 1
fat 55505 1 vfat
snd_intel8x0 33213 2
radeon 896428 2
snd_ac97_codec 105614 1 snd_intel8x0
ac97_bus 12642 1 snd_ac97_codec
snd_pcm 80244 2 snd_intel8x0,snd_ac97_codec
pcmcia 39671 0
thinkpad_acpi 73750 0
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
ttm 65184 1 radeon
snd_seq_midi_event 14475 1 snd_seq_midi
drm_kms_helper 40745 1 radeon
cryptd 19801 0
aes_i586 16956 1
aes_generic 38023 1 aes_i586
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
binfmt_misc 13213 1
joydev 17322 0
drm 180037 4 radeon,ttm,drm_kms_helper
nsc_ircc 23199 0
ppdev 12849 0
snd_timer 28659 2 snd_pcm,snd_seq
yenta_socket 27230 0
irda 185091 1 nsc_ircc
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
pcmcia_rsrc 18292 1 yenta_socket
parport_pc 32111 1
airo 73165 0
snd 55295 12 snd_intel8x0,snd_ac97_codec,snd_pcm,thinkpad_acpi,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
pcmcia_core 21505 3 pcmcia,yenta_socket,pcmcia_rsrc
video 18951 0
psmouse 73312 0
nvram 14035 1 thinkpad_acpi
i2c_algo_bit 13184 1 radeon
crc_ccitt 12595 1 irda
soundcore 12600 1 snd
serio_raw 12990 0
shpchp 32345 0
snd_page_alloc 14073 2 snd_intel8x0,snd_pcm
lp 13349 0
parport 36746 3 ppdev,parport_pc,lp
usbhid 41704 0
hid 77084 1 usbhid
usb_storage 43946 1
e1000 101089 0
uas 17676 0
floppy 60032 0
arvediu@arvediu-ThinkPad-T40:~$ sudo ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0d:60:39:d7:63
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

---------- Post added 11-08-11 at 10:08 AM ----------

part two

eth1 Link encap:Ethernet HWaddr 00:02:8a:ef:48:31
inet6 addr: fe80::202:8aff:feef:4831/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:470 dropped:0 overruns:0 frame:470
TX packets:21 errors:16 dropped:0 overruns:0 carrier:0
collisions:38 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:5458 (5.4 KB)
Interrupt:11 Base address:0x8000

irda0 Link encap:IrLAP HWaddr 00:00:00:00
NOARP MTU:2048 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:8
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:36 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2712 (2.7 KB) TX bytes:2712 (2.7 KB)

wifi0 Link encap:UNSPEC HWaddr 00-02-8A-EF-48-31-30-30-00-00-00-00-00-00-00-00
BROADCAST MULTICAST MTU:2312 Metric:1
RX packets:0 errors:470 dropped:0 overruns:0 frame:470
TX packets:21 errors:16 dropped:0 overruns:0 carrier:0
collisions:38 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:5458 (5.4 KB)
Interrupt:11 Base address:0x8000

---------- Post added 11-08-11 at 10:09 AM ----------

Part three
 
Old 11-08-2011, 10:09 AM   #4
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
sorry,Part three
arvediu@arvediu-ThinkPad-T40:~$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

eth1 IEEE 802.11-DS ESSID:""
Mode:Managed Frequency:2.452 GHz Access Point: Invalid
Bit Rate:11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=5/100 Signal level=-91 dBm Noise level=-101 dBm
Rx invalid nwid:1979 Rx invalid crypt:48 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:24417 Missed beacon:0
 
Old 11-08-2011, 10:09 AM   #5
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
Part four


wifi0 IEEE 802.11-DS ESSID:""
Mode:Managed Frequency:2.452 GHz Access Point: Invalid
Bit Rate:11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=5/100 Signal level=-91 dBm Noise level=-101 dBm
Rx invalid nwid:1979 Rx invalid crypt:48 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:24417 Missed beacon:0

arvediu@arvediu-ThinkPad-T40:~$
 
Old 11-09-2011, 10:23 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Do you have a usb wireless device in this machine as well as the onboard card? Please post the result of the following.

Code:
$ sudo lsusb
Good luck. ;-)
 
Old 11-12-2011, 01:41 PM   #7
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
USB Wireless devices

It was a gift, used but I've only had it a few months. I'm pretty sure it just has a cisco wireless modem. It recognizes the network, I gert the Brooklyn Public Library stuff and all but it doesn't connect. Thanks.
 
Old 11-12-2011, 02:31 PM   #8
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Could we see the result of the following please?

Code:
$ uname -r
Good luck. ;-)
 
Old 11-12-2011, 03:57 PM   #9
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Could you also post the results of the following?

Code:
$ dmesg | grep eth1
$ dmesg | grep wifi0
Good luck. ;-)
 
Old 11-13-2011, 01:39 PM   #10
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
Will Do. I'll post the results Monday morning. THanks for all your help so far!
 
Old 11-13-2011, 04:25 PM   #11
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 375

Rep: Reputation: 77
Quote:
eth1 Link encap:Ethernet HWaddr 00:02:8a:ef:48:31
inet6 addr: fe80::202:8aff:feef:4831/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:470 dropped:0 overruns:0 frame:470
TX packets:21 errors:16 dropped:0 overruns:0 carrier:0
collisions:38 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:5458 (5.4 KB)
Interrupt:11 Base address:0x8000

irda0 Link encap:IrLAP HWaddr 00:00:00:00
NOARP MTU:2048 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:8
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:36 errors:0 dropped:0 overruns:0 frame:0
TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2712 (2.7 KB) TX bytes:2712 (2.7 KB)

wifi0 Link encap:UNSPEC HWaddr 00-02-8A-EF-48-31-30-30-00-00-00-00-00-00-00-00
BROADCAST MULTICAST MTU:2312 Metric:1
RX packets:0 errors:470 dropped:0 overruns:0 frame:470
TX packets:21 errors:16 dropped:0 overruns:0 carrier:0
collisions:38 txqueuelen:100
RX bytes:0 (0.0 B) TX bytes:5458 (5.4 KB)
Interrupt:11 Base address:0x8000
There are two entries in /etc/network/interfaces file for the same device, I'm guessing the /etc/network/interfaces file needs to be edited to remove one of the two and possibly add network information for successful hookup as the information required is not in there as pointed out in the next quote.
Quote:
eth1 IEEE 802.11-DS ESSID:""
Mode:Managed Frequency:2.452 GHz Access Point: Invalid
Bit Rate:11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=5/100 Signal level=-91 dBm Noise level=-101 dBm
Rx invalid nwid:1979 Rx invalid crypt:48 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:24417 Missed beacon:0
Try commenting out wifi0 section of /etc/network/interfaces file as shown in example below, then try to connect to network via the network icon near the clock in upper right of Ubuntu desktop and enter proper information. If you still don't connect and the proper information is not in the eth1 section of /etc/network/interfaces file, try editing it manually. Google key words "interfaces wireless Ubuntu" for links with advice on how it should look.
Code:
# iface wifi0 inet static
#     address 192.168.0.42
#     network 192.168.0.0
#     netmask 255.255.255.0
#     broadcast 192.168.0.255
#     gateway 192.168.0.1

Last edited by Brains; 11-13-2011 at 04:58 PM. Reason: added some
 
Old 11-14-2011, 10:08 AM   #12
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
replay to peacdog (ps I'll try Brains advice as well)

uname r

and post this


$ dmesg | grep eth1
$

here's what I got.
Thanks again.
arvediu@arvediu-ThinkPad-T40:~$ uname r
uname: extra operand `r' (Tried it another wway and got something like r not installed.
Try `uname --help' for more information.
arvediu@arvediu-ThinkPad-T40:~$ dmesg | grep eth1
[ 20.424681] airo(eth1): Firmware version 5.60.21
[ 20.424685] airo(eth1): WPA supported.
[ 20.424689] airo(eth1): MAC enabled 00:02:8a:ef:48:31
[ 31.504029] eth1: no IPv6 routers present
[ 123.961645] airo(eth1): link lost (local choice)
arvediu@arvediu-ThinkPad-T40:~$ dmesg | grep wifi0
arvediu@arvediu-ThinkPad-T40:~$
 
Old 11-14-2011, 07:51 PM   #13
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Just copy and paste the following into your terminal.

Code:
uname -r
Good luck. ;-)
 
Old 11-15-2011, 09:23 AM   #14
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
Wifi help.

Thanks will do.
 
Old 11-16-2011, 11:42 AM   #15
leralongine
LQ Newbie
 
Registered: Nov 2011
Posts: 10

Original Poster
Rep: Reputation: Disabled
uname -r

arvediu@arvediu-ThinkPad-T40:~$ uname -r
2.6.38-8-generic


Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless activation issue on FS Li - 2727 running Ubuntu 11.04 Natty Narwhal Scarface758 Linux - Wireless Networking 1 07-26-2011 06:08 AM
LXer: Ubuntu 11.04 (Natty Narwhal) or Linux Mint 11 (Katya)? LXer Syndicated Linux News 0 06-30-2011 10:30 AM
LXer: Resolve slow connexion when using wifi in ubuntu 11.04 Natty Narwhal LXer Syndicated Linux News 0 06-21-2011 08:41 PM
LXer: Natty Ubuntu - Natty Narwhal Inspired Theme for Nokia Smartphones LXer Syndicated Linux News 0 06-10-2011 11:30 AM
LXer: Ubuntu 11.04: Is Natty Narwhal the best Linux desktop ever? LXer Syndicated Linux News 1 05-05-2011 10:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration