-   Linux - Newbie (
-   -   No sound on Ubuntu 10.04 LTS (

methodtwo 07-06-2010 09:58 AM

No sound on Ubuntu 10.04 LTS
I just installed fresh.I was using Ubuntu 9.04 before.The sound worked fine before.In sound preferences the soundcard is listed as ICE1712[envy 24] PCI i/o controller.It's an maudio soundcard.I don't know if Ubuntu "knows" what the soundcard really is, as the drivers were listed as similar names before, in other distros.The output of lsmod suggests that all the right drivers are loaded.There are also the snd and soundcore drivers.So can i assume alsa installed correctly?.The output of dmesg only mentions the driver on one line.Here is the relevent line fron dmesg:

  13.941990]  alloc irq_desc for 17 on node -1
[  13.941995]  alloc kstat_irqs on node -1
[  13.942004] ICE1712 0000:02:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[  13.971901] type=1505 audit(1278424158.173:11):  operation="profile_load" pid=640 name="/usr/bin/evince-thumbnailer"

I've tried messing around in sound preferences.I've tried messing around in alsamixer.I've tried different cable-in-socket combinations.Still no sound on any of the apps i've tried since installing(firefox, totem etc).
I really don't know what to do.
Someone fixed their sound problem by doing:

$rm -r ~/.pulse

could this work for me?.I don't know if i have any pulse audio apps installed.So this probably won't work right?.Do you think it's worth a try?.What else should i do?
Here's the output of aplay -l:


card 0: M2496 [M Audio Audiophile 24/96], device 0: ICE1712 multi [ICE1712 multi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And here's the output of lshw -C multimedia:


      description: Multimedia audio controller
      product: ICE1712 [Envy24] PCI Multi-Channel I/O Controller
      vendor: VIA Technologies Inc.
      physical id: 1
      bus info: pci@0000:02:01.0
      version: 02
      width: 32 bits
      clock: 33MHz
      capabilities: bus_master cap_list
      configuration: driver=ICE1712 latency=32
      resources: irq:17 ioport:c800(size=32) ioport:c400(size=16) ioport:c000(s

Thank you for your time

tredegar 07-06-2010 02:52 PM

I didn't have sound with a fresh install of 10.04 on my (new in 2010) Sony VPCF11C5E laptop until I'd done a bit of searching.

I then installed linux-backports-modules-alsa-kernel-name and rebooted.

Sound worked :)

Maybe this will work for you also.

Mr. Majestic 07-06-2010 03:37 PM

This will address most all sound problems in Ubuntu:

All times are GMT -5. The time now is 06:08 AM.