LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No Sound On My HDTV, But Do Get Video Using ATI Drivers Under KDE (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-on-my-hdtv-but-do-get-video-using-ati-drivers-under-kde-934868/)

Adler 03-16-2012 08:06 PM

No Sound On My HDTV, But Do Get Video Using ATI Drivers Under KDE
 
Hi All,

It has been a while since I been here @ LQ.

What brings me here is I port my PC to a HDTV via HDMI cable. The set up worked perfectly with UBUNTU Lucid Lynx. However, just to up date to a newer Linux distro I installed Linux Mint 12. The drivers ATI drivers provided were not suitable for two reasons. They both distorted my PC display and although I could port my PC to my HDTV, I had no sound. Doing a little Googling I came across a fix - download the latest ATI Driver. This worked for a very short while and I could get both Audio and Video on my HDTV. However, my screen once again became unstable and apps froze.

I have since switched to openSuSE 12.1 using KDE as my Desktop. Again, I can get video on my HDTV, but no sound. Believe me I have been working on this issue for a while.

Any ideas, and thanks in advance for your responses.

bigrigdriver 03-17-2012 05:30 AM

In your situation, porting PC to TV involves two hardware/software issues: video and audio.

You know the video part works, so focus now moves to audio. Opensuse includes an app called hwinfo in it's repository. I don't remember if it's installed by default. If not, you can install it easily.

Once hwinfo is installed, run this command: hwinfo --sound

The executable is not in the user's path, so you need to add it to your path or use the path to the executable: /usr/sbin/hwinfo --sound.

Hwinfo will probe your hardware and identify the sound hardware as well as it is able. It will also tell you which driver is needed, whether or not the driver is loaded, and which command to use to load it if the driver is not active: modprobe <drivername>

If the driver is active, you will probably need to go to your System settings and configure Alsa to use the hardware identified by hwinfo.

Adler 03-17-2012 06:40 AM

bigrigdriver,

Thanks for the reply. I have an amazingly well fresh install of openSuSE 12.1 running, but this sound to HDTV issue is driving me crazy. LOL!

At any rate, I did as you suggested:

jjmacey@linux-hiwe:~> su
Password:
linux-hiwe:/home/jjmacey # hwinfo --sound
23: PCI 14.2: 0403 Audio device
[Created at pci.319]
Unique ID: 5Dex.Jpa__qQ4asA
SysFS ID: /devices/pci0000:00/0000:00:14.2
SysFS BusID: 0000:00:14.2
Hardware Class: sound
Model: "ATI SBx00 Azalia (Intel HDA)"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x4383 "SBx00 Azalia (Intel HDA)"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x30fc
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xd2500000-0xd2503fff (rw,non-prefetchable)
IRQ: 16 (30239 events)
Module Alias: "pci:v00001002d00004383sv0000103Csd000030FCbc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown

32: PCI 105.1: 0403 Audio device
[Created at pci.319]
Unique ID: l4dC.vfAxXUx5zd4
Parent ID: vSkL.QA_hbVWU301
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.1
SysFS BusID: 0000:01:05.1
Hardware Class: sound
Model: "ATI RS780 Azalia controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x960f "RS780 Azalia controller"
SubVendor: pci 0x1002 "ATI Technologies Inc"
SubDevice: pci 0x960f
Driver: "snd_hda_intel"
Driver Modules: "snd_hda_intel"
Memory Range: 0xd2410000-0xd2413fff (rw,non-prefetchable)
IRQ: 19 (60 events)
Module Alias: "pci:v00001002d0000960Fsv00001002sd0000960Fbc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=yes, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)
linux-hiwe:/home/jjmacey #

Thanks again.

Adler 03-18-2012 06:39 AM

BUMP.


All times are GMT -5. The time now is 05:20 AM.