LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No sound in Mint 6 (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-in-mint-6-a-692036/)

lifeafterdeath 12-21-2008 08:16 AM

No sound in Mint 6
 
Hi.

I just installed Linux Mint 6 and the sound isn't working. I had the same problem when I installed Ubuntu 8.04. I resolved it by setting everything to ALSA in the sound preferences. I did the same now. And its not working.
Please Help.

camorri 12-22-2008 05:58 AM

To get sound to work, there are some things to check, and find out.

First of all, is the sound hardware detected by the OS. To find out, from a command prompt, run the command 'lspci' This will produce some output, and tell you the hardware resources connected to the PCI bus. Post the results.

Next, if the hardware shows up, is there an module loaded to support the device? There are two parts to this. Once you know the hardware, then some searching to find the name of the module that will support the hardware. Since you know Alsa will work, and the modules exists, ( it worked in Ubuntu ) then go to the Alsa site, here --> http://www.alsa-project.org/main/index.php/Main_Page check out the hardware you found, find the module name.

To see it the module is loaded, from a command prompt, run the command '/sbin/lsmod |grep snd' This will list all modules with snd in their names. Alsa modules use snd in their names.

Now if the modules are loaded, bring up a mixer, and make sure the sound is not muted, and the volume is turned up. Try a sound test, use the command aplay wavefile, where wave file is the path to the file, and the name of the file.

If the modules are not loaded, read the Alsa pages for your driver module. It will tell you what to load with the root command 'modprobe' ( All commands without quotes ). Once loaded, use the mixer, and test.

Use a .wav file for testing. Linux should play them without any codecs. If you test with; say an .mp3 file, you need the codecs installed to decode .mp3 files.

Another approach, boot the system with the Ubuntu CD, test your sound. When it works, use the commands I stated, to find the hardware, and module names. Then boot to Mint, and verify, or load what is necessary.

Post your questions. Make sure you post the results of lspci and lsmod commands. Remember, we in the community can not see your hardware, and we only know what you post.

adamt222 03-08-2009 04:29 PM

No sound in Mint 6
 
Hi all, hope I'm not too late to the party ;)

Anyway, I recently switched from Xubuntu 8.10 to Mint 6 GNOME and have encountered the same issue of sound not playing.

I followed the advice above in Using the LIVE CD that installed Mint 6 to this computer. With the LIVE CD, the sound worked flawlessly, so I figured it must have been `something` I did in terms of audio settings on the HD-installed version of Mint.

After making sure all the settings matched (from that of LIVE CD sound preferences), I then (after looking almost every place a sound preference COULD be set) Double-clicked on the "speaker" icon on the taskbar.

Sure enough, I noticed that my "Headphone" output was muted. I don't remember doing the mute, but hey, it's possible.

Headphone output is where my sound pipes to my speakers, so un-muting did the trick.

Thanks again for the troubleshooting Advice of the LIVE CD, it sure did save a lot of time in diagnosing things like Pulse or ALSA drivers.

Adam


All times are GMT -5. The time now is 10:06 PM.