LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-19-2015, 12:54 PM   #1
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 251
Blog Entries: 41

Rep: Reputation: 46
No sound in Kodi


I now have everything working just fine, running Mageia 5 on a Dell Inspiron tower (details available). Except.

My sound works. It works when playing my music, it works in Skype...

It does not work in Kodi, which is where I watch my TV. If I can't get this to work, I'm going to be stuck in Windows more of the time.

(unconnected rant: People talk about why The Year of Linux has never materialized. It is because every time you try a distro, you have to find out if you can even install it, and then have to spend weeks talking to other people to get it to work right. You don't have to do that in Windoze or MuckOS. Personal point: I have been trying to find The Perfect Linux For Me since 1998. Closest I have come is Puppy Linux, and that won't fully install for me although it runs great from a disk. Prior to installing Mageia 5, I wanted to try Manjaro, and it wouldn't even install as it refused to recognize my monitor.)
 
Old 07-19-2015, 03:06 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,880

Rep: Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489
Not an expert on Kodi, but usually the system settings can select the audio destination.
 
Old 07-19-2015, 05:58 PM   #3
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,266
Blog Entries: 17

Rep: Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219
zaivala,

Video > Add-ons > click on the Sound icon at the bottom right.

Then click on Volume and/or Volume Amplification. Set the required volume.

Scroll down the Sound options and click on Set as Default.
 
Old 07-19-2015, 06:27 PM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,880

Rep: Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489
Quote:
Originally Posted by beachboy2 View Post
zaivala,

Video > Add-ons > click on the Sound icon at the bottom right.

Then click on Volume and/or Volume Amplification. Set the required volume.

Scroll down the Sound options and click on Set as Default.
Been there done that... and it doesn't work if the wrong output audio device is selected. That was why I referenced the "settings".

USUALLY there would be only one entry in the available list. But even on the Raspberry PI there are three: hdmi, alsa, and a bcm(some number I don't remember).

The default was hdmi... guess what? no sound. Setting the volume level didn't work...

Selecting analog in the system settings did.

What is available depends on the host operating system.
 
Old 07-20-2015, 12:58 PM   #5
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 251

Original Poster
Blog Entries: 41

Rep: Reputation: 46
Well, today my sound doesn't work in Facebook either. I'm fed up.
 
Old 07-21-2015, 03:52 AM   #6
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,266
Blog Entries: 17

Rep: Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219
jpollard,

All I can say is that the sound worked in Kodi on my Raspberry Pi using Raspbian.

I use an hdmi cable and I did not even need to visit settings.
 
Old 07-21-2015, 05:49 AM   #7
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,880

Rep: Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489Reputation: 1489
Quote:
Originally Posted by beachboy2 View Post
jpollard,

All I can say is that the sound worked in Kodi on my Raspberry Pi using Raspbian.

I use an hdmi cable and I did not even need to visit settings.
HDMI is the default... And it would have worked for me if I had a TV that supported HDMI.

As it is, I have a monitor, no audio, no hdmi - but it did have a DVI, and an HDMI to DVI cable worked for the video.

But no sound. I had to use the analog/composit output for that. But since it wasn't the default, it "didn't work" until I selected it.
 
Old 08-08-2015, 12:32 AM   #8
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 251

Original Poster
Blog Entries: 41

Rep: Reputation: 46
Solved it the hard way. Using LinuxMint 17.1 instead of Mageia. Have everything working, no issues.
 
Old 08-08-2015, 03:23 AM   #9
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,266
Blog Entries: 17

Rep: Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219
zaivala,

That is good news.

At the top of your original post, click on Thread Tools and then select "Mark this thread as solved".
 
Old 08-08-2015, 07:35 PM   #10
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 251

Original Poster
Blog Entries: 41

Rep: Reputation: 46
Quote:
Originally Posted by beachboy2 View Post
zaivala,

That is good news.

At the top of your original post, click on Thread Tools and then select "Mark this thread as solved".
OK, I did that. Although it really is not solved, merely circumvented. Just because I don't have the problem any more doesn't mean others don't want to know how to fix it if they run into the same problem.
 
Old 08-09-2015, 04:44 AM   #11
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 20 MATE, MX-19.3, antiX, EndeavourOS
Posts: 3,266
Blog Entries: 17

Rep: Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219Reputation: 1219
zaivala,

Quote:
Just because I don't have the problem any more doesn't mean others don't want to know how to fix it if they run into the same problem.
That is the whole point of the LQ forums.

Your thread and thousands of other "solved" ones are effectively archived for future searches by other users with a particular problem.
 
Old 08-09-2015, 05:18 PM   #12
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.3, Bodhi 5, OpenMandriva Lx 4.1, Manjaro Cinnam,on 2020, others
Posts: 251

Original Poster
Blog Entries: 41

Rep: Reputation: 46
Quote:
Originally Posted by beachboy2 View Post
zaivala,



That is the whole point of the LQ forums.

Your thread and thousands of other "solved" ones are effectively archived for future searches by other users with a particular problem.
In which case, this should not be marked as "solved", as the problem was not solved. Someone will surf in here and see, oh gee, all I have to do is change distros... that's not a fix...
 
Old 10-10-2015, 09:41 AM   #13
Omaj
LQ Newbie
 
Registered: Oct 2015
Location: Czech Republic
Distribution: Mageia
Posts: 1

Rep: Reputation: Disabled
You must allow tainted repos in 'Configure media sources for install and update' in 'Mageia Control Center' and then install these additional packages to your computer. When you allow these tainted repos, you should see in rpmdrake packages with *.tainted under codecs you have installed etc... You can also see different color of arrow in status bar. Sounds in Kodi didn't work for me, but after this step I made by pure coincidence, it works. It also solved my problem with sound in aegisub. It didn't normally loaded a sound track, when you tried, there was an error or the whole program dropped. Now it works. Hope I helped.
 
  


Reply

Tags
kodi, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Kodi 15.0 RC2 released LXer Syndicated Linux News 0 07-12-2015 10:00 AM
LXer: RC 1 released of Kodi 15.0 LXer Syndicated Linux News 0 07-04-2015 02:03 AM
LXer: Kodi 15.0 Isengard Beta 1 LXer Syndicated Linux News 0 05-02-2015 02:15 PM
LXer: Getting Started With KODI(XBMC) LXer Syndicated Linux News 0 12-16-2014 12:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration