LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2020, 03:14 AM   #16
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184

Quote:
Originally Posted by Alok Rai View Post
Mute: no
that line means that your sink is not muted. if it were, it would say "Mute: yes". i just did that to mine to test it to make sure. that is confirmed by the pacmd line that says "muted: no".

about the last thing i can think of that can be checked might be to try pactl list sources | grep -iE 'volume|mute'.
 
Old 06-29-2020, 04:19 AM   #17
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
Ref: Cordx - And this is the output I got:

Command 'mute' not found, but can be installed with:

sudo apt install aumix-common
 
Old 06-29-2020, 04:27 AM   #18
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
I'm going to point you at this thread describing similar behaviour. In this case it was found that the headphone jack was stuck in a "plugged in" state with the help of the hdajackretask utility.

This post may be of interest as well...
https://forums.linuxmint.com/viewtop...?f=48&t=293910
 
1 members found this post helpful.
Old 06-29-2020, 05:10 AM   #19
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
Quote:
Originally Posted by cordx View Post
Code:
pactl list sources | grep -iE 'volume|mute'
that was the command i was trying to get you to run.


i hope you have been looking at some of the other forum threads people have suggested. everything listed by pactl and pacmd so far shows your software set up recognizing your card and not muted or with the volume set too low so it is beginning to look less and less likely that pactl will increase your volume.
 
Old 06-29-2020, 05:42 AM   #20
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
Thank you, wonderful people!

I tried the hdajackretask to the best of my ability - and on one of the unconnected pins, after the business of checking the override box and selecting the internal speaker, etc - when I ran the small .wav file, it DID produce a little sound - basically, two short mutterings. But this did not translate into the ability to play the music that I was trying to play, alas!
 
Old 06-29-2020, 05:46 AM   #21
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
Thanks, Cordx - here is the output -

$ pactl list sources | grep -iE 'volume|mute
>
> pactl list sources | grep -iE volume|mute
> pactl list sources | grep -iE 'volume|mute

pactl list sources | grep -iE 'volume|mute'

Command 'mute' not found, but can be installed with:

sudo apt install aumix-common

Mute: no
Volume: front-left: 96337 / 147% / 10.04 dB, front-right: 96337 / 147% / 10.04 dB
Base Volume: 65536 / 100% / 0.00 dB
Flags: DECIBEL_VOLUME LATENCY
Mute: yes
Volume: front-left: 2764 / 4% / -82.50 dB, front-right: 2764 / 4% / -82.50 dB
Base Volume: 5206 / 8% / -66.00 dB
Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY
 
Old 06-29-2020, 06:16 AM   #22
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
Am thoroughly confused by now, but I think I was following a lead provided by Ferrari, about using hdajackretask. Anyway, I fiddled around with the unconnected pins, etc

Try overriding 0x17 and set that as LFE

And now I have sound coming from my Internal Speaker LFE! So, success, and many thanks, all.

However, in all that fiddling, I might have done something to the settings, because now there is no sound from my headphones!

Also, the volume from the speaker is rather low. But I might have taxed the patience of my kind correspondents too much already!
 
Old 06-29-2020, 06:16 AM   #23
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Pop!_OS
Posts: 945

Rep: Reputation: 297Reputation: 297Reputation: 297
My laptop has a mute function where I can hit the Fn key and one of the function keys. Check your keys to see if you have a hardware method to mute the sound. It may be a little symbol on the keyboard like a speaker with an x and may even have two more for up/down volume.
 
Old 06-29-2020, 06:17 AM   #24
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
edit: just saw your most recent post. congrats on getting it working

Last edited by cordx; 06-29-2020 at 06:19 AM.
 
Old 06-29-2020, 06:20 AM   #25
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
Quote:
Originally Posted by Alok Rai View Post
However, in all that fiddling, I might have done something to the settings, because now there is no sound from my headphones!

Also, the volume from the speaker is rather low. But I might have taxed the patience of my kind correspondents too much already!
can you switch between the two or raise the volume with pavucontrol?
 
Old 06-29-2020, 06:28 AM   #26
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
The volume seems to have improved - though I would welcome suggestions as to how it might be increased further.

But, with alsamixer, I have been able to restore the headphones as well!

Thank you all, very very much!

AR
 
1 members found this post helpful.
Old 06-29-2020, 06:37 AM   #27
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
That reads like progress. Late here in NZ. I’ll check back here tomorrow.
 
1 members found this post helpful.
Old 06-29-2020, 06:45 AM   #28
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.1.0
Posts: 797

Rep: Reputation: 184Reputation: 184
Quote:
Originally Posted by Alok Rai View Post
Volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
Base Volume: 65536 / 100% / 0.00 dB
according to that your volume is already at 100%. you could check again with
Code:
pactl list sinks | grep -i volume
it is possible to raise the volume above 100% with either pavucontrol or pactl, but it doesn't seem like that would be good for your system in the long term.
 
Old 06-29-2020, 08:47 AM   #29
Alok Rai
Member
 
Registered: Aug 2015
Posts: 247

Original Poster
Rep: Reputation: Disabled
Yeah, volume's at 100% already. One possible reason for it feeling inadequate might well be my own loss of hearing! Hardware, I suppose - and no replacements possible, either!

Still, thanks!

AR
 
Old 06-29-2020, 02:30 PM   #30
ferrari
LQ Guru
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 5,864

Rep: Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152Reputation: 1152
Perceived sound can be so subjective. If you can, try comparing against another laptop model, and/or with another listener to judge the levels against. There may still need to be some further adjustments, or it may simply a limitation of this device.

Try this test with "human speech" for appraisal...
Code:
speaker-test -Dplug:front -c2 -l5 -twav
If that fails try this instead...
Code:
speaker-test -c2 -l5 -twav
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] bluetooth dongle + bluetooth speaker but no sound on the bluetooth speaker vonbiber Slackware 4 05-11-2017 09:53 AM
Slackware sound problems- only getting sound through my pc speaker patrick23220 Slackware 3 01-11-2011 04:18 PM
How could I make USB speaker as default/master speaker ? czy11421 Linux - Hardware 1 09-02-2007 10:59 AM
CD PLAYER SOUND CARD LINE-IN, then output sound to speaker out of compuer scrollups Linux - Hardware 2 06-07-2006 10:29 PM
Left speaker does not speak - not speaker issue. Hardware or software issue? Svip Linux - Hardware 3 05-03-2006 11:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration