LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2004, 03:02 PM   #1
scarabs
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Rep: Reputation: 0
Question no sound from cd player


HI I finally got my sound to work in redhat 9. I had to install ALSA. I have sound but only for .wave files. I cant play a cd in my cd-rom. I put it in and the cd player pops up but no sound. How do I correct this. I am a complete newbie so I will need detailed directions. Can anybody help me?

Also no sound when I play games.!!!!

Last edited by scarabs; 03-25-2004 at 03:04 PM.
 
Old 03-25-2004, 03:06 PM   #2
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Do you have more than one CD/DVD-ROM drive? If so then try the other one. If that works than you need to either (a) open your case and switch which drive the audio cable (thin, round gray cord) is attached to or (b) change which drive the CD player app your using looks for. (b) is probably a lot easier.
 
Old 03-25-2004, 03:42 PM   #3
scarabs
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I do have two cd-roms but neither work in redhat 9 but they both work in windows. any more suggestions
 
Old 03-25-2004, 04:07 PM   #4
pingswept
Member
 
Registered: May 2003
Location: Cambridge, MA
Distribution: SuSE, RedHat, and OpenBSD
Posts: 116

Rep: Reputation: 15
Are you talking about playing audio CDs, like you buy in a store? Those get played through the thin, 4 wire cable (not the wide ribbon cable) coming out of the back of your drive. If that cable is not plugged into your sound card, audio CDs won't play, but data CDs will.

Is the cable plugged in?
 
Old 03-25-2004, 04:09 PM   #5
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
It will work in Windows without the cable, because it reads over the bus and uses CPU. Linux needs the cable.

RO
 
Old 03-25-2004, 04:35 PM   #6
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
ya... do a websearch for "cd audio cable installation" or "installing a cdrom" etc.. plenty of tutorials out on the net...
 
Old 03-25-2004, 04:42 PM   #7
pingswept
Member
 
Registered: May 2003
Location: Cambridge, MA
Distribution: SuSE, RedHat, and OpenBSD
Posts: 116

Rep: Reputation: 15
Oh, man, I bet it's the cable. I just know it. It's the cable.

The cable!

The cable!
 
Old 03-25-2004, 05:28 PM   #8
scarabs
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
I checked the audio cable(the thin grey one) and they check out all is fine with the cable so what else could it be.
 
Old 03-25-2004, 06:06 PM   #9
scarabs
LQ Newbie
 
Registered: Mar 2004
Posts: 19

Original Poster
Rep: Reputation: 0
als when hit soundcard detection test music I get an error telling me the driver couldn't be loaded but then I hear the sample sound clip play so I answer I hear the music. No other errors after that
 
Old 04-06-2004, 10:12 PM   #10
wrAith
LQ Newbie
 
Registered: Mar 2004
Location: nj
Distribution: fedora core
Posts: 9

Rep: Reputation: 0
i hope this helps http://staff.xmms.org/priv/redhat8/
xmms-mpg123-1.2.7-13.i386.rpm
if you use xmms

Last edited by wrAith; 04-06-2004 at 10:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card works but CD player doesn't make a sound? OmnipotentOscar Linux - Newbie 2 02-03-2005 04:42 AM
no sound from cd player, good sound from audio device test fmickel Linux - Hardware 5 06-04-2004 01:46 PM
Xandros delux 2.0 When I try to run Sound server Control ,Media Player & Sound Record Jesta Linux - Distributions 0 05-15-2004 10:35 PM
How come dvd player sound works but cd player doesn't? Magus67 Linux - Hardware 9 04-19-2004 05:31 PM
Ensoniq 5880 Audio PCI test sound okay but no Sound from CD Player ashok17 Linux - Hardware 0 10-04-2003 11:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration