LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   no sound from ADI SoundMax (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-from-adi-soundmax-32203/)

newbix 10-07-2002 10:45 PM

no sound from ADI SoundMax
 
I'm trying to get the sound card working on my Gateway 500S. I'm not at all sure what the chipset for a SoundMax card is, but by digging around the Gateway support web site, I think I've figured out it's ADI 1885 (I could be completely wrong about this). I tried installing the alsa driver from www.alsa-project.org, and I ran into a couple of problems. Following their directions, the first problem I ran into was that there was no /dev/midi on my machine, so I couldn't "chmod a+rw /dev/midi" as they instruct. The next problem was when I tried to "modprobe snd-": I then get the message:

modprobe: Can't locate module snd-

To make things even more confusing, if I run sndconfig, it says:

A PCI sound card was found in your system. The details are:
Model: Intel Corp.|unknown device 8086:24c5

Then it says that device is not supported, and that's pretty much the end of that.

Is there any way to get my sound card working? Have I misidentified the chipset and is it the case that there really isn't a driver out there for it?

Help! (and thanks in advance):eek:

newbix 10-26-2002 10:44 PM

solution found
 
I've figured out a few things since my original post, and for the benefit of anyone else out there who runs into the same problem, here's my solution.

First I've sorted out some of my own confusion. The sound chip in my case is not on a separate card, but rather it's an integrated chip, part of the intel 845 chipset on the motherboard.

I was finally able to install the ALSA driver for the intel 810 chipset, but it didn't work (I think my original problem with "modprobe snd-" is simply a typo in the installation directions for the ADI 1885, which is not the appropriate chip in my case anyway).

I don't know whether the fact that I couldn't get the ALSA driver for the intel 810 to work is due to my not installing properly, or to the fact that the 810 and 845 chipsets are simply too different to be compatible. However, I was able to purchase a driver from 4front at www.opensound.com which works perfectly. Their test driver can be dowloaded for free and it automagically detects the sound card and installs. Purchasing the permanent license costs a few $, but this is the only way I've been able to get sound under linux. ;)

I hope someone out there finds this useful :)

newbix 10-26-2003 06:29 PM

Update
 
Hi everyone,

Since this post seems to be getting a lot of views, I thought I should post an update. I recently upgraded to redhat 9, and the chipset is correctly recognized and the sound works fine, without having to pay extra for a driver. I know this isn't helpful if you're using 7.3, but if you were considering upgrading anyway, this might be useful information.

Cheers.


All times are GMT -5. The time now is 10:25 AM.