LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No sound, dummy output in Ubuntu / Lubuntu 14.04 (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-dummy-output-in-ubuntu-lubuntu-14-04-a-4175523450/)

Pingu4 10-27-2014 05:29 AM

No sound, dummy output in Ubuntu / Lubuntu 14.04
 
Hi all

I've got and old emachines PC with Ubuntu 12.04 installed on it. I've tried the new Lubuntu 14.04 and loved it - everything works fine apart from the fact that there's complete lack of sound. The same was true for Ubuntu 14.04.

My PC's specs:
Emachines 5250
160 GB
originally 512MB
Intel pentium 4
sound card Realtek Intel ALC 880

I've tried all the suggestions I could find on the web, nothing works. First I just had a Dummy Output, then manged to get it fixed to Analog stereo output. My sound card is sometimes seen by the system, sometimes not.

I've tried re-installing pulseaudio and alsa several times - nothing.
I've tried to do modprobe commands but all I get in return is: Permission denied.

What am doing wrong? Any suggestions?

ondoho 10-27-2014 03:28 PM

try the modprobe commands with "sudo " in front of them.

if it still doesn't work, post exactly what you tried, based on what assumption/blog/wiki/howto, and what kind of error message you got.

floppy_stuttgart 10-27-2014 04:40 PM

Quote:

Originally Posted by Pingu4 (Post 5260171)
Emachines 5250
160 GB
originally 512MB
Intel pentium 4
sound card Realtek Intel ALC 880

I would give a try to "Antix" and/or "crunchbang".
Ubuntu is too heavy for your machine?

from here... http://askubuntu.com/questions/46265...realtek-alc880 ...?
Quote:

download the driver from the RealTek site and compile it yourself.

RealTek Driver Page, Pick the 3.0 driver The Rest of this is taken from here and posted to askubuntu.

Open terminal.

Type: "sudo su" and enter root password.

Change to the folder where you downloaded the driver (ie: "cd ~/Downloads")

Type: "tar -xjf LinuxPkg_XXX.tar.bz2" , where XXX is the version of your downloaded driver (as sown in filename, example: "tar -xjf LinuxPkg_5.17rc13.tar.bz2").

Type: "cd realtek-linux-audiopack-YYY" , where YYY is the version of your downloaded driver (as shown if folder name, example: "cd realtek-linux-audiopack-5.17").

Type "tar -xjf alsa-driver-ZZZ.tar.bz2" , where ZZZ is the version corresponding to the filename (example: "tar -xjf alsa-driver-1.0.25-5.17rc13.tar.bz2").

Type "cd alsa-driver-WWW" , where WWW is the version corresponding to the folder name (example: "cd alsa-driver-1.0.25").

Type "./configure --with-cards=hda-intel"

Type "make"

Type "make install"

Reboot

Test the audio output. You can do this by right-clicking on you speaker icon and selecting sound preferences -> hardware -> select the desired audio output -> select the desired surround profile (ie: Analog Surround 5.1 Output + Analog Stereo Input) -> Test Speakers. During the installation the sound level can be mutted, check out in the slider if it is not mute!

Fred Caro 10-27-2014 10:01 PM

It sounds like you don't have the right driver/firmware. You could look on 'synaptic package manager' for the chip in your sound card. If synaptic is not installed on your system by default "sudo apt-get install synaptic" (without quotes should do it) and in 'quick search' look for the name of the chip in your sound card or info given under the listing given by the cmd in a terminal for lspci, look for "sound".
Alternatively "apt-cache search "blar" being the name of the chip or some id specific to that card.

Fred.

Pingu4 10-30-2014 06:33 AM

Thank you very much for your replies.

To ondoho:
I've tried 'modprobe commands with sudo but still I get 'permission denied'.

To floppy_stuttgart:
Ubuntu 12.04 works on my PC with no problems, but I just like the feel of Lubuntu. On Ubuntu 14.04 there's no sound.

I've already tried to follow the exact thread (download from Realtek) you suggested, but can't find the right driver for my card.

To Fred Caro:
I've got synaptic installed, I'll try to find the chip in my sound card. Thanks a lot.


All times are GMT -5. The time now is 04:30 PM.