LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2017, 11:16 AM   #1
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: EU mainland
Distribution: Debian like
Posts: 908
Blog Entries: 4

Rep: Reputation: 86
No sound Debian8 backports kernel


I have no sound anymore. It was there few weeks before.

By booting my PC with

Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-0.bpo.2-686-pae root=UUID=6d24ff20-a81d-48f1-946d-ec821c40176e ro quiet acpi=off pnpbios=off intel_rng.no_fwh_detect=1 pcie_aspm=off

cat /proc/asound/cards
Code:
cat: /proc/asound/cards: Datei oder Verzeichnis nicht gefunden
= no card seen

lspci | grep -i audio
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
06:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]

So, there is a sound card, but not recognized.

lsmod
Code:
Module                  Size  Used by
nls_utf8               16384  0 
btrfs                1040384  0 
xor                    28672  1 btrfs
raid6_pq              106496  1 btrfs
ufs                    73728  0 
qnx4                   16384  0 
hfsplus                94208  0 
hfs                    53248  0 
minix                  36864  0 
ntfs                   98304  0 
vfat                   20480  0 
msdos                  20480  0 
fat                    57344  2 msdos,vfat
jfs                   172032  0 
xfs                   978944  0 
libcrc32c              16384  1 xfs
crc32c_generic         16384  2 
dm_mod                 94208  0 
nfsd                  282624  2 
auth_rpcgss            53248  1 nfsd
nfs_acl                16384  1 nfsd
nfs                   188416  0 
lockd                  73728  2 nfsd,nfs
grace                  16384  2 nfsd,lockd
fscache                45056  1 nfs
sunrpc                249856  6 auth_rpcgss,nfsd,nfs_acl,lockd,nfs
radeon               1445888  2 
ttm                    77824  1 radeon
drm_kms_helper        114688  1 radeon
iTCO_wdt               16384  0 
iTCO_vendor_support    16384  1 iTCO_wdt
lpc_ich                24576  0 
mfd_core               16384  1 lpc_ich
drm                   253952  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           16384  1 radeon
pcspkr                 16384  0 
evdev                  20480  3 
serio_raw              16384  0 
intel_powerclamp       16384  0 
rng_core               16384  0 
shpchp                 32768  0 
fuse                   90112  3 
parport_pc             28672  0 
ppdev                  20480  0 
lp                     20480  0 
parport                36864  3 lp,parport_pc,ppdev
autofs4                36864  2 
ext4                  503808  2 
crc16                  16384  1 ext4
jbd2                   77824  1 ext4
fscrypto               24576  1 ext4
mbcache                16384  3 ext4
hid_generic            16384  0 
usbhid                 45056  0 
hid                    90112  2 hid_generic,usbhid
sg                     32768  0 
sr_mod                 24576  0 
sd_mod                 40960  4 
cdrom                  49152  1 sr_mod
ata_generic            16384  0 
ata_piix               32768  3 
libata                192512  2 ata_piix,ata_generic
tg3                   155648  0 
ehci_pci               16384  0 
uhci_hcd               40960  0 
ehci_hcd               65536  1 ehci_pci
scsi_mod              180224  4 sd_mod,libata,sr_mod,sg
psmouse               114688  0 
ptp                    20480  1 tg3
pps_core               20480  1 ptp
usbcore               184320  4 usbhid,ehci_hcd,uhci_hcd,ehci_pci
usb_common             16384  1 usbcore
libphy                 36864  1 tg3
It seems that no snd driver is loaded.
Perhaps one of the boot codes in the kernel command messed it up?

Any advice/idea is welcome.
I will further search.
Thanks.
 
Old 05-21-2017, 12:19 PM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
The module you need is snd_intel8x0. You might want to take away pnpbios=off. acpi=off is usually just if you're having problems. You might not need it either.
 
Old 06-10-2017, 05:22 AM   #3
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: EU mainland
Distribution: Debian like
Posts: 908

Original Poster
Blog Entries: 4

Rep: Reputation: 86
I took away all bootparameters (in case one could make the issue). Now:
lspci -nn
Quote:
00:00.0 Host bridge [0600]: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub [8086:2580] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 [8086:2660] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 [8086:2662] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 [8086:2658] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 [8086:2659] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 [8086:265a] (rev 03)
00:1d.3 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 [8086:265b] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller [8086:265c] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev d3)
00:1e.2 Multimedia audio controller [0401]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller [8086:266e] (rev 03)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge [8086:2640] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller [8086:266f] (rev 03)
00:1f.2 IDE interface [0101]: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller [8086:2651] (rev 03)
05:09.0 PCI bridge [0604]: PLX Technology, Inc. PEX8112 x1 Lane PCI Express-to-PCI Bridge [10b5:8112] (rev aa)
06:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] [1002:68f9]
06:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series] [1002:aa68]
40:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express [14e4:1677] (rev 01)
But lsmod still dont show any "snd" sound related modules.
Any advise where to search for installing again the sound is welcome.
 
Old 06-10-2017, 02:12 PM   #4
trumpforprez
Member
 
Registered: Nov 2016
Location: UK
Distribution: Debian Jessie
Posts: 154

Rep: Reputation: Disabled
It could be due to your Radeon HD soundcard.

1. Have you added 'contrib' and 'non-free' to your /etc/apt/sources.list?

2. Have you installed package: 'firmware-linux-nonfree'. This installs the non-free drivers for the soundcard to work.

3. Have you opened alsamixer and selected F6 to see a choice of soundcards?

Incidentally, which specific processor are you using?

Last edited by trumpforprez; 06-10-2017 at 02:13 PM.
 
Old 06-12-2017, 02:03 AM   #5
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by floppy_stuttgart View Post
Any advice/idea is welcome.
Hi...

If you would, please go to this page and follow the instructions there. The results might give us additional information that would help us resolve your issue.

Regards...
 
Old 06-12-2017, 04:30 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ sudo modprobe snd-intel8x0

or

$ sudo modprobe snd-hda-intel

it could just be something in /etc/modprobe.d/ that's blocking it from loading by default. Also check that the modules exist.

$ find /lib/modules/$(uname -r)/ -iname '*snd*ko'
 
Old 06-16-2017, 06:12 AM   #7
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: EU mainland
Distribution: Debian like
Posts: 908

Original Poster
Blog Entries: 4

Rep: Reputation: 86
Thanks.
I cleaned up a bit
a) according #,6 deleted what was blocking from loading (after this, the snd modules are loaded)
b) made an alsa audit; result is in http://www.alsa-project.org/db/?f=3a...ecc2a9b2c2d953
Pulseaudio is not working according the log. Is it perhaps necessary? But a start dont work
Quote:
pulseaudio --start
Quote:
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/family/.config/pulse//daemon.conf': Keine Berechtigung
W: [pulseaudio] daemon-conf.c: Öffnen der Konfigurationsdatei fehlgeschlagen : Keine Berechtigung
in the pulse directory, I could not find any daemon.conf
And the path indicated in the message is a bit weird.
Any advice is welcome.

Last edited by floppy_stuttgart; 06-16-2017 at 06:20 AM.
 
Old 06-16-2017, 10:00 AM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Pulse seems to compensate if you just delete the pre-existing user specific config stuff.

$ pulseuadio --kill
$ rm -rf $HOME/.config/pulse
$ pulseaudio --start

Although --kill wont do much if "autospawn = yes" in /etc/pulse/client.conf. Plus redundant if it never started in the first place. Also if you've done pulse things by accident as root you might need to delete other things.

# rm /.pulse*
# rm /root/.config/pulse
# rm /root/.pulse*

Depending on version of pulse ofc, and with -rf where needed. Symptom's wise it tends to load root pulse things before $HOME pulse things. But technically root pulse things shouldn't exist. There's also /run/ type things that are user specific that might get changed to root owner:group when you biff pulse as root. Just use chown to bring it back into usable form.

$ ls -al /run/user/$(id -u)/pulse*

The owner:group on those files should match the user who started pulseaudio and NOT be root.

In terms of globals:

/etc/pulse/client.conf
/etc/pulse/default.pa
/etc/pulse/daemon.conf

The only ones I've ever had to customize. But in my case to add networked and jackd extras. Plus add complete stoppage of pulse to do special things, or just have the 10% more CPU and RAM perk of NOT using pulseaudio.

Last edited by Shadow_7; 06-16-2017 at 10:02 AM.
 
Old 06-17-2017, 02:19 PM   #9
trumpforprez
Member
 
Registered: Nov 2016
Location: UK
Distribution: Debian Jessie
Posts: 154

Rep: Reputation: Disabled
Quote:
Originally Posted by floppy_stuttgart View Post
Pulseaudio is not working according the log. Is it perhaps necessary?
Are you saying you have installed Pulseaudio but the program is not opening?

It's not
Code:
pulseaudio --start
It is
Code:
pavucontrol
Yeah, I know it's stupid. But welcome to Debian!
Also, your GUI (i.e. your desktop environment) will have Pulseaudio listed. Just click on the Pulseaudio icon on your GUI.

I find it is helpful to install Pulseaudio.
After running the program, select Configuration tab, then on 'Built-in Audio' section change the 'Profile' to a setting which then gives you sound.

My setting is 'Digital Stereo (IEC958) input'.
Obviously, make sure all the other tabs do not have settings where sound is muted.

If people helping you ask you questions, please answer them else it looks like you're dismissing their comment.
Best of luck.
 
Old 06-25-2017, 05:51 AM   #10
floppy_stuttgart
Member
 
Registered: Nov 2010
Location: EU mainland
Distribution: Debian like
Posts: 908

Original Poster
Blog Entries: 4

Rep: Reputation: 86
Quote:
Originally Posted by trumpforprez View Post
Are you saying you have installed Pulseaudio but the program is not opening?

It's not
Code:
pulseaudio --start
It is
Code:
pavucontrol
Yeah, I know it's stupid. But welcome to Debian!
Also, your GUI (i.e. your desktop environment) will have Pulseaudio listed. Just click on the Pulseaudio icon on your GUI.

I find it is helpful to install Pulseaudio.
After running the program, select Configuration tab, then on 'Built-in Audio' section change the 'Profile' to a setting which then gives you sound.
.
I made
apt-get install pulseaudio.
Then
pavucontrol
Quote:
bash: pavucontrol: Kommando nicht gefunden.
= Nothing starts.
No pulseaudio icon can be seen on the GUI.
 
Old 06-25-2017, 12:15 PM   #11
trumpforprez
Member
 
Registered: Nov 2016
Location: UK
Distribution: Debian Jessie
Posts: 154

Rep: Reputation: Disabled
Quote:
Originally Posted by floppy_stuttgart View Post
I made
apt-get install pulseaudio.
Ok, so you did
Code:
apt-get update
apt-get install pulseaudio
1. Was there any error message or was pulseaudio successfully installed?

2. Can you please offer answers to my previous comment on #4?

3. Please consider ardvark71's recommendation on comment #5.

4. If you can't install a program from the Debian repos on your Debian OS, then clearly there is a simple and basic error which needs to be identified. IMO.
 
Old 06-25-2017, 08:32 PM   #12
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
In debian pavucontrol is a separate package from pulseaudio.

$ sudo apt-get install pulseaudio pavucontrol

Assuming that:

bash: pavucontrol: Kommando nicht gefunden.

means something like "command not found" in ?german? ??? I could probably google translate, but I'm lazy.
 
Old 06-25-2017, 09:03 PM   #13
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, EndeavourOS
Posts: 3,661
Blog Entries: 7

Rep: Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297Reputation: 1297
Do you have the sound firmware installed? firmware-intel-sound

https://packages.debian.org/jessie-b...re-intel-sound
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Debian8 kernel 4.9.0-0.bpo.2-amd64 dont make working the RTL8188CE floppy_stuttgart Linux - Wireless Networking 2 05-25-2017 03:19 AM
[SOLVED] stable-backports distribution spec not known to backports.debian.org jhwilliams Debian 7 05-31-2012 05:31 AM
which backports kernel? cccc Debian 1 02-08-2012 12:54 AM
Debian & old pc: Can we PLEASE have a 2.4 series or best 2.4.31 kernel in BACKPORTS? frenchn00b Debian 11 01-06-2010 10:58 AM
problem with dma after installing kernel-2.6-15 from backports mechmg93 Debian 2 04-05-2006 02:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration