LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No sound coming from my Fedora 19 laptop (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-coming-from-my-fedora-19-laptop-4175478156/)

Cabroncito 09-23-2013 02:32 AM

No sound coming from my Fedora 19 laptop
 
Today I went to YouTube for the first time since I installed Fedora 19, and saw that I needed to install a missing Flash plugin in order to watch videos. I installed the plugin. Youtube videos then played fine, except no sound. I checked my sound settings and made sure everything was turned up/on, and tested both the left and right speakers using the troubleshooting tool. No sound from either. I've tried both the 'microphone' and 'internal microphone' options. Point me in the right direction?

jdkaye 09-23-2013 02:37 AM

If I understand you correctly the Youtube business is a red herring. Your problem has nothing to do with the flashplayer plugin. You don't have any sound at all, right? Have you tried running alsamixer from a terminal? You can make sure all the settings for your card are correct. What audio system are you using (alsa? pulse? other?)?
jdk

Cabroncito 09-23-2013 02:48 AM

Right--no sound whatsoever. Now that I re-read my post, it wasn't necessary to include the bit about Flash and youtube at all.

I'll start googling alsamixer, and how to look up the type of audio system. I just needed someone to give me a lead. Thanks.

BTW, love your sig.

jdkaye 09-23-2013 03:20 AM

Glad to be of service and thanks for the kind comment. The alsamixer is found in a package called alsa-utils in Debian. Perhaps its package has a similar name in Fedora.
jdk

Cabroncito 09-24-2013 04:44 AM

Looks like I'm stuck again. I've been using Google for a while, but I can't determine the source of the problem.

Here's the info for my sound card:

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. Device 1297
Flags: bus master, fast devsel, latency 0, IRQ 43
Memory at feb3c000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

I have Alsamixer. When I go into Alsamixer and hit F6 for 'select sound card,' my choices are default, HDA Intel, and 'enter device name.' I've tested the speakers with both default and HDA Intel selected, but I still have no sound. Again, I've made sure all volume controls are turned up.

Also, here's this if it helps:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: AD198x Digital [AD198x Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

jdkaye 09-24-2013 09:43 AM

Can you try this on a terminal
Code:

aplay *some .wav file*
and put the path and name of any .wav file on your system. Maybe an interesting error message will appear. Here's what that looks like on my system--
Code:

:~$ aplay /usr/share/sounds/alsa/Side_Left.wav
Playing WAVE '/usr/share/sounds/alsa/Side_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

and I hear a woman's voice saying "side left".
jdk

Cabroncito 09-24-2013 12:16 PM

I tried that. Here's what I got:

aplay /home/dan/Downloads/hornytoads.wav
Playing WAVE '/home/dan/Downloads/hornytoads.wav' : Unsigned 8 bit, Rate 11000 Hz, Mono

Still no sound. It looks like Linux thinks it's playing the file without problems.

Kuranes 09-24-2013 12:52 PM

Make sure alsamixer levels are not muted, since alsa mutes them by default after installation.
Look for "MM" at the bottom of output channels and press m to toggle it (OO means it's unmuted).

Cabroncito 09-24-2013 01:03 PM

It's working! :D It turned out that I just needed to go into the sound settings and switch from Analog Output/Amplifier to Analog Output/No Amplifier.

jdkaye 09-25-2013 12:58 AM

Well done! Persistence pays off, eh?
jdk

Sumguy 09-25-2013 11:15 AM

Quote:

Originally Posted by Cabroncito (Post 5033971)
It's working! :D It turned out that I just needed to go into the sound settings and switch from Analog Output/Amplifier to Analog Output/No Amplifier.

How does one access those settings? I'm having a similar problem, after having installed a new sound card.....

Kuranes 09-25-2013 02:33 PM

Quote:

Originally Posted by Sumguy (Post 5034630)
How does one access those settings? I'm having a similar problem, after having installed a new sound card.....

If you use pulseaudio, pavucontrol is the "control panel" you might be looking for, where you can select the output (cf. Profiles in the Configuration tab).


All times are GMT -5. The time now is 10:49 AM.