LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No sound at startup (https://www.linuxquestions.org/questions/linux-newbie-8/no-sound-at-startup-286321/)

MegaByll 02-04-2005 05:46 PM

No sound at startup
 
Hi, is there a way to get the sound to load at startup automatically so I don't have to run alsaconf each time I boot up linux? I am not sure if changing modules.conf works, as there is nothing in my modules.conf, and the alsa group said that it was a depracated file. If that is the solution, could you tell me what I need to add in? Thanks!

Peacedog 02-04-2005 05:50 PM

After running alsaconf, and alsamixer, run aslactl store. That should save your settings across a reboot.
good luck.

MegaByll 02-04-2005 07:33 PM

I tried that already, and alas, nothing!

Anyone else have a solution?

MegaByll 02-06-2005 04:06 PM

Come on people, I need help with this. No posts in a couple days now. Come on help me out here.

Linux~Powered 02-06-2005 04:18 PM

Quote:

After running alsaconf, and alsamixer, run aslactl store. That should save your settings across a reboot.
good luck.
That's how you do it. run alsamixer. Make your adjustments. Then as root run...

Code:

alsactl store

Brian1 02-06-2005 04:38 PM

There is several ways that this can be done. Create a file either as etc/aumixrc or in your own home directory. Change settings if to low or loud. There are serveral other paramaters that can be here like pcm, bass, etc. read man pages on aumix for more help.

Contents of /etc/aumixrc.
Code:

vol:60:60
Then edit your /etc/rc.local file and add this to it
Code:

bin/aumix-minimal -f /etc/aumixrc -L
Or start it in your /etc/modprobe.conf file. Example below. You may have something close to this.
Code:

> post-install sound-slot-0 /bin/aumix-minimal -f /etc/aumixrc -L
>> /dev/null 2>&1 || :
> pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/aumixrc -S
>> /dev/null 2>&1 || :

Brian1
" Google the Linux way @ http://www.google.com/linux "

Brian1 02-06-2005 04:42 PM

Quick thought if you have ' xaumix ' then that can save and load settings as well. Don't know how well it works. I use scripts to set volumes like above.

Brian1
" Google the Linux way @ http://www.google.com/linux "

Peacedog 02-06-2005 06:21 PM

Quote:

I tried that already, and alas, nothing!

Anyone else have a solution?
Try this after a reboot, run as root or su -

alsactl restore

if that works add the command to your startup scripts.
good luck.

fuzzyworm 03-01-2005 07:08 PM

I have the same problem
 
At the moment, I am having the same problem. All was well for a while, and then it started. I am not sure when or how, because I didn't notice it at first. The problem is NOT with the mixer, which is what gets stored and restored using alsactl store / restore. The problem is in the actual configuration of alsa. I suspect that it is a bug, either in alsa itself, or in one of the drivers.

The symptons are:
* /dev/dsp is not recognised as a device
* running /etc/init.d/alsa start produces an error message saying:
"no state present for card ..." (in my case bt878)
*KDE can't find device (see first point)

Running alsaconf fixes this, it does something which forces alsa to detect the card. If anyone is familiar with the innermost workings of alsaconf, and can think of some way of automating it, this would work, at least as a temporary fix, by adding it to /etc/init.d/alsa before the bit which runs alsactl.

Any help you can offer would be great, and I hope that this information helps to clarify the problem we are having. I don't think dmesg etc. would be much use, but let me know if you want it, I just didn't want to clutter the page too much.

Peacedog 03-02-2005 08:02 AM

What card, and alsa version are you using?
good luck.

fuzzyworm 03-02-2005 11:42 AM

I am using a Via onboard sound card, I'm not sure of the model no, I think it's 82 something, but as I said, I've had it working before, I went throuogh the steps in one of the other threads to set it up in the first place, which involved blacklisting certain stuff.

As for the version of alsa, I am running 1.0.8 at the moment.

Thanks for any help anyone can offer.

[edit]:
Ok, I just had a closer look at dmesg:
* My sound card is via 8233
* It's having a failure when it loads:

VIA 82xx Audio: probe of 0000:00:11.5 failed with error -12
via-rhine.c:v1.10-LK1.1.20-2.6 May-23-2004 Written by Donald Becker

* Also, I think that the bt878 I mentioned before might be my DVB TV card, why would alsa suddenly start trying to interface with this?

Help :(

Peacedog 03-02-2005 05:21 PM

Please post the output from lspci -v, and lsmod.
good luck.

fuzzyworm 03-02-2005 06:08 PM

I didn't want to clutter the thread, so it can be found at:
lsmod
lspci -v

Thanks for your time

Peacedog 03-02-2005 06:14 PM

This may be the root of your problem.

Quote:

via82cxxx 12956 1
It looks like your system may have loaded the alsa modules and the oss module. Try blacklisting the above module.
good luck.

fuzzyworm 03-03-2005 03:18 PM

Ok, I tried what you said, but it didn't work, thanks for trying. That module has been loading, even when the sound was working, so I don't think it was that. As I said, I did have teething problems with the sound, (here's what I did) but these were resolved. I believe that the problem lies somewhere in an alsa configuration file, since it tries at startup to use bt878, which I think is something to do with my TV card. If anyone knows how to automate the steps in alsaconf, so I can make a startup script, this would suffice, at least as a temporary fix.

Thanks in advance


All times are GMT -5. The time now is 12:28 PM.