LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No Slax-install in KDE home (https://www.linuxquestions.org/questions/linux-newbie-8/no-slax-install-in-kde-home-635590/)

trebek 04-15-2008 06:23 PM

No Slax-install in KDE home
 
Hi there.

I just downloaded Slax and i want to install it to the hard drive for testing. My flash drive has just been shipped to me and i want to use it for a while before it gets here.

Problem here is that i don't see the Slax-install icon in the KDE home folder where the manual says it should be. Why don't i have that installer icon? I booted from the cd, and i selected the first option in the menu when selecting how to boot, that is, the part with KDE.

How can i install Slax if i don't have the installer icon?

Thanks for the help in advance.

Peacedog 04-16-2008 10:42 PM

Hi trebek, There is a fairly extensive thread here discussing different install options. Hope something there helps.
Good luck. ;-)

trebek 04-16-2008 11:11 PM

That was a hell of a reading i just did. But unfortunately, my issue is not here. I will try a couple of more options that i read there, to see if it's no necessary to have the Slax-install file, just like the Slax manual says in it's site.

Thanks, i'll post back with the results of my quest.

trebek 04-17-2008 12:06 AM

Hi there, update on the install process.

I read the entire link there you wrote, for that, thanks a lot. So, i found out that it's not necessary to have the Slax-install, but, i ran into a little problem when attempting the alternate install method.

I followed these simple steps:
1. Run Slax from the SlaxCD
2. mounted both my cdrom and the hard drive.
3. cp cdrom to the hard drive
4. ran boot/bootinst.sh

Now, i got almost there, the installer started, but i got the following error:

Code:

Flushing filesystem buffers, this may take a while...
Setting up MBR on /dev/hda...
The Master Boot Record of  /dev/hda  has been updated.
Activating partition /dev/hda2...
No partition table modifications are needed.
Updating MBR on /dev/hda...
Setting up boot record for /dev/hda2...
/dev/hda2: this doesn't look like a valid FAT filesystem
root@slax:/hdadrive/boot#

What is going on? Is it not possible to install Slax on a ext3 or reiserfs? I ask because i used to have Debian installed there on that drive. I know there is a swap partition, and 2 partitions, either formatted as ext3 or reiserfs. Am i missing something?

Peacedog 04-17-2008 08:00 AM

Quote:

What is going on? Is it not possible to install Slax on a ext3 or reiserfs? I ask because i used to have Debian installed there on that drive. I know there is a swap partition, and 2 partitions, either formatted as ext3 or reiserfs. Am i missing something?
It appears that particular install script requires a fat partition. IIRC, there is another install script posted in that thread that was inadvertently left out of version 6. I'd download that script and give it a try.
Good luck. ;-)

trebek 04-17-2008 09:28 PM

Quote:

Originally Posted by Peacedog (Post 3124061)
It appears that particular install script requires a fat partition. IIRC, there is another install script posted in that thread that was inadvertently left of version 6. I'd download that script and give it a try.
Good luck. ;-)

Huh? Another script? I'll sure look it up there. The problem is that i would have to put that script into the hard drive or into the cd so that i have it available. Right?

Here are the contents from the livecd that i copied over to the hard drive:

System.map-2.6.18-6-686 grub/ mt86p*
boot.0300 initrd.gz slax.cfg
bootinst.bat* initrd.img-2.6.18-6-686 slax.png
bootinst.sh* isolinux/ syslinux/
chain.c32* lilo.conf vesamenu.c32*
config-2.6.18-6-686 lilo.map vmlinuz
dos/ liloinst.sh* vmlinuz-2.6.18-6-686

Thanks man. I'll post back with the results.

Peacedog 04-17-2008 10:11 PM

There is a script that should run here. I'm including a quote from that thread explaining the use of the script for you.

Quote:

Hmmm my fault, the Slax installer isn't in Slax6, I put it back into mine version. I've uploaded it here :

http://backtrack.serveftp.com/backtr...6-install.kmdr

Its a kmdr script, so download it to where you want, say /usr/share/slax/, then run it using the following :

Code:

/usr/bin/kmdr-executor /usr/share/slax/slax6-install.kmdr
Ignore the portion on the "live" version install, use the "real" version install.
Hope that gets you going.
Good luck. ;-)

trebek 04-19-2008 07:53 PM

Hi there friends.

I managed to copy all the files to the hard drive. I ran liloinstall.sh with a terminal, and it booted to Slax. Problem is that i got into the new installation, and it just worked slow and ended up freezing.

I will open a new thread if i am not able to fix my newly installed Slax. The installation issue is over.

Thanks for the help, i learned like hell here. LQ users rule!!!

Peacedog 04-19-2008 08:12 PM

Glad you got the install sorted.
Good luck. ;-)

gychang 02-21-2009 07:37 PM

Quote:

Originally Posted by Peacedog (Post 3126569)
Glad you got the install sorted.
Good luck. ;-)

I have been looking for Slax install for last 20minutes. This is a big oversight by the programmer, too bad, it looks good overall. Will have to try other distro.

gychang


All times are GMT -5. The time now is 06:41 AM.