LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2008, 05:33 PM   #1
brisbin33
Member
 
Registered: Oct 2007
Location: boston, ma
Distribution: fedora, ubuntu, slack, arch
Posts: 30

Rep: Reputation: 15
No Shutdown Button in Fedora 8 under GNOME


Hopefully an easy one for someone out there...

Using Fedora 8:

Logging in as root and checking control center... system admin... login manager i verified that all users have the ability to shutdown locally

if i then log in as a user in a KDE environment the logoff button gives me the options to shutdown or restart that i want.

however, if i log in as a user in a GNOME environment the logoff button only gives me the option to logoff and then i have to shutdown from the login manager. also using the commands /usr/shutdown or shutdown -h now wont work unless i become root.

is there a setting i have to change as root in a GNOME environment to let all users shutdown the computer from a GNOME environment?

thanks in advance,
pat
 
Old 03-31-2008, 05:53 PM   #2
SpecHackers
LQ Newbie
 
Registered: May 2006
Location: Chennai , India
Distribution: RHEL 5
Posts: 15

Rep: Reputation: 0
I am not sure, but someone might have edited your bash.rc profile. May be check down there.
 
Old 03-31-2008, 06:51 PM   #3
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Quote:
Originally Posted by brisbin33 View Post
Hopefully an easy one for someone out there...

...if i log in as a user in a GNOME environment the logoff button only gives me the option to logoff and then i have to shutdown from the login manager.

is there a setting i have to change as root in a GNOME environment to let all users shutdown the computer from a GNOME environment?
I'm anxious to see that, myself. After installing kubuntu-desktop on top of Ubuntu, I have the same exact problem. It's not major for me, but still annoying.

Cheers
 
Old 04-01-2008, 06:28 AM   #4
brisbin33
Member
 
Registered: Oct 2007
Location: boston, ma
Distribution: fedora, ubuntu, slack, arch
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dragonslayer48dx View Post

...It's not major for me, but still annoying...
yeah i agree; two days of googling and all i could find was to verify the control center setting i mentioned in the first post.

i hope someone here has a solution

regards,
pat
 
Old 04-01-2008, 06:38 AM   #5
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Wow, weird. I know this was (or is it still?) caused by using compiz and I'd probably bet on that if I wasn't running F8 with GNOME myself.. Even if I enable desktop-effects the shutdown button is still there.
 
Old 04-14-2008, 11:49 AM   #6
brisbin33
Member
 
Registered: Oct 2007
Location: boston, ma
Distribution: fedora, ubuntu, slack, arch
Posts: 30

Original Poster
Rep: Reputation: 15
so since this isn't really a show stopper of a problem i haven't been attempting a fix as often as i like; but i gave it another try last night...

when i am in my gnome environment i only have the log off option. from there i am taken back to the logon screen (the only one i've seen since i installed)

from there if i choose menu... shutdown.. i get the shutdown, restart, hibernate, options in exactly the same graphical representation as if i had been in a KDE desktop and chosen the (very accessible) shutdown button.

it seems i'm using a KDE display manager.

i read a post online of solving their lack of a shutdown button by editing the X11 conf file to read /gdm at the end instead /kdm... sounds great, makes sense; i've been trapped with a KDE logon disply if i change it to /gdm i'll get an ubuntu looking logon screen and have my shutdown buttons as usual.

well the only config file i could find in etc/X11 was under a slightly different name, etc/X11/prefdm; i figured, ok ubuntu/fedora translation, let's check this one out...

it contained (among other things) this:

# Run preferred X display manager
preferred=
if [ -f /etc/sysconfig/desktop ]; then
. /etc/sysconfig/desktop
if [ "$DISPLAYMANAGER" = GNOME ]; then
preferred=/usr/sbin/gdm
elif [ "$DISPLAYMANAGER" = KDE ]; then
preferred=/usr/bin/kdm
elif [ "$DISPLAYMANAGER" = WDM ]; then
preferred=/usr/bin/wdm
elif [ "$DISPLAYMANAGER" = XDM ]; then
preferred=/usr/bin/xdm
elif [ -n "$DISPLAYMANAGER" ]; then
preferred=$DISPLAYMANAGER
fi
fi

looks like if im using GNOME then it should go to /gdm, right?

well, now i'm confused.

anyone still following this thread,
care to comment?

Last edited by brisbin33; 04-14-2008 at 04:57 PM.
 
Old 04-14-2008, 05:01 PM   #7
brisbin33
Member
 
Registered: Oct 2007
Location: boston, ma
Distribution: fedora, ubuntu, slack, arch
Posts: 30

Original Poster
Rep: Reputation: 15
Solved

mwaha!

etc/sysconfig/desktop

was:

DESKTOP="KDE"
DISPLAYMANAGER="KDE"

will now be:

DESKTOP="GNOME"
DISPLAYMANAGER="GNOME"

let's hope this fixes it
 
Old 07-28-2008, 04:33 AM   #8
alainahming
LQ Newbie
 
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
Did you try re-creating the button and assigning the correct command to it?

Suggestion:
1. On panel, right click on System, click 'Edit menus'
2. Choose the section where you want to add the button
3. Assign the appropriate icon, command (e.g. shutdown -h now). click close and your new Shut down button will be visible.

Alain
 
Old 07-28-2008, 06:28 AM   #9
sir_com
Member
 
Registered: Feb 2008
Posts: 31

Rep: Reputation: 15
One more suggestion...may be helpful

If the shutdown button is not listed then pressing "crtl+alt+del" will give you the shutdown menu provided if the below entry is present in the /etc/inittab file.

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -h

Cheers
sir_com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
shutdown button Rita G. Debian 8 02-02-2008 10:45 AM
Logout/shutdown/reboot button misconfigured on GNOME odiseo77 Linux - Software 1 08-09-2006 02:37 PM
shutdown button missing in gnome bhar0761 Fedora 5 08-02-2005 10:59 AM
Shutdown button Ezzy Linux - Newbie 6 04-26-2005 09:44 AM
Shutdown with power button hriosm Linux - Hardware 4 06-06-2003 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration