LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2008, 05:24 PM   #1
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Rep: Reputation: 30
no rule to make error


Ok I got a new dlink and got the files that come on the cd copied them to /tmp ran make install like it said on the cd. The output was no rule to make rhine_main.o needed by rhinefet.o. Since I can not find the second file on my comp I do not know what it is talking about but it sounds like I already have a driver on my comp.

Are all o files drivers. What do I do now.
 
Old 08-31-2008, 06:41 PM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Please provide more details.

What dlink? A router? What are you trying to install? It sounds like you are trying to build some software - what commands do you use to do this, and what is the actual output?
 
Old 09-01-2008, 12:17 AM   #3
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by matthewg42 View Post
Please provide more details.

What dlink? A router? What are you trying to install?
A network card.

Quote:
It sounds like you are trying to build some software - what commands do you use to do this,
make install

[QUOTE]
and what is the actual output?
[\QUOTE]

no rule to make rhine_main.o needed by rhinefet.o
 
Old 09-01-2008, 01:25 AM   #4
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
Quote:
A network card.
Do you care to tell us which model, or should be guess?

Do you know of some download link where we can get the software to have a look at it? Without seeing the Makefile, (and preferably the other files in the package too), it's impossible to diagnose the problem further.

Last edited by matthewg42; 09-01-2008 at 01:35 AM.
 
Old 09-01-2008, 01:57 AM   #5
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by matthewg42 View Post
Do you care to tell us which model, or should be guess?
dlink dfe530tx+

Do you know of some download link where we can get the software to have a look at it? Without seeing the Makefile, (and preferably the other files in the package too), it's impossible to diagnose the problem further.[/QUOTE]

http://support.dlink.com/products/XPstatus.asp?Prodid=DFE-530TX+&OS=linux

Its the version 6.0
 
Old 09-01-2008, 02:08 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Can you post the lspci output for the card? The kernel may already have a driver for it.
 
Old 09-01-2008, 02:13 AM   #7
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Heres what I found but I am new to this and do not know what to do about it.

`No rule to make target `xxx', needed by `yyy'.'
This means that make decided it needed to build a target, but then couldn't find any instructions in the makefile on how to do that, either explicit or implicit (including in the default rules database).



I do not know whats rule is missing so don't know how to correct it.
 
Old 09-01-2008, 02:25 AM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,243

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
from the downloaded package "DFE-530Tx+_F2_" did you go to DFE-530Tx+_F2_/linux and open dlkfet-4.39.tar.gz then from that folder run " make "
and did you read this FIRST
DFE-530Tx+_F2_/Info/LINUX/linux.txt
linux.txt has the build and install instructions
 
Old 09-01-2008, 06:50 AM   #9
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Nylex View Post
Can you post the lspci output for the card? The kernel may already have a driver for it.
I checked that. I thought maybe the via-rhine might work but got an error when I ran insmod. I will post it tonight after work.

Last edited by dvdljns; 09-01-2008 at 07:15 AM.
 
Old 09-01-2008, 06:55 AM   #10
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
[QUOTE=John VV;3265803]from the downloaded package "DFE-530Tx+_F2_"
[\Quote]

No. I used the one on the disk that came with the card.
Quote:
did you go to DFE-530Tx+_F2_/linux and open dlkfet-4.39.tar.gz then from that folder run " make "
and did you read this FIRST
DFE-530Tx+_F2_/Info/LINUX/linux.txt
linux.txt has the build and install instructions
I followed the instructions to the letter.

Last edited by dvdljns; 09-01-2008 at 07:15 AM. Reason: forgot color
 
Old 09-01-2008, 07:14 AM   #11
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by John VV View Post
from the downloaded package "DFE-530Tx+_F2_" did you go to DFE-530Tx+_F2_/linux and open dlkfet-4.39.tar.gz then from that folder run " make "
and did you read this FIRST
DFE-530Tx+_F2_/Info/LINUX/linux.txt
linux.txt has the build and install instructions
Just did that with downloaded files. I still get same error.
 
Old 09-01-2008, 12:33 PM   #12
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,243

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
well in the folder( DFE-530Tx+_F2_/linux) there IS a make file AFTER you uncompress dlkfet-4.39.tar.gz LOOK FOR IT
open a terminal and cd to the folder WITH the make file
example: for me it is -- from my home folder -- use "su -" or sudo
Code:
cd download/DFE-530Tx+_F2_/linux
su -
( your root password when asked)
make
you might also want to install if you are using GNOME and fedora
nautilus-open-terminal
Code:
su -
yum install nautilus-open-terminal
this puts a option in the right click menue to " open a terminal here"

Last edited by John VV; 09-01-2008 at 12:36 PM.
 
Old 09-01-2008, 08:24 PM   #13
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
I do not have gnome I am working from a command line. I do have kde.
 
Old 09-01-2008, 08:40 PM   #14
dvdljns
Member
 
Registered: Sep 2003
Posts: 210

Original Poster
Rep: Reputation: 30
Unhappy

Quote:
well in the folder( DFE-530Tx+_F2_/linux) there IS a make file AFTER you uncompress dlkfet-4.39.tar.gz LOOK FOR IT
open a terminal and cd to the folder WITH the make file
example: for me it is -- from my home folder -- use "su -" or sudo

It is already uncompressed in /tmp as per the instructions in gz file. Here is the instructions I followed.




Installation
============
Please enter the following commands at the UNIX prompt. Remember, UNIX is
case sensitive.

1) Create a temporary directory:
mkdir /temp

2) Change to the temporary directory:
cd /temp

3) Copy driver (dlkfet-4.39.tar.gz) from DOS disk, (mcopy below is one tool in
mtools, if you didn't install mtools, you can type
'mount -t msdos /dev/fd0 /mnt' and use 'cp /mnt/dlkfet-4.39.tar.gz /temp'
command to copy the driver to the temporary directory):
mcopy a:dlkfet-4.39.tar.gz .

4) untar the archive file:
tar xzvf dlkfet-4.39.tar.gz
cd dlkfet-4.39

5) Compile the driver source files and it will generate rhinefet.o, and
copy it to correct driver installation path (The installation directory
is different in different kernel versions. In 2.4.x/2.6.x kernel, the path
is /lib/modules/KERNEL_VERSION/kernel/drivers/net/,

make install

6) Check configuration file (/etc/modules.conf or /etc/conf.modules or
/etc/modprobe.conf, it depends on your Linux distribution) for loading
kernel modules. Make sure the first line below is appeared in the
configuration file, where # is the interface number (eg: alias eth0
rhinefet). If you need to set the driver options, below second line is
an example to set the NIC to 100Mbps fullduplex mode (remember to unmark
the line if it is put in the configuration file).
alias eth# rhinefet
#options eth# speed_duplex=2

7) Reboot now:
shutdown -r now

8) Install your driver module (If the driver module is in the wrong place,
an error message will appear, and say that can't find the driver
module):
insmod rhinefet.o

9) Use ifconfig command to assign the IP address, where # is network
interface number:
ifconfig eth# <IP>

10) Check the interface works:
ping <remote_host_IP>

Remove intermediate files
=========================
Please enter the following command to remove intermediate files generated
during the driver compilation:
make clean
 
Old 09-01-2008, 09:12 PM   #15
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,243

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
then when you cd to the folder with makefile in it and run " make " it should build or through an error
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
get this error when runnign make ***** "no rule to make target 'config'. stop" procfs Linux - General 4 05-12-2013 11:25 AM
No rule to make bootstrap error - LFS LiveCD olcal Linux From Scratch 10 02-09-2012 04:04 AM
automake error: no rule to make target all jwstric2 Programming 2 10-18-2011 03:48 PM
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 12:19 PM
Error: *** No rule to make target 'all'. Stop aa2bi Linux - Newbie 6 06-08-2004 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration