-   Linux - Newbie (
-   -   "No root file system is defined" - During installation process of Ubuntu (

Trinric 05-19-2008 09:37 PM

Error!"System~1_Resto-1RP57CHANGE~1.1 is 1k but it has 4 clusters (16k)
I fixed this problem below where it says no root system..ect, But now I have a new problem, when i specify which one is the root, with mount "/" I get an error when i click forward that says, "System~1_Resto-1RP57CHANGE~1.1 is 1k but it has 4 clusters (16k). And i have the option to Ignore or Continue.
Well, I am at the point during the installation of Ubuntu, when I have to specify which is the partition for the "Root file system" and the Swap, All of which I made partitions for using Partition magic, It automatically made a 500mb Swap with it.

So it only allows me to choose one option, which seems to be my root partition, and i get the error" No root file system is defined"

I'm Not sure what to do, this is my first time installing linux.

Other info:
I currently also have a windows Xp partition, I am having this one so i can dual boot.

Under devices I have, which the ones I made for linux ( this doesn't include window's ones)
/dev/hda4 for the swap , 526 Mb
and /dev/hda3 for the Primary one for linux, and its Ext3 and next to it, it has /media/hda3
and I have about 10,000 Mb set aside for that.

So what should I do to fix this error?


masonm 05-19-2008 10:22 PM

Did you set the mount point for that partition to / (root) in the installer at that point?

You have to tell it you want that as the root partition.

Trinric 05-19-2008 10:31 PM

Alright I tried that, but I get a cluster error?
something about 4 clusters and (16k) and resto..not sure.. i have a swap and i removed the partition so i had some empty space, and i used manual partition with ubuntu installer, and i get this error!
Its now set as "/" also.

jay73 05-20-2008 12:32 AM

Which version are you trying to install? The "root partition" things was a known bug in the 7.04 installer. It could be worked around using a little Python but if that is your problem you may as well get a newer version (current = 8.04).

DaF101 05-20-2008 03:49 AM

You have to be careful when it comes to dual booting Linux and Windows, because it can be rather risky. These are the following partitions you have to make (and if I were you I wound download Parted Magic to do all of your partition work) But don't use partition magic or any other partition editor when you are about to install linux because you can do it when you are in the installation. Here is how you manually partition your linux system within the setup.

First you have to make your root directory:
Mount point has to be "/"
In linux / is basicly the same as C:\ in windows.

Secound you have to do your swap which does not have a mount point deciding how big your swap partition is going to be is easy, they recommend that you have twice as much swap space as what you have in ram so say for example you have 256MB of ram and you would make 512MB as swap

Next you need a boot partition so your system will boot, the mount point for a boot partition is /boot
Make your boot partition about 100MB

If you want to do it the easy way, Just click "Partition manually" but if you want to do it by yourself, then thats the way to do it :)

Good Luck :)

Sunfist 05-20-2008 05:34 AM

I can tell you what I did and it worked, when you get to the partition screen, pick manual. Click on the partition where you want to install Linux and then click new partition. I made a 1G swap partition, set the size with the little click arrows and pick swap for the file type. Then the installer rescans the HD and you see the swap partition and the unused partition. Click on the unused partition and click new partition again, for type I used ext3, then for some reason the window where you would think you could pick root or whatever didnt work I would click on it and it wouldnt do anything, so I just manually entered "/" and clicked ok and that seemed to work. This is for version 7.1, if I recall 7.04 was very similar too.

Trinric 05-20-2008 06:34 AM

I have done all of this before, and i still have this new error. It says something like, "1.1 has 1k, but it is 4 clusters (16k) in the error.

charliebrown1977 02-14-2011 01:44 PM

I had the same issue "/" is the answer

All times are GMT -5. The time now is 11:07 PM.