-   Linux - Newbie (
-   -   No initab file found - No more processes left in this runlevel (

mrhansen 08-20-2004 05:08 PM

No initab file found - No more processes left in this runlevel
Hi I am in deep trouble here guys, if anyone can help me I would appreciate it greatly! I am a total newbie here :scratch:

I am running a Suse 9.1 server on the internet, and it crashed here after I had some error messages in KDE with RANDRINIT hack or something like that.

Now i first got some errors regarding missing files and directories, and reiserfs filesystem ....vs-508 unexpeted message and so on. I logged on with the cd and ran reiserfsck --first the fix and the the rebuild tree ......

Well now I don get anywhere it just boots up and I get errors like this :

-warning: cant't open /etc/mtab: No such file or directory
-warning: cant't open /etc/mtab: No such file or directory
-ReisersFS: hda2: found reisersfs format "3.6"with standard journal
-ReisersFS: hda2: using orderd data mode

and it keeps going until

- VFS: Mounted root (reiserfs filesystem) readonly
- Trying to move old root to /initrd ... failed
- Unmounting old root
- Trying to free ramdisk memory ..ok
- Freeing unused kernel memory
- INIT: version 2.85 booting
- INIT: No initab file found

-Enter runlevel:
When entering 3 here it reports back:

- INIT: Entering runlevel: 3
- INIT: no processes left in this runlevel
And here it just stops !?

I am really out on a limb here guys, anyone please if you have any suggetions to me, please I am all out of ideas because this is all so new to me !

MrHansen :cry:

btmiller 08-20-2004 05:36 PM

Sounds like your /etc/inittab file is missing or corrupt. You'll need to boot into signle user mode (or perhaps even off your rescue CD) and restore it from backups (you do have backups, right :)). If you don't have anything backed up you can probably reinstall the package that provides /etc/inittab. In RH9 this is the initscripts package (it may be different in SuSE). As for mtab, if you touch /etc/mtab I think it should be dynamically created at boot (mtab is the table of mounted filesystems).

Mara 08-20-2004 05:40 PM

- Trying to move old root to /initrd ... failed
That's the problem. For any reason there's something wrong with your initrd file. I think you need to use the cd as rescue again and check if initrd exists. You may have bigger damage than you expected, IMHO (more things can be missing).

BTW When you're hacked it's the best idea to install from scratch. You can put the disk to any other machine and copy data.

mrhansen 08-21-2004 01:42 PM

Thanks guys, I tried to check for the initrd but found that I cant even log in from rescue now, so I will have to reinstall from scratch :o

mrhansen 08-21-2004 02:32 PM

Hmrpf I did manage to access the disk....seems the /initrd is missing, cant find it anywhere.

But both the inittab and mtab is present and accessible!

Is there anything I can do with the /initrd ?? Could I just recreate it somehow ??



btmiller 08-21-2004 05:08 PM

mkinitrd will re-create the initrd for you. See the man page for more details.

mrhansen 08-27-2004 03:17 PM

Thanks for helping me out guys. I discoverd why the problem arised in the first place and it was a hardware problem that corrupted my hardisk.

I tried creating a new initrd but failed to do so, and also every other attempt to recover my system has been futile. It says the root partition is missing and as a last try I will attempt to recover it, but probably I will have to reinstall.

At least I am a little more wise now. Thanks.

All times are GMT -5. The time now is 07:53 AM.