LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2007, 09:12 AM   #1
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Rep: Reputation: Disabled
No Graphic Interface after Nvidia 9755 Driver Installation


Dear Community,
I wanted to install these drivers on my notebook with a 6800 Go and Kubuntu Edgy 64bit. Heres what I did:
Code:
apt-get install build-essential linux-headers-generic
then I downloaded the above drivers. Switched to text-mode, logged in as root and turned of kdm:
Code:
/etc/init.d/kdm stop
the I ran the installation:
Code:
sh NVIDIA-Linux-x86_64-1.0-9755-pkg2.run
telling it not to search for pre compiled version. Installation seemed to have been succesfull. Next I ran
Code:
dpkg-reconfigure xserver-xorg
and configured X.
Last I checked that nv was not in use:
Code:
vim /etc/default/linux-restricted-modules-common
and restarted the system. Login was still in text-mode so I logged in and wanted to start kdm:
Code:
/etc/init.d/kdm start
the output was that kdm was allready running. I tried hitting Control Alt and F7, yet all I recieved was a black screen I could type anything into, however with no reaction of the system. Switching back to text-mode I ran
Code:
dpkg-reconfigure xserver-xorg
trying different resolutions, activating and Kernel-Framebuffer and dri and changing resolution and refresh rate.
Thank you for your time,
baking-a-77
 
Old 05-08-2007, 09:38 AM   #2
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
can you post your xorg.conf? That will help get to the bottom of this.
 
Old 05-08-2007, 09:42 AM   #3
dfowensby
Member
 
Registered: Dec 2003
Location: OceanView Virginia, gem of the Southern Shore
Distribution: MATE 15.04
Posts: 194
Blog Entries: 1

Rep: Reputation: 30
or google it...

http://packages.debian.org/stable/x11/nvidia-glx

should get you the needed deb files, and install with dpkg, or use synaptic (from testing/unstable universe) .
upon install completion, edit /etc/X11/xorg.conf to ensure the card section reads Driver "nvidia", and that the proper modules files were written (should all be automagical)

also ensure while you're editing, that your monitor specs, and modes are within mfr limits. the proprietary nvidia needs 24bits as a setting, and at least 1024x768 for best results.
shouldnt take more than 2 or 3 minutes.

this works fine in Feisty, hope it works for you.
luck, -O
 
Old 05-08-2007, 10:03 AM   #4
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Thanks for the quick answers.
Apperantly permissions are denied for /etc/X11/xorg.conf, allthough I am loged in as root. (That is root not su, allthough kubuntu.)
I am definatly within mfr limits.
nvidia-glx is now installed, yet there are no visible changes to the situation.
 
Old 05-08-2007, 10:28 AM   #5
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
To edit my files in Ubuntu I use
Code:
sudo vim /etc/X11/xorg.conf
then type the password and you are set. Substitute vim for your editor of choice.

To post the file you should be able to
Code:
cat /etc/X11/xorg.conf
and then cut and paste from there.

I think you are still using the nv drivers.
 
Old 05-08-2007, 10:48 AM   #6
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
It still won't let me copy & paste. But for sure there is a way to save the file to an external device?
In any case im not using the nv drivers as Section "Device" put out
Quote:
Originally Posted by Section Device
Identifier "6800 Go Ultra"
Driver "nvidia"
Bus ID "PCI:1:0:0
Option "UseFBDev"
I would be more than happy to copy any other relevant sections in here.
 
Old 05-08-2007, 11:00 AM   #7
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
Wow. I reinstalled 7.04 last night and the nvidia process was about 5 minutes, much like dfowensby said. This is odd. Have you restarted the system at all? I restarted the xserver with control-alt-backspace when I installed last night.

I would restart and see if there are any error messages when x tries to start.
 
Old 05-08-2007, 12:01 PM   #8
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Yes the System was restarted numerous times. when I type in startx I recive:
Quote:
(EE) Failed to load /usr/lib/xorg/modules/libglx.so
Failed to load module "glx" (loader failed, 7)
(EE) NVIDIA(0): Failed to initalize the GLX module; please check in your X server, and that the module is the NVIDIA GLX module. If you continue to encounter problems, please try reinstalling the NIVIDIA driver.
Error: API mismatch: the NIVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9755. Please make sure all the kernel module and all NVIDIA driver components have the same version.
(EE) NVIDIA(0): Faild to initialize the NVIDIA kernel module! Please ensure that there is a supported NVIDIA GPU in this system, and th NVIDIA device files have been created properly. Please consult NVIDIA README for details.
*** Aborting ***
(EE) Screen(s) found but none have a usable configuration.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0" after 0 requests (o known processed) with 0 events remaining.
I will try to install missing data and setup X again. Thanks for your input so far, always ready for more,
baking-a-77
 
Old 05-08-2007, 12:06 PM   #9
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
Can you install the drivers via synaptic? I get my driver that way (nvidia-glx-new). After that runs, I edit my xorg.conf and then ctrl-alt-bksp and it is all done. I do not have a 64 bit though so I am not positive with yours.
 
Old 05-08-2007, 12:27 PM   #10
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Yeah, I wanted to install nvidia-glx-new, as I have seen it around but apt does not seem to find it. How can I use synaptic without X running? I kicked out the other glx, and that seems to solve the first of the three problems startx prints out.
Thanks again,
baking-a-77
 
Old 05-08-2007, 01:15 PM   #11
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
I open synaptic while in X. I search for nVidia. Then I roll on down to nvidia glx new. Check it for installation and apply. When it is done I open a terminal and edit xorg.cong to show nvidia instead of nv. I also make sure my monitor specs are correct (horizontal synch, vertical synch, and the screen sizes are what I want). I save it and then hit control-alt-backspace and everything is set. No need to do anything with the x server until the very last bit (ctrl-alt-bksp).
 
Old 05-08-2007, 01:36 PM   #12
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
No luck. Als synaptic does not show a nvidia-glx-new. There's just glx and glx-legacy.
 
Old 05-08-2007, 01:49 PM   #13
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
Wait a sec, these are the 64 bit drivers, right? Maybe they are not in synaptic. I don't have a 64 bitt processor so I am at a loss with that.

Here is the other way to do it if you have the drivers downloaded from nvidia. If it still logs in as text mode just do that and sign in. Then cd to directory where the drivers are. Follow the commands from the nVidia site (sudo sh NV you can probably hit tab at that point and the rest will fill in). This should kick off the whole process.

When that is all done, you can edit your xorg.conf using
Code:
sudo vim /etc/X11/xorg.conf
then make the changes (I am assuming you know basics of vim). Or-even easier-, you can run
Code:
dpkg-reconfigure xserver-xorg
and follow along answering the questions. Use advanced for your monitor and enter the correct specs. When it is all done you can hit startx and you should be set.

Last edited by jkirchner; 05-08-2007 at 01:50 PM.
 
Old 05-08-2007, 01:54 PM   #14
baking-a-77
Member
 
Registered: Jun 2006
Location: Europe
Distribution: Sabayon, Debian, openSuse, JAD
Posts: 50

Original Poster
Rep: Reputation: Disabled
Well that is what I did right in the beginning, and X would'nt start, but I guess I'll just try it the fourth time.

Last edited by baking-a-77; 05-08-2007 at 01:55 PM.
 
Old 05-08-2007, 01:59 PM   #15
jkirchner
Member
 
Registered: Apr 2007
Location: West Virginia
Distribution: Mint
Posts: 778

Rep: Reputation: 201Reputation: 201Reputation: 201
I never do that first apt-get you mention in your first post. I am not saying it is wrong, I am somewhat new myself at this. I also do not know if there are differences between the 64 and 32 versions.

When you do this, do you get any errors from the nVidia installer? Or warnings?

EDIT: I noticed you got this:
Quote:
Error: API mismatch: the NIVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9755. Please make sure all the kernel module and all NVIDIA driver components have the same version.
Have you downloaded the restricted modules for the driver you want to use? You can do that through synaptic also.

Have you tried reloading synaptic? There is a button on the menu to refresh the listing. Perhaps nvidia-glx-new will show up then.

Last edited by jkirchner; 05-08-2007 at 02:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA-Linux-x86-1.0-9755 and 2.16.19.1 Kernel Ellops Slackware 7 04-12-2007 11:49 PM
LXer: NVIDIA Proprietary Linux Display Driver 1.0-9755 LXer Syndicated Linux News 0 03-09-2007 07:17 PM
LXer: NVIDIA 1.0-9755 Display Driver LXer Syndicated Linux News 1 03-08-2007 01:43 AM
problem with nvidia driver: unable to close graphic enviroment for a console login Valkyrie_of_valhalla Linux - Hardware 2 11-25-2006 03:10 PM
NVIDIA graphic card driver trouble crazyalex Linux - Hardware 6 05-31-2005 06:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration