LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   no free disk space on '/' (https://www.linuxquestions.org/questions/linux-newbie-8/no-free-disk-space-on-734290/)

upper_room 06-19-2009 07:48 PM

no free disk space on '/'
 
Hi, I just installed ubuntu 9.04 on a dual boot with Windows Vista. I'm trying to update and I get a message 'no free disk space' and an explanation that I don't have enough disk space on '\'. I should have enough free space.

I went to Gparted, I have 132Gb in partition /dev/sda2, file system ext2. I have partition /dev/sda5 file system ext3 mounted as '/', which has zero free space. What do I do in this situation.

Tinkster 06-19-2009 07:58 PM

Hi, welcome to LQ!

And what is /dev/sda2 mounted as?


Cheers,
Tink

upper_room 06-19-2009 08:02 PM

it's not mounted as anything, the column 'mount point' is blank

Tinkster 06-19-2009 08:47 PM

Can you please copy & paste the output of
Code:

mount
and
Code:

fdisk -l
in code tags?

upper_room 06-19-2009 09:08 PM

Code:

grant@grant-laptop:~$ mount
/dev/sda5 on / type ext3 (rw,relatime,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
lrm on /lib/modules/2.6.28-11-generic/volatile type tmpfs (rw,mode=755)
securityfs on /sys/kernel/security type securityfs (rw)
overflow on /tmp type tmpfs (rw,size=1048576,mode=1777)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/grant/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=grant)

and

Code:

root@grant-laptop:/home/grant# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xb258bbd4

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1              1        192    1536000  27  Unknown
Partition 1 does not end on cylinder boundary.
/dev/sda2  *        193      17825  141637072+  83  Linux
/dev/sda3          18152      19458    10485760    7  HPFS/NTFS
/dev/sda4          17826      18151    2618595    5  Extended
/dev/sda5          17826      18130    2449881  83  Linux
/dev/sda6          18131      18151      168651  82  Linux swap / Solaris

Partition table entries are not in disk order


syg00 06-19-2009 09:16 PM

Nice try :p - change the < > to [ ] and the included will be formatted properly (you can edit your own posts).
Go to sf.net and get and run the bootinfo script - post the generated RESULTS.txt. It'll show us what's pointing to what.

upper_room 06-19-2009 09:55 PM

This download isn't working. I went to sourceforge.net, found the boot_info_script, tried to download it. The download window doesn't open, I tried direct download, same thing. No files are being downloaded. Tried to change the 'save files to' under preferences, and it won't let me enter anything or browse.

Any other ideas?

syg00 06-19-2009 10:07 PM

Same problem here - I've attached a slightly older version.

upper_room 06-19-2009 10:11 PM

Attached? Where do I get the attachment?

norobro 06-19-2009 10:23 PM

I just download v0.32 from here

Nice script.

upper_room 06-19-2009 10:40 PM

again, the download at sourceforge.net isn't working.

norobro 06-19-2009 10:57 PM

I just downloaded it again.

Check your email.

syg00 06-19-2009 11:07 PM

The attach failed - invalid file; might have to ask jeremy about that.
I don't understand why Ubuntu would install like that.
Try these commands
Code:

sudo blkid -c /dev/null
cat /etc/fstab
grep -Ev "^#|^\s*$" /boot/grub/menu.lst"


upper_room 06-19-2009 11:21 PM

Okay, here's the output from those commands

Code:

grant@grant-laptop:~$ sudo blkid -c /dev/null
/dev/sda1: UUID="AEAEC0C7AEC08973" LABEL="TOSHIBA SYSTEM VOLUME" TYPE="ntfs"
/dev/sda2: UUID="0777f285-64ea-4001-95b0-890f528d7c86" TYPE="ext2"
/dev/sda3: UUID="F014ABBC14AB8466" TYPE="ntfs"
/dev/sda5: UUID="75d2bff3-9f52-42c0-91ca-8d5221c2edb6" TYPE="ext3"
/dev/sda6: UUID="838ffcd4-186a-461a-8bf6-32528494ad52" TYPE="swap"
grant@grant-laptop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
# / was on /dev/sda5 during installation
UUID=75d2bff3-9f52-42c0-91ca-8d5221c2edb6 /              ext3    relatime,errors=remount-ro 0      1
# swap was on /dev/sda6 during installation
UUID=838ffcd4-186a-461a-8bf6-32528494ad52 none            swap    sw              0      0
/dev/scd0      /media/cdrom0  udf,iso9660 user,noauto,exec,utf8 0      0
grant@grant-laptop:~$ grep -Ev "^#|^\s*$" /boot/grub/menu.lst"
>

That's where it leaves off, the last command doesn't have an output.

syg00 06-19-2009 11:40 PM

Ahhh - remove the trailing double quote.


All times are GMT -5. The time now is 03:44 PM.