LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No distro installs properly (https://www.linuxquestions.org/questions/linux-newbie-8/no-distro-installs-properly-333377/)

10xOXR 06-14-2005 04:51 AM

No distro installs properly
 
I'm attempting an XP/Linux duel boot, with XP as the OS resident on /dev/hda1 and Linux using the 20Gb of unpartitioned free space left on the disk.

This problem is driving me nuts! Any Distro of Linux, be it Gentoo, SuSE, Fedora, whatever, will not install on my machine.

Any live or install CD/DVD that I've tried (Knoppix, et al) will run without any problems and all hardware is recognised. When I'm installing, all distros have no problem partitioning the free space on my drive and installing their files and eventually the bootloader (tried both GRUB and LILO). But when I restart, the system hangs when grub/lilo loads and goes no further - I don't even get an OS menu. XP/W2K CD's refuse to boot either to repair the MBR afterwards.

I've even tried using NTLDR to boot linux, installing the bootloader to the /boot partition, but after install and restart I just get "Invalid system partition" and it hangs again!

Interestingly though, when I've installed the distro in question and I then look at the partition table from Partition Magic 8.0 rescue disks I'm told that the whole disk is "*BAD*", it sees not one vailid partition. But when I then boot Knoppix Live CD I can access the Linux Partitions with no problems.

When I then format the drive from PM8 as FAT32 I can reinstall Windows without a hitch.

Could someone please offer any advise before my machine takes a trip out the window!

AMD64 3200+ Processor
ABit KV8-Pro Mainboard
512Mb DDR400 RAM
80Gb 7200rpm Maxtor HDD on IDE1
ATI Radeon 9200SE (RV280)

xxx_anuj_xxx 06-14-2005 05:52 AM

Did you tried this?
At the time of installaion of ur distro and configuring your grub:-
Select Install Boot Loader record on "...First sector of boot partition".
:)

10xOXR 06-14-2005 07:24 AM

It doesn't seem to matter whether I install the bootloader to the MBR or the first sector of the /boot partition and try using NTLDR.

I'm running out of ideas here - I'm hoping that its not a hardware fault with the HDD, I'll cry if it is! :cry:

dinolinux 06-14-2005 09:25 AM

Hi!

Do you get an error code from GRUB or LILO when the system is booting?

10xOXR 06-14-2005 09:34 AM

No errors, I just get "GRUB Loading, please wait..." and that's it - system hangs.

I have no idea what would be causing this...


10x...

dinolinux 06-14-2005 10:25 AM

Hello again!

As I can see, you have a REALLY BIG problem here...

Do you have a 64 bit processor? If yes, you need to get a 64 bit distro like Fedora Core 4 x86_64. If not, there may be another possibility...

I have a 80GB Seagate disk here. When I tried to partition it in Linux for the first time, it went completely wrong. Later I found out that the disk was meant for Windows "only", so I had to partition it with Seagate's own partition tool. After that the disk works like a dream. I can even partition it in Linux.

But as I can see you have a Maxtor disk...

Is there any possibility your disk is one of those "Windows only"? Maybe there is a partition tool on the Internet?

And one more thing: Have you tried to install the boot loader on MBR?

10xOXR 06-14-2005 01:28 PM

I'm using AMD64 distro releases so there's no problem there.

As I said before, there's no difference whether I install the bootloader on the MBR or the /boot partition - both fail.

I must say that I've never heard of any HDD being designed for one OS only - The HDD in my system has had a successful install of SuSE 9.2 before so I guess I draw a blank on that one too.

Thanks for all you help thus far, I'll just have to persevere.



10x...

titopoquito 06-14-2005 03:15 PM

Well, to be honest I don't know your problem.
But maybe if you try the next time to install Windows and Linux, you could try a different boot loader. I use Xfdisk, it works like a charm and is able to boot Win, Linux and *BSD (maybe more, didn't try). I didn't like the idea to mix a Windows partition (/dev/hda1 for me) with a Linux boot loader, that sounded like a real "duel boot" to me.

BTW, I don't know if I would partition and FORMAT the drive with partition magic. Maybe I try to keep it to simple, but for this issue (formatting a FAT32 partition) I still use an old Windows98 oder WindowsME boot disk.

I hope you get your computer working with Linux :)


All times are GMT -5. The time now is 12:39 PM.