-   Linux - Newbie (
-   -   no choice for lilo- now can't dual boot (

netwench 06-29-2003 04:59 PM

no choice for lilo- now can't dual boot
i'm hoping for some help. i have a soyo dragon plus mb, amd athelon xp 2000 processor, 768 mgs of ram, 40 gig drive. i just installed win 200 server (ntfs) and red hat 6.2 . i TRIED installing rh9 but it just hung when it probed my devices so i gave that one up.

anyway, my problem is i was trying to install server components and most everything so that i can learn how to use it in rh. my partitions are hda1 is win 2000 (about 20 gigs), hda2 is the linux native (rest of drive) and hda3 is 500mgs swap.

after i restarted, when i just let it boot from hdd it stops after "verifiying data....." it says " LI_" then hangs with a blinking cursor.
i can boot into linux using the boot disk i made when i installed it . with that disk, LILO gets spelled out and i can log into linux fine.
i CANNOT boot into windows at all anymore even using the cd rom with windows 2000 on it.

i saw some of the directions here talking about "boot into windows and add such and such to boot.ini" but what do i do if i can't get into windows? and i don't understand at all what i have to do with the mbr and copying files and such.

please, if someone could walk me through this. rh6.2 install does not give me an option of whether to use lilo or not or even where to put it, as i've seen in other posts.

i want to be able to boot into either, obviously.... if it means wiping everything out i can do that but i'll need instructions as to where to put everything back.


michaelk 06-29-2003 05:23 PM

Not sure if W2K has the same options as XP but if you can boot the install CD and select repair mode then run the command fixmbr.

Other option is if you have a win98 CD or emergency boot floppy use that to boot to DOS mode and run the command

fdisk /mbr.

netwench 06-29-2003 05:29 PM

i tried loading from the cd rom- it is bootable- but it just said:

"booting from cdrom drive...


(hangs again)

i have xp pro- trying to find emergency boot disk from that right now...

netwench 06-29-2003 05:48 PM

snif snif... ok, if i put in the rh boot disk AND the win 2000 cd, it boots to windows from cd. (wtf?)

fixmbr worked!

so now i can boot to windows .. snif snif.. but i want linux!

and if i put in the rh boot disk, i can boot to linux. so it's there but..

i'm not touching anything else until someone can advise me how to install linux dual boot and what (if anything) i need to wipe out. i have a feeling the partitions are still there but the mbr has been changed so.... i don't know my next step.

sorry for being such a newbie... i thought i had read enough posts but i guess not...


michaelk 06-29-2003 07:08 PM

To use W2K to boot linux:

fixmbr just restored the master boot record.

What the above steps shows is instead of writing lilo to the mbr you will write it to the boot partition. Then copy it to a file on the W2K c: drive. Modify W2K's bootloader to boot linux.

adz 06-30-2003 12:38 AM

I dual boot XP and Debian. Here's my lilo.conf file. It works for me. I've left in all the auto-generated comments - they might help.



# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.
# bios=0x81

# bios=0x80



# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller. Using `compact' is especially recommended when
# booting from a floppy disk. It is disabled here by default
# because it doesn't always work.

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details


# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.

# You can put a customized boot message up if you like. If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress. `single-key' goes with the `alias' lines in the
# `image' configurations below. eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
# message=/boot/bootmess.txt
# prompt
# single-key
# delay=100
# timeout=100


# Kernel command line options that apply to all installed images go
# here. See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
append="hdd=ide-scsi apm=on"


# initrd=/initrd.img
# restricted
# alias=1

image = /boot/rtzImage
label = RTlinux
root = /dev/hda1

# label=LinuxOLD
# read-only
# initrd=/initrd.old
# restricted
# alias=1

# label=Linux2.2.20
# read-only
# optional
# restricted
# alias=2



netwench 06-30-2003 07:25 AM

thanks so much for the very detailed lilo .conf. but where does it go? mbr? /boot? i'm still confused about that concept.

one last thing- i'm finding that the drivers for things i want (video card, etc) can be found only for later versions of rh. if i find a WORKING (grr) copy of rh 7/8/9 and i want to install that, will i have this dual boot mess all over again? i mean, will it just write over my mbr and possibly leave me in "LI" of death hang again?

i found this page but i NEVER saw this screen when i installed linux all 5 times with both "custom" and "server" options... any clue as to why that screen never shows up? does anyone know if it appears in later versions?

thanks for all your help!

adz 06-30-2003 09:02 AM

Yes. The lilo.conf file is located in /etc. So the Whole address is /etc/lilo.conf. It exists already you'll just have to edit it. The lines that interest you the most are the two sections down the bottom. They describe how to define another OS on another partition (other=blah, blah). After you have saved you changes to this file and exited you'll have to run /sbin/lilo.

Two notes: 1. You'll have to be root to edit lilo.conf and execute /sbin/lilo.
2. More often than not you wont have to type in "/sbin/lilo". Just "lilo" will do.

When you run lilo, it just shoves all the settings from lilo.conf into the MBR. If you don't run it, then your new settings wont take effect.

With regards to the screen you never saw I can't help you specifically with that (I use Debian) but to force-load lilo into the MBR you type "lilo -b /dev/hda" (assuming you are using /dev/hda as your boot device - which you probably are). If you want to install lilo into the first sector of you linux partition and let windows (or something else) be you boot manager you do this with "lilo -b /dev/hdax" where x = 1 to 4 and corresponds to the partition on which linux in installed. If you're not sure, type "fdisk -l". A table will appear. Then read off the device (first column) corresponding to the system "Linux" (last column).

Hmmm... got kinda verbose there.

adz 06-30-2003 09:06 AM

Oh about the drivers... No you wont have to go through the dual-booting nightmare again. Different drivers install differently. Just boot linux and follow the vendor instructions. Driver installation *SHOULDN'T* affect your booting.

netwench 06-30-2003 09:45 AM

thanks so much! verbose is good- i USE linux (worked for isps, web stuff, etc) i've never installed it.
i really needed thos directions as to how to make lilo point to the linux partition- i want windows to be the boot manager. i will try this tonite (going to work) and report back.

and about drivers, i get it now. but what about an "upgrade" to rh itself? i have no gui, so i don't know how to do that (besides i still haven't config'd the onboard nic) so i'm asumming i can put in a cd and upgrade..? or? that's where i was worried about having this dual boot nightmare again. it seems the minimum version i need is rh 8.... just don't know how to make it that....


adz 06-30-2003 10:10 AM

Not entirely sure about the upgrading procedure on RH. On debian it's just "apt-get upgrade" (as root). I understand that RH also has apt-get... Am I right?

Mind you, you have to have your /etc/apt/sources.list file configured properly. If you have apt-get, type "man apt-get" and "man sources.list" for more detailed info.

All times are GMT -5. The time now is 06:21 AM.