-   Linux - Newbie (
-   -   No /boot/initrd*.img in RH7? (

stoub 12-15-2002 10:59 PM

No /boot/initrd*.img in RH7?
I'm trying to get my system to triple-boot, with WindowsME, Red Hat 7.1 and Mandrake 9.0. WindowsME and RedHat had been installed and I installed Mandrake, which took control of Lilo. I can boot into WindowsME and Mandrake no problem. Right now, I'm trying to figure out how to get Red Hat back.

Some of the previous postings on this site have suggested that I need to copy Red Hat's /boot/vmlinuz and /boot/initrd*.img files to Mandrake's /boot/ (renaming to something like "vmlinuz-RH" and "initrd-RH"). However, when I looked in the RedHat /boot partition, there is no initrd file. I'm looking for suggestions about how to proceed from here...

I'm not sure if this is relevant or not. My RedHat 7.1 came with kernel 2.4.2. When I ran up2date and loaded a new kernel (2.4.18), Red Hat's Lilo (this was before I got Mandrake up) detected that kernel, but it was never able to boot into it. Booting into RH7.1 with the 2.4.2 kernel worked ok.

Thanks in advance!

All times are GMT -5. The time now is 07:41 AM.