-   Linux - Newbie (
-   -   No audio, HDA intel sound card on a toshiba netbook running slackware 13 (

thenewguy24 01-30-2010 02:56 PM

No audio, HDA intel sound card on a toshiba netbook running slackware 13
I have a toshiba netbook, and I'm running linux slackware 13. The sound card is an HDA intel. So far I've ran alsaconf and configured the above mentioned sound card. I've also gone into the alsamixer and unmuted everything and turn the volume up. I get absolutely no audio. Any help would be greatly appreciated.

GrapefruiTgirl 01-30-2010 03:06 PM


bash-3.1# cat /etc/modprobe.d/sound.conf

alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd_hda_intel msi=1 model=6stack-dig


Assuming your snd-hda-intel driver is built as a module (not statically into the kernel), You may benefit from creating a file similar to the above, only change the "model=" designator to a different one, one that specifically applies to the sound card in your machine.
For whatever reason, the identical soundcard in a laptop is operated differently than one in a desktop machine.
My computer is a desktop, and the above is what I use (though my device is now actually detected by the kernel, since a patch was applied, so this for me is not needed now) but there are a whack of other "model" options you might try, that may help.
Normally I wouldn't offer this as a first step, but you have already tried the usual first step, that being alsamixer and alsaconf.

Search google for possible "model" options; or read the documentation inside the kernel source's /Documentation folder, or read the kernel source-code in /snd/pci/hda/patch-realtek.c for the options in your particular kernel release.

Best of luck! Oh, and when you change the "model" in the file above (if you create such a file) you will; need to reboot for it to work.


thenewguy24 01-30-2010 05:00 PM

I'm having trouble finding the different options you mentioned. I found what I think is the right Documentation directory and I've read some of the txt files, but I'm not seeing anything on the options. Also do I need to include all the aliases that were in your file or just the final options line.

GrapefruiTgirl 01-30-2010 05:23 PM

Let me give a better, more accurate location of the documentation file :)

<your-kernel-source>/Documentation/sound/alsa/HD-Audio.txt # definitely read this one

And no, you don't absolutely need to put the other options in my file. I'm not sure if they are always identical for every machine using that driver, so I suggest trying without those options first, and focus mainly on the "model" option.

If you get nowhere with the model= option, we'll revisit the other options.

PS - I also thought your post read "notebook" rather than "netbook", and since it's a netbook, 100% support may not yet be in the kernel if the netbook is very very new; however, a model= option will hopefully still get you reasonably close, if not perfect, audio working.

If you get nowhere, we can dig some more info out of your computer, and have a look right into the driver sourcecode (I'll do that if you like) and see if there's any code for your device.


damgar 01-30-2010 05:28 PM

This is probably of no use to you, but I found that unmuting in alsamixer didn't work for me, however, unmuting through kmixer did. That was on my first slack13 installation. I can't explain it.

Specifically I have to select "configure channels"; select PCM; then unmute it.

GrapefruiTgirl 01-30-2010 05:31 PM

@ damgar -- yes, good point; also I have read of situations where if the headphone was NOT muted, the speakers didn't work.
Moral: fiddle with alsamixer a lot before giving up on it :)

thenewguy24 01-30-2010 05:42 PM

my sound card shows up as an HDA intel (ALC272) and there are no options listed for ALC272, am I missing something.

Peacedog 01-30-2010 05:42 PM

Hi newguy24, Welcome to LQ. If you know what card you actually have, the model options are a lot easier to sort out. HDA Intel covers a lot of different chips. Please post the output from the following so we can see what we're working with.


cat /proc/asound/card0/codec#* | grep Codec
Once we know which card you actually have it'll be easier to sort this.
Good Luck. ;-)

thenewguy24 01-30-2010 05:48 PM

Ok the output of
cat /proc/asound/card0/codec#* | grep Codec
is Codec: Realtek ALC272

thenewguy24 01-30-2010 05:54 PM

thank you to everyone who has been helping so far and damgar how do you access kmixer

damgar 01-30-2010 06:01 PM

In KDE session:

1. right click speaker icon in tray
2. show mixer window
3. settings
4. configure channels
5. select appropriate channels.

For me and many others PCM is the magic channel. There will probably be 2 selections for PCM. I'd select them both.

6. Ok or apply or whatever
7. in mixer window unmute PCM (one or the other, maybe both. I always unmute everything.

That's for my desktop systems. There maybe a different channel or something that will be obvious to you when you are looking, so I'd maybe choose everything in step 5.

thenewguy24 01-30-2010 06:17 PM

damgar I did that already I didn't know that was the kmix, but I don't have a PCM channel in kmix, I only have one in alsa(which I already unmuted)

thenewguy24 01-30-2010 06:19 PM

sasha, should I try options from the ALC262 to see if any will work for me (ALC272) or is that a waste of time

Peacedog 01-30-2010 06:24 PM

The options you want are for the ALC662/663/272 group, however, I think Slack13 shipped with alsa drivers 1.0.18. So the ALC272 quirks may not be recognized by that version. You may need to upgrade your alsa driver modules. Here are the quirks, you can give them a whirl if you like.


  3stack-dig        3-stack (2-channel) with SPDIF
  3stack-6ch        3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig        6-stack with SPDIF
  lenovo-101e        Lenovo laptop
  eeepc-p701        ASUS Eeepc P701
  eeepc-ep20        ASUS Eeepc EP20
  ecs                ECS/Foxconn mobo
  m51va                ASUS M51VA
  g71v                ASUS G71V
  h13                ASUS H13
  g50v                ASUS G50V
  asus-mode1        ASUS
  asus-mode2        ASUS
  asus-mode3        ASUS
  asus-mode4        ASUS
  asus-mode5        ASUS
  asus-mode6        ASUS
  dell                Dell with ALC272
  dell-zm1        Dell ZM1 with ALC272
  samsung-nc10        Samsung NC10 mini notebook
  auto                auto-config reading BIOS (default)

Good luck. ;-)

thenewguy24 02-01-2010 09:31 AM

Ok, I tried several of the options, but when I try them and reboot it tells me I've removed my sound card and there isn't one active. Is there a way to update alsa and get new drivers for my sound card.

Thanks for all the advice so far.

All times are GMT -5. The time now is 01:55 AM.