LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2018, 06:14 PM   #1
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Rep: Reputation: 22
No Audio


I can't believe I have to ask this, but how could Sound not work, in the 21st century?

Just replaced my mobo with an Asus Prime Z270M Plus. But sound has never worked out of this new mobo, whether line out, S/PDif, or HDMI. RHEL7.4 + KDE4.14.8-6.

Obviously it would be best if HDMI audio worked, but I can't make anything work.

# lspci -k
...
00:1f.3 Audio device: Intel Corporation 200 Series PCH HD Audio
Subsystem: ASUSTeK Computer Inc. Device 86d4
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
...

# lsmod |grep snd_
snd_hda_codec_hdmi 49152 1
snd_hda_codec_realtek 94208 1
snd_hda_codec_generic 69632 1 snd_hda_codec_realtek
snd_hda_intel 40960 3
snd_hda_codec 126976 4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core 81920 5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep 16384 1 snd_hda_codec
snd_seq 65536 0
snd_seq_device 16384 1 snd_seq
snd_pcm 94208 4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer 32768 2 snd_seq,snd_pcm
snd 77824 16 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd _seq_device,snd_hda_codec_realtek,snd_pcm

# aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default
Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
HDA Intel PCH, ALC887-VD Analog
Default Audio Device
front:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
Front speakers
surround21:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
HDA Intel PCH, ALC887-VD Digital
IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=PCH,DEV=0
HDA Intel PCH, HDMI 0
HDMI Audio Output
hdmi:CARD=PCH,DEV=1
HDA Intel PCH, HDMI 1
HDMI Audio Output
hdmi:CARD=PCH,DEV=2
HDA Intel PCH, HDMI 2
HDMI Audio Output

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

# cat /sys/class/sound/card*/id
PCH

# aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0



This silence all of a sudden just started one day when I installed the ASUS. Same CPU, memory, OS, and everything else as before. Am I going to have to completely reinstall this host server? Or should I ditch ASUS which I've trusted for a long time?

Last edited by Quantumstate; 02-01-2018 at 06:19 PM.
 
Old 02-01-2018, 06:41 PM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
Did you run pavucontrol and played with settings?
 
Old 02-01-2018, 11:52 PM   #3
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Original Poster
Rep: Reputation: 22
Yes, and in fact payback volume was all the way down, so I set it to 100%. And in Config I have it set to Digital Stereo (HDMI) output.

And when I play music, in pavucontrol-qt's Playback tab it shows the VLC audio strength jumping around. But no music out HDMI.

I also have KDESettings|Multimedia|Phonon|AudioHardwareSetup set to Digital Stereo (HDMI) Output, although I have no idea of the relation between Alsa, PulseAudio, and Phonon.

In KMix there's only one slider in Playback, Built-In Audio Digital (HDMI) Stereo, and it's at 100%. Running alsamixer I have everything unmuted (00) and set to 100%.

I'd almost rather reinstall the server OS, than take the whole server apart again to replace the mobo with some unknown mobo.
 
Old 02-02-2018, 12:12 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,928
Blog Entries: 1

Rep: Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832
HDMI audio tends to be quirky.

$ egrep -r -i hdmi /proc/asound/*

And you might find that HDMI audio is hw:0,3 (where default audio is hw:0,0). The simple-est fix IMO is to have a custom .asoundrc. Although with pulseaudio, pavucontrol might work well enough.

FILE: $HOME/.asoundrc
Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 3
Assuming that HDMI audio output is hw:0,3.
 
Old 02-02-2018, 12:20 AM   #5
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Original Poster
Rep: Reputation: 22
My gosh, it is 3. Setting /etc/asound.conf now.

# cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7740000 irq 165

# cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
Codec: Intel Skylake HDMI

# alsactl init 0
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,104386d4,00100302 HDA:80862809,80860101,00100000" "0x1043" "0x86d4"

# alsactl init 3
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,104386d4,00100302 HDA:80862809,80860101,00100000" "0x1043" "0x86d4"
Hardware is initialized using a generic method

# egrep -r -i hdmi /proc/asound/*
/proc/asound/card0/codec#2:Codec: Intel Skylake HDMI
/proc/asound/card0/codec#2: Device: name="HDMI 0", type="HDMI", device=3
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x58560010: [N/A] Digital Out at Int HDMI
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x18560020: [Jack] Digital Out at Int HDMI
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x58560030: [N/A] Digital Out at Int HDMI
/proc/asound/card0/eld#2.0:connection_type HDMI
/proc/asound/PCH/codec#2:Codec: Intel Skylake HDMI
/proc/asound/PCH/codec#2: Device: name="HDMI 0", type="HDMI", device=3
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x58560010: [N/A] Digital Out at Int HDMI
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x18560020: [Jack] Digital Out at Int HDMI
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x58560030: [N/A] Digital Out at Int HDMI
/proc/asound/PCH/eld#2.0:connection_type HDMI
/proc/asound/pcm:00-03: HDMI 0 : HDMI 0 : playback 1
/proc/asound/pcm:00-07: HDMI 1 : HDMI 1 : playback 1
/proc/asound/pcm:00-08: HDMI 2 : HDMI 2 : playback 1

------------------------------------------------------------------
Edit

Rebooted and still no sound. In /etc/asound.conf:
#**********************************************
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 3
#**********************************************
.. and then rebooted

In pavucontrol-qt I can set audio out to Analog Line Out, and it sees that it is plugged in. But when I set the receiver to this, no audio. All volumes are over 100%.

When in pavucontrol-qt I set audio out to HDMI3, it says it is unplugged. I beg to differ; the projector works. All volumes over 100% and no audio.

------------------------------------------------------------------
Edit 2

Ok in alsamixer I unmuted S/PDIF and got music! This is definitely over HDMI as I have it plugged directly in to powered speakers.

I don't understad why S/PDIF would have an influence over HDMI audio? There is an S/PDIF header on the mobo but I haven't tried it yet. No idea what the settings for that would be in pavucontrol-qt, or KDE settings?

And I don't understand why no alsamixer's volume sliders would work on it?

I then plugged the HDMI in to the receiver and got projector (video) but no audio. This is probably a receiver setting.

Going to bed angry again tonight... but with at least a little hope.

Last edited by Quantumstate; 02-02-2018 at 01:15 AM.
 
Old 02-02-2018, 10:00 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,928
Blog Entries: 1

Rep: Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832
If you're using an HDMI to DVI adapter, the DVI signal is the same as HDMI, but lacks the audio connections.

S/PDIF can be optical or analog, which uses the regular audio jack. For some soundcards you have to change the TYPE of output to get mixer settings that can be adjusted. But if you're doing HDMI audio, you need to use the soundcard on the GRAPHICS card.

$ cat /proc/asound/cards

$ speaker-test -c 2 -l 1 -D hw:3,3

And if you have multiple monitors out, and you're not on the default one, it could be ,5 ,7 ,8 ,9 and such.

$ egrep -r -i hdmi /proc/asound/*

YMMV.
 
Old 02-02-2018, 12:21 PM   #7
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Original Poster
Rep: Reputation: 22
I only have one sound 'card', which is the one internal to the Intel CPU. Also using the Intel internal GPU.

Well I had audio briefly... until I rebooted. Now I can't make it come back to save my life. In pavucontrol-qt it thinks all HDMI interfaces are "unplugged". I've tried every permutation in pavucontrol-qt and nothing works.

When I had audio working last night no alsamixer setting had any influence over the audio except S/PDIF, which would only mute/unmute. No volume control was possible. I did have co-ax and optical S/PDIF plugged in, but while the music was playing I unplugged both and it continured so it must have been HDMI. And I had projector, which is HDMI.

I don't understand why pavucontrol-qt sees no HDMI plugged in anywhere, when I have projector.

# cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7740000 irq 165

# egrep -r -i hdmi /proc/asound/*
/proc/asound/card0/codec#2:Codec: Intel Skylake HDMI
/proc/asound/card0/codec#2: Device: name="HDMI 2", type="HDMI", device=8
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x58560010: [N/A] Digital Out at Int HDMI
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x18560020: [Jack] Digital Out at Int HDMI
/proc/asound/card0/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/card0/codec#2: Pin Default 0x58560030: [N/A] Digital Out at Int HDMI
/proc/asound/card0/eld#2.0:connection_type HDMI
/proc/asound/PCH/codec#2:Codec: Intel Skylake HDMI
/proc/asound/PCH/codec#2: Device: name="HDMI 2", type="HDMI", device=8
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x58560010: [N/A] Digital Out at Int HDMI
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x18560020: [Jack] Digital Out at Int HDMI
/proc/asound/PCH/codec#2: Pincap 0x0b000094: OUT Detect HBR HDMI DP
/proc/asound/PCH/codec#2: Pin Default 0x58560030: [N/A] Digital Out at Int HDMI
/proc/asound/PCH/eld#2.0:connection_type HDMI
/proc/asound/pcm:00-03: HDMI 0 : HDMI 0 : playback 1
/proc/asound/pcm:00-07: HDMI 1 : HDMI 1 : playback 1
/proc/asound/pcm:00-08: HDMI 2 : HDMI 2 : playback 1

# speaker-test -c 2 -l 1 -D hw:3,3
speaker-test 1.1.3

Playback device is hw:3,3
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Playback open error: -2,No such file or directory

Last edited by Quantumstate; 02-02-2018 at 12:25 PM.
 
Old 02-02-2018, 06:55 PM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,928
Blog Entries: 1

Rep: Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832
You often have more than one soundcard on modern systems. Even if one is INPUT only like a webcam. Desktops often have one on the motherboard, and one on the graphics card. Based on previous output try:

$ speaker-test -c 2 -l 1 -D hw:0,3
$ speaker-test -c 2 -l 1 -D hw:0,7
$ speaker-test -c 2 -l 1 -D hw:0,8

It could be that the user is not in the audio group. Although you wouldn't have any sound under any conditions for that scenario. It might be that the projector is HDMI to DVI adapted internally and has NO audio through that connection.
 
1 members found this post helpful.
Old 02-02-2018, 06:58 PM   #9
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Original Poster
Rep: Reputation: 22
So I've figured out what it is.

You have to spend days, spinning your wheels and banging your head against the wall, before PulseAudio yields and decides to lift the gate and work with HDMI.

I don't know what fixed it, but I'll tell you what I did. I'd edited /etc/asound.conf to put in the three recommended lines choosing HDMI device 3, but at some point something thoughtfully erased that file for me.

Following another lead, I renamed /usr/bin/pulseaudio to /usr/bin/XpulseXaudioX, killed the running pulses and tried it. Suddenly all my devicen appeared in KDE|Settings|Multimedia! And multiple ones worked... until I rebooted.

So I re-enabled Pulse, went in to BIOS and changed the audio device from S/PDIF to HDMI. I morosely booted to find as usual no sound. Sadly and barely able to do it, in KDE Settings I tried the devices one-by-one, but suddenly AUDIO! it was in "BuiltIn Audio Digital Stereo (HDMI 2)".

I don't know why HDMI 2, but I moved that to the top for Music and Video, Applied, and rebooted. I still have audio. Who knows how long it will last, but maybe I can watch TV at least tonight...

And Shadow 7, I think you mean that in modern systems (like ones with CPU-embedded video and audio), you have only one sound 'card' but can have multiple devices in that sound 'card'. Thanks for your help man. You got me through this.

Last edited by Quantumstate; 02-02-2018 at 07:04 PM.
 
Old 02-02-2018, 07:10 PM   #10
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,928
Blog Entries: 1

Rep: Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832Reputation: 832
There's "autospawn = no" that you can put in /etc/pulse/client.conf. This allows you to stop pulseaudio $(pulseaudio --kill) and have it stay stopped. Sounds a bit like what you're accomplishing through more subversive methods. A useful trick if you play with jackd and other audio methodologies.
 
Old 02-03-2018, 12:11 AM   #11
Quantumstate
Member
 
Registered: Jun 2005
Location: Seattle, Ecotopia
Distribution: CentOS 7.4 with KDE
Posts: 262

Original Poster
Rep: Reputation: 22
Yes I reversed that little change. Unfortunately Pulse is in control again.

I think this was a combination of things.
- My receiver had to have "HDMI Control" (CEC) on -and- the HDMI amp on.
- My Asus Prime Z270M Plus BIOS had to have HDMI set to HDMI -not- S/PDIF.
- In KDE|Settings|Multimedia|Phonon|Controls I had to choose the -right- device for music and video. ("HDMI 0") As a precaution I also moved this to the top for preference in both.
- In pavucontrol-qt I had to turn up the volume to 100%. (It was at 0)

In retrospect this was not as soul-crushing as setting up Postfix/Dovecot/Spamass/ClamAV, but more so than setting up Libreswan.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How To Enable Beats Audio Subwoofer Audio On a HP Laptop In Ubuntu/Linux LXer Syndicated Linux News 0 12-05-2015 08:33 AM
can no longer change audio settings, missing gstreamer plugin or no audio device dsollen Linux - General 3 11-16-2009 08:40 AM
[SOLVED] Onboard Audio (hda_intel) for Mic Input and Soundcard (ca0106) for Audio Output? snowdonkey Linux - General 1 07-11-2009 03:17 PM
smplayer: video+audio stutters with pulseaudio, audio files play fine GamerX Linux - Desktop 1 02-06-2009 08:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration