-   Linux - Newbie (
-   -   'nixing freebsd in favour of SuSE (

hyper guy 02-06-2004 09:17 AM

'nixing freebsd in favour of SuSE
I'm stuck. My excitement over finally attempting to make the jump to linux has turned to teeth-gnashing frustration. Heard that before? Ok, I'm another silly windoze boob who tried to jump blindfolded (hopin for blind luck methinks ;-). Still, help me. Please.

Tried to go with the big monster freebsd. I *think* it actually worked, but i couldn't get it to see my (rather ordinary i tho) ps/2 mouse. Or get the x windows bit to work (i'm sure i buggered up the process somewhere, zigging instead of zagging -- or vice versa, who knows).

Anyhoo, decided i'd try something supposedly much friendlier: SuSE. So I burned an image of the boot iso like they tol' me to. I was pretty sure popping that disc in when i still had Freebsd on my system wouldn't work, and i was right (for once). Surfed around a bit and the only (best?) advice i could find about removing/uninstalling bsd from my system was to go to the fdisk app and make it change the type (?) of my hard drive (or wotever) to 131 (which, as i unnerstand it, is s'posed to be linux).

One prayer-accompanied reboot later (with the suse boot disc in my cd-rom drive) and all i see on my screen is a woefully bleak:

"Operating system not found"

Now wot? I've got a pretty old system (an IBM ambra system circa '96? -- cyrix PII clone with a 3gb hd), but i was hopin it'd have many more years of service left in it before turning into the over-engineered paperweight it is now.

How the hell do i fix this?

hw-tph 02-06-2004 09:36 AM

1. FreeBSD is a BSD derivate using a Mach kernel, not Linux. They both use the base GNU operating system though, so most utilities are the same on both platforms. But FreeBSD still isn't Linux.

2. You should be able to remove your FreeBSD partitions from the SuSE setup program. Just remove all partitions on the hard drive and create new ones for Linux instead. I believe SuSE has an "auto" mode where it decides which partitions to create where and what size they should be.

3. It sounds like your computer isn't even trying to boot from the CD-ROM when you have the SuSE CD in it. Enter your system BIOS (usually accessed by pressing F1, F12 or Del when the system boots) and change the boot order to include the CD-ROM *before* the first drive. So something like this is sane and useful: 1st boot device - floppy, 2nd boot device - CD-ROM, 3rd boot device - First hard drive, 4th boot device (if available) - external IDE or SCSI. Then try booting from the CD again.


hyper guy 02-06-2004 10:09 AM

Thanks, Hakan (<--- sorry, couldn't figure out the accent thingie)

1. yeah, you're absolutely correct, of course. wot i should've said was i was all in a tither about moving from windows to *nix...i was curious to start off with the OS the supposed snooty *nix "elites" use. got mah fingers burned (big time).

2. when i tried to boot the system with the suse boot disc, the system just seemed to ignore the fact i had a disc in there and went ahead with it's usual boot to freebsd.

3. as far as i can tell, my system IS set up to check the cd-rom first. that's how i got freebsd on there (i hadda burn a freebsd disc beforehand). i've just interruped the boot (with F2) and checked the boot setup and confirmed it. an idear...i'll b back...

hyper guy 02-06-2004 10:23 AM

Well wot i done did now was shut off the system and reboot with the freebsd install disc i had before, and it seemed to start the same ol install process again no prob.

so now i'm back to square 1 (or is that 2): i have freebsd back on my system again. but i would still like to remove it in favour of suse.

it would appear there might be something amiss with the suse install disc then??

Smartcat99S 02-06-2004 05:11 PM

try using dos fdisk to delete the partitions and then use the suse install disk (yes, I know M$ products are crappy, but this might just actually work.

t3___ 02-06-2004 05:32 PM

hold up... key questions here... how did you aquire and how are you trying to install suse?

the only bootable suse disk is a 40 MB install "jumpstart" type disk that allows you to [very important point here]load network drivers and connect to a smb, nfs, ftp share or 2ndary hard disk that contains the [6gig] suse distribution! I repeat, suse does not have a bootable iso disk that actually contains the distribution available for download. this confuses a lot of people.

if you look at the directory listing for that suse boot disk, you should see the following:

boot (a folder)
media.1 (a folder)
content (a file)

if the contents of that disk look like a standard linux distrobution with about 6 folder and a handful of files, you will never get it to boot.

please clarify - T

t3___ 02-06-2004 05:33 PM

oh, and regarding your original question about how to remove the BSD partitions, SUSE will wipe them by default and create its own partitions during the install process.

hyper guy 02-06-2004 09:51 PM

sorry for the late reply -- i was beginning to think i was too messed up to help. thanks again.

smartcat -- i'm afraid i no longer have any M$ s/w on my system. it's totally freebsd now.

t3 -- glad to hear suse will do the "heavy" lifting wiping out freebsd for me -- if i can ever get it to work. wot i got from the suse site was some kind of initial boot files (but i didn't get it from their "current" section, but from their "9.0" folder, if that makes a diff). it's about 20mb worth, and i burned the iso image (?) from when i look at wot i have on the disc, i see 2 folders ("boot", "media.1") and one file named "content" (can't really tell what file type it is). so, pretty much like you were bettin.

inside the boot folder is another folder, "loader" and a file named, "rescue." inside loader is a bunch of .spl files, one called isolinux.bin, isolinux.cfg and a few other files.

inside the media.1 folder are two files, "media" and "products" (again file type unknown).

i hope that clarifies things for you, cuz none of that means diddly to me :-D

did i download the wrong stuff??

thanks again

All times are GMT -5. The time now is 03:59 AM.