-   Linux - Newbie (
-   -   NIVIDIA Video Driver and X-Server (

kuwaitikid 11-13-2009 02:35 AM

NIVIDIA Video Driver and X-Server
I am running Fedora 10 and trying to install the NVIDIA Driver GeForce 8700M Video Card on my Toshibia Laptop. I have the correct NVIDIA driver software to do this but the installation program tells me that because I am running an X Server it cant install the driver. Could someone please tell me how to turn off this X-Server?

trist007 11-13-2009 02:38 AM

X-Server is the gui desktop you are running. Try logging out to where you are in the text only interface. Then run the driver install program there.

brianL 11-13-2009 06:52 AM

Shut down X by running (as root):

telinit 3

mrrangerman 11-13-2009 08:37 AM


X-Server is the gui desktop you are running.

No the X-server in NOT the gui desktop, that would be the Window Manager ie. KDE, Gnome, Fluxbox. The X-server allows the WM to work. They are two separate things but work together, you can run X-server session without the use of a WM but you can't run a WM without a X-server session running.


Fallow reply #3 to stop the X-server from running.

kuwaitikid 11-13-2009 09:06 AM

I tried running Telinit 3 command as "Root" and my video display breaks up and freezes. Below is the error message that the NVIDIA Driver installation program returns:

ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver download page at

mrrangerman 11-13-2009 09:20 AM

While in your Desktop environment press Ctrl+Alt+F1 this will put you in a command console, at the prompt log in as root, confirm with root passwd. Once logged in run the command


telinit 3
Now cd to the directory containing the Nvidia driver you downloaded and run it.

lewc 11-13-2009 09:26 AM

try repeatedly pressing ctrl+alt+backspace, eventually X will tell you it will restart in [X] amount of time, then you can quickly run your script, I think my X gives me 2minutes which should be enough time, alternatively I believe you can boot into a different runlevel by changing grub options which will take out the GUI. try modifying the grub at boot time rather than doing it by changing grub.cfg or menu.lst because this way changes are lost by next boot

kuwaitikid 11-13-2009 10:05 AM

In the command line mode now when I run telnet 3 the system returns:

telenet: connect to address invalid argument

I am sorry but I am little lost with this.

mrrangerman 11-13-2009 10:17 AM



In the command line mode now when I run telnet 3 the system returns:
NOT telnet it's telinit 3.

kuwaitikid 11-15-2009 12:04 PM

Finally it works, thankyou everyone, your help was very much appreciated

All times are GMT -5. The time now is 11:28 PM.