LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-07-2011, 03:24 AM   #1
amitvasani
LQ Newbie
 
Registered: Jun 2011
Location: Ahmedabad
Distribution: Redhat
Posts: 2

Rep: Reputation: Disabled
Smile NIC driver installation issue due to change in kernel..


Hi guys,
I am facing a problem that after upgrading RAM from 2 GB to $ GB in my ASUS-P5KPL AM-PS board with Realtek r8168 driver that was previously labled
as r8168.ko, but now as I reinstall Redhat Linux 5.1 (same as before),
but the kernel is looked now like 2.6.18-53.el5.PAE insted of 2.6.18-53.el5. (What is this PAE.???)
and now as I am going to install the LAN driver same r8168.ko file on the same path as before /lib/modules/2.6.../.../net directory using the
insmod command. it throws an error that "Invalid module format.."
so tell me please How can I get .c source file of the LAN driver and how can i compile it again to
.ko file to make it working again with this PAE kernel..??
Please Help..!!!

Last edited by amitvasani; 06-09-2011 at 12:05 AM. Reason: for better understanding..
 
Old 06-07-2011, 03:55 AM   #2
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Rep: Reputation: 37
First check Which modules are existing?

Code:
# modprobe -l | egrep 'pcnet32|vmxnet|e1000'
If you find anything here you may load it and try like below.

Code:
#modprobe e1000
restart the machine to take it into effect.
 
Old 06-08-2011, 11:50 PM   #3
amitvasani
LQ Newbie
 
Registered: Jun 2011
Location: Ahmedabad
Distribution: Redhat
Posts: 2

Original Poster
Rep: Reputation: Disabled
Smile

The modprobe command displayes the twol lines of output of e1000 and e1000e modules at the given path
but It haven't solved the problem. my r8168.ko file still can't work.guy., even after restart.
 
Old 06-09-2011, 12:07 AM   #4
pinga123
Member
 
Registered: Sep 2009
Posts: 684
Blog Entries: 2

Rep: Reputation: 37
Try loading

Code:
modprobe e1000
restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian on HP ProLiant DL380 - NIC Driver installation issue ( firmware-bnx2 ) RouterRat Linux - Server 1 04-07-2011 10:45 AM
Kernel Deleted due to Upgrade, Cannot Reinstall Kernel due to Dependency Issues Kenji Miyamoto Debian 2 02-17-2007 10:44 AM
is the ipw3945 driver due for inclusion into upcoming kernel? steve1401 Linux - Wireless Networking 4 04-06-2006 11:58 AM
can't DHCP, i think due to ioctl's busy(?). sis900 NIC, linksys router, 2.4 kernel FirebirdV0273 Linux - Networking 2 02-11-2006 04:43 PM
change in resolution due to driver zexter Linux - General 1 11-01-2003 11:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration