-   Linux - Newbie (
-   -   NFS stale file handle and not using NFS (

odjb 10-19-2009 06:34 AM

NFS stale file handle and not using NFS
I did a backup of the ssd on my eeepc using the following command from a Linux Mint on a USB key :

dd if=/dev/sda1 of=/media/disk/eeepc_save/SYSTEM/system.bck
(/media/disk in an external USB disk)

I deleted the ext2 partition using GPartEd on live USB key and created it back.
I rebooted Linux Mint and restored the filesystem using the opposite command :

dd if=/media/disk/eeepc_save/SYSTEM/system.bck of=/dev/sda1

I mounted /dev/sda1 and when I "ls" the root directory, I get several "NFS stale file handle" messages concerning directories (/dev and other).
I tried "e2fsck -y", had a bundle of corrections that resulted in the deletion of the directories.

I don't use NFS.
I did the same for the user filesystem and had no problem (it's an ext3 partition)
The two filesystems are the ones that came with the original Xandros installed on my eeepc and that were mounted with union-fs.

This is not a serious issue as this was only a test but I'd like to understand.

Any help greatly appreciated.


janoszen 10-25-2009 04:25 AM

NFS off?
How about turning NFS off and unloading the kernel modules if possible? What does that do?

chrism01 10-25-2009 07:10 PM


rpcinfo -p

and post the results

odjb 11-05-2009 09:41 AM

get rid of xandros
thank you for the answers but i definitely gave up the xandros installed on my eeepc. i kept the images i made and i realized that, in fact, the root image was useless as it is a read-only filesystem that never changes. as i hadn't problems with the the user filesystem image, i kept this one and get rid of the other. (i tried a restore by reinstalling the whole system and made a dd of the user filesystem image over the new one and it worked fine.)

P.S. : i now use linuxmint wich seems much better than xandros. i also gained about 1 and a half GB as xandros was using unionfs.

All times are GMT -5. The time now is 09:03 PM.