LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   NFS & Samba (https://www.linuxquestions.org/questions/linux-newbie-8/nfs-and-samba-669961/)

sherrylady 09-15-2008 02:19 AM

NFS & Samba
 
Hey Guys
I have a folder (Which has 3 sub folder) on a Linux client (Unbreakable Linux) which keeps updating through Oracle, This folder is shared through NFS with another Linux client (CentOs) everything is fine upto here I have permission to read write copy and delete all files and sub folders. The only problem is gives me failed to shutdown when I try to restart NFS. This shared folder on CentOs is shared through samba with a windows xp client. But when I try to copy files from sub folders to Windows gives me permission Error. And at the same time when I try to parse XML files in teh sub folders it gives me permission Error!!!
Any Ideas?

Thanks
Sherry

BrianK 09-16-2008 10:56 PM

first off - why would you restart NFS? (that's rhetorical ;))

You say it gives you "Failed to shutdown" - what failed to shutdown? NFS? If NFS is what you're referring to, have you tried stopping nfs rather than restarting? If so, what happens?

When you connect from the windows machine via samba, what username are you using to connect? Does that user have read/write permissions? Can you write files anywhere from the Windows machine to a linux machine via samba? If you can, who owns the files and what are the permissions? How are you handling user/passwords in your samba config?

sherrylady 09-17-2008 01:40 AM

Hi,
Thanks for your reply, Yesterday I solved my problem by adding my nfs user in samba, but the biggest problem wasnt related to Linux! lol! The XMLs that was generating by oracle were corrupted!! thats why I couldnt parse them in windows.
Anyways thanks for your reply :)


All times are GMT -5. The time now is 03:08 PM.