LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2018, 09:23 AM   #1
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Rep: Reputation: Disabled
Newly Installed Linux Mint 18.3 Sylvia Cinnamon Edition Won't Boot


Hi all, first time poster here.

I just installed Linux on my laptop as a replacement to Windows 8.1, which was running slowly. The steps I used to install it were fully formatting and wiping my hard drive using Parted Magic and then installing Linux Mint 18.3 via a bootable USB. As far as I can tell, the install was successful, but when I try to boot from the hard drive I get a message "checking media presence, no media present."

I would really appreciate any help anyone could give me to get this working. I'm sure there's a lot more info I could provide that would be helpful, but I'm a true newbie, so could really use some guidance. Thanks in advance!
 
Old 01-07-2018, 06:02 PM   #2
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
UPDATE: Unsuccessful Boot Repair Attempt and Log

After searching around the internet for some solutions, I tried running Ubuntu Boot Repair through the terminal. It didn't fix my issue, but it did generate a log with what is probably lots of helpful info on the specifics of my system. It can be found here: https://paste.ubuntu.com/26341864/
 
Old 01-07-2018, 08:12 PM   #3
killingthemonkey
Member
 
Registered: Mar 2011
Location: Winston-Salem, NC
Distribution: Fedora, CentOS, Linux Mint
Posts: 181

Rep: Reputation: 19
Have you tried disabling secure boot in BIOS?
 
1 members found this post helpful.
Old 01-07-2018, 08:30 PM   #4
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Secure boot is disabled.
 
Old 01-07-2018, 09:25 PM   #5
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,608

Rep: Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772
Did you remove the usb you used to install Mint?
Did you change the BIOS as recommended in boot repair to point to:

Quote:
Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/shimx64.efi file!
You needto enter the BIOS to make this change and the method varies with manufacturer, you should see a message on boot telling you which key to use.
 
1 members found this post helpful.
Old 01-07-2018, 09:33 PM   #6
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
Did you remove the usb you used to install Mint?
Yes, the USB is removed.

Quote:
Originally Posted by yancek View Post
Did you change the BIOS as recommended in boot repair to point to:

You needto enter the BIOS to make this change and the method varies with manufacturer, you should see a message on boot telling you which key to use.
The boot order is set to boot the HDD/SSD first. Is that the setting this is referring to or is it something different?
 
Old 01-08-2018, 08:11 AM   #7
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 8,608

Rep: Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772Reputation: 1772
Quote:
The boot order is set to boot the HDD/SSD first. Is that the setting this is referring to or is it something different?
You need to get into the BIOS and specifically select the shimx64.efi file. You need to explore your BIOS to find how to do that as it varies with manufacturer. The 'shim' file is generally only needed when Secure Boot is enabled, see the link below.

https://askubuntu.com/questions/3423...64-and-shimx64

Maybe it wasn't disabled when you ran the script since generally what is used to boot with Secure Boot disabled is grubx64.efi.
 
1 members found this post helpful.
Old 01-08-2018, 05:31 PM   #8
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by yancek View Post
You need to get into the BIOS and specifically select the shimx64.efi file. You need to explore your BIOS to find how to do that as it varies with manufacturer.
I went through all the setting in my BIOS and didn't see any way to specifically select a file. The closest I found was a setting that let me change Boot Mode from UEFI Boot to CSM boot. I tried this and I got a different message when I restarted (see attached).

If it's helpful, I can also upload photos of all the menus available to me in BIOS.
Attached Thumbnails
Click image for larger version

Name:	UEFIBoot.jpeg
Views:	133
Size:	93.5 KB
ID:	26698  
 
Old 01-08-2018, 06:04 PM   #9
cbertram68
LQ Newbie
 
Registered: Jan 2018
Location: Downey CA
Distribution: Linux Mint
Posts: 10

Rep: Reputation: Disabled
That last screen is for running an OS off a network, in your boot order it would be 3rd or 4th option that the BIO tries to run when it can't find a Hard Drive or other media to boot from.

SO first thing is to change that setting back to uefi.

Next, can you get to the grub bootloader?

Do do this restart the machine, and right after POST, which is when you see the manufacturer portion of boot happeing (where you can enter the BIOS etc) hold down the shift key, and it should go into grub.

Send us a picture of that if it works.

Chris
 
1 members found this post helpful.
Old 01-08-2018, 06:41 PM   #10
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cbertram68 View Post
Next, can you get to the grub bootloader?
I changed Boot Load back to UEFI Boot. Then I tried several times to get grub bootloader, but no luck. I did get a new screen which flashes on for a couple of seconds before disappearing. It says "Failed to open \EFI\BOOT\grubx64.efi - Not Found..." (see attached)
Attached Thumbnails
Click image for larger version

Name:	failedtoopen.jpeg
Views:	64
Size:	101.9 KB
ID:	26699  
 
Old 01-08-2018, 06:53 PM   #11
cbertram68
LQ Newbie
 
Registered: Jan 2018
Location: Downey CA
Distribution: Linux Mint
Posts: 10

Rep: Reputation: Disabled
OK, that at least tells us it is looking for GRUB to boot.

When you installed Mint when it got to the hard drive portion which option did you choose, did you let Mint do what it wanted, or did you choose something else?

Usually, the Live CD/USB will detect that your system is in UEFI mode, and install accordingly, but if you saw any options about legacy mode, or you made disc changes on your own during install that could be the problem.

Perhaps try doing the install again, and let Mint use the entire disc. Unless you are trying to dual boot or some other thing like that.
 
1 members found this post helpful.
Old 01-08-2018, 07:02 PM   #12
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cbertram68 View Post
When you installed Mint when it got to the hard drive portion which option did you choose, did you let Mint do what it wanted, or did you choose something else?
Yes, I used all the default options when installing.

Quote:
Originally Posted by cbertram68 View Post
Perhaps try doing the install again, and let Mint use the entire disc. Unless you are trying to dual boot or some other thing like that.
Do I have to do anything specific to let Mint use the entire disk? Or just go with the defaults again?
 
Old 01-08-2018, 07:08 PM   #13
cbertram68
LQ Newbie
 
Registered: Jan 2018
Location: Downey CA
Distribution: Linux Mint
Posts: 10

Rep: Reputation: Disabled
I am going through the installation dialogues in my mind, trying to remember if there was a specific question spot that would stop you. Let me look up the screens on the Linux Mint forums, and see if I can get you a good answer.
 
1 members found this post helpful.
Old 01-08-2018, 07:41 PM   #14
cbertram68
LQ Newbie
 
Registered: Jan 2018
Location: Downey CA
Distribution: Linux Mint
Posts: 10

Rep: Reputation: Disabled
I went and looked at the screenshot of the installation, I did not see anything that really jumps out at me.

In general, when I set up Mint, I choose the entire disc option and LVM (on laptops I may add disc encryption). Try it again, and make sure you read each dialogue to see if any info comes up about UEFI, I vaguely remember something, but it has been a few weeks since I did an install.

Also, I did not verify what hardware you are using, is the machine 64bit? Make sure your LiveCD/USB is the 64bit version if your computer is 64bit.

The only times I have had issues like you are seeing have to do with UEFI and Legacy, I know the latest LiveCD/USB is better aware of these, so make sure you are using the latest if you can.
 
1 members found this post helpful.
Old 01-08-2018, 08:33 PM   #15
bjacobsonny
LQ Newbie
 
Registered: Jan 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Wow! Not sure what changed but I think it's working now! I reinstalled Linux from the USB using only the default options. When I restarted, I still got the "checking media presence, no media present" message first, but eventually Linux booted up.

Thank you for the help Chris and Yancek!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to connect newly installed Linux Mint 18 Cinnamon to the internet samix Linux - Newbie 6 11-26-2016 05:22 PM
Newly installed Linux Mint 18 Cinnamon always crashes and runs in Fallback Mode Ptrjg Linux - Newbie 1 11-23-2016 09:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration