LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Newbie, please help. (https://www.linuxquestions.org/questions/linux-newbie-8/newbie-please-help-988/)

BC 02-22-2001 04:41 PM

Newbie, please help
 
Hello, I am a new user to Linux-Mandrake 7.2, I really like it alot and hope that I can get it all working properly. I have so many questions, but I'll start with two that I would like to have going asap.

1-When I installed Linux, it gave me the option of connecting to the internet and I tried to do so, one problem though it asked me where my modem was and gave me the options up to com 4. The problem is that my modem is hooked up to com 5. Does Linux only go up to 4? Is there any way I can get it to see com 5?

2-I am also having having problems trying to read my cd-rom. It is a sony rewrite. In the devices it shows up, after mounting it I't won't read. I have no problems with the floppy.

3-I also have no sound. It looks like things get loaded at bootup, but then that's all. Do I have to do things within Linux to get those to work?

Well I guess that was three to start, I could go on, but don't want to overwhelm anyone. Any help would be so much appreciated. I plan on reading other posts to see if there are anwsers to other questions I have.

Thanks so much!
BC

oh, and by the way, I have a 3com USR modem, and an Intel pentium III at 933 cpu speed with 256 RAM.



[Edited by BC on 02-22-2001 at 06:17 PM]

trickykid 02-23-2001 06:43 AM

Okay here goes:

1. First what kind of modem is it? If it is a winmodem, you probably have like a 5% chance it will work. If its not, you might want to try and reset the com port to either 2 or 3. Some modems have jumpers on the mdoem itself to maunally set this. If not, you might want to boot into windows to change this, then try.

2. Okay, so you mount the cd rom, what is the errors you recieve when trying to read from it? Were you mounting in the GUI or from the command line. If from GUI, try this on the command line:

# mount /dev/cdrom /mnt/cdrom
if no errors then try this:
# cd /mnt/cdrom
this will change into the cd rom to read to it. if no errors, then do and ls to list what is on the cd. then try to read from it or copy files from it.

3. Well, yes, in Linux....you will always have to do some type of configuration to get things working right. But that is the fun part though. You have total control of your system. You want to try using Drakconf to configure your sound, or try sndconfig....not sure though if that will work.

Good Luck and let us know.

Drew

BC 02-23-2001 06:57 AM

Thank you for your response, I have a U.S. Robotics 56K Voice PCI on com port 5 (Linux only shows up to com port 4). I wonder if SCSI has something to do with how I am configuring my system. I tryed to run "find new hardware" when I went back to the boot disk to upgrade and add office and I clicked on the find new haredware to see if I could get it to work and it asked for a driver to install (or one to chose from) I tryed everyone listed and none worked.

I will try what you suggested about mounting the Cdrom.

That's one of the reasons I like Linux, it is so powerful and puts the user in control, unlike windows that makes all the decisions for you.

Thank you again for your help, I really appreciate it.

BC

trickykid 02-23-2001 10:33 PM

Well first off, you need to go here with your modem's model number and find it on this list to see if it is a winmodem or not!
http://www.idir.net/~gromitkc/20010212a.html

If its a winmodem, most likely you need to get a new one to work with Linux. If someone has gotten it to work or its not a winmodem, you need to set the com and irq's in Windows to Com Port 2 and IRQ 5, I downloaded the manual and this is their recommended settings for Windows for almost all their modems. Or at least get it on com 4 or anything besides 5 or its not going to work. You should have one of those com ports open, not knowing why it would be on com 5, didn't know you could get a device on com 5, didn't even know it existed. Anyways, research, and let us know.


All times are GMT -5. The time now is 09:46 PM.