-   Linux - Newbie (
-   -   Newbie basic errors? Only root runs X, games does not work. (

fipeso 04-12-2005 04:29 PM

Newbie basic errors? Only root runs X, games does not work.

Im new to Linux.
I formated my pc that had "MS XP HOME Windows" installed on it and installed SlackWare 10.1 two weeks ago. (No dual boot, format c: :o )

I can get to startx as root and surf the web. Managed to install NVidia and allot of other stuff I don't even know what it is for :o (because different games seems to require some strange stuff for audio and things like that.)

Things are not going great though.

I have tried to install a few games, but cant get any off them to run correctly.
- "Targetware" flight sim runs but I cant get the joystick hat to work correctly. (hard to fly when one cant look around)
- "Supertux" platform game compiles (I think) but I cant find the executable program.
- "UFO-AlienInvasion_Xmas-demo" compiles and runs, but mouse moves so slow, I cant play the game.
- "dangerdeep" sub game wont compile. It gets error :
"/usr/lib/gcc-lib/i486-slackware-linux/3.3.4/../../../../i486-slackware-linux/bin/ld: cannot find -lGLU
collect2: ld returned 1 exit status

I must be doing some basic stuff wrong here...
I log in as root, download the game from the net to /root home. Right click the file and unpack it under /root. Read the INSTALL document and try my best...

Then I read at linux org that one should not do all stuff as root.

So I do from X console "adduser bob" and "passwd bob" and reboot and login as bob.

Now when I startx I get lotsa errors, and I realize things has to be very wrong on my system. :scratch:

Some say that slackware was a bad choice for a newbie. It did install nicely though. But there are a lot of small problems for me as a new user. Then again I really want to learn Linux, so if I can get the problems fixed it should be a good way to learn.

QUESTION (finally)
Is there some "standard" / "obvious" things I'm doing wrong here. Or is it a complicated task to get X to run as "looser user"?
Is there some basic thing I'm doing wrong when I try to install those games? Or is it more likely all has their own problems?
I want to learn Linux, but should I maybe down load a different distro, would that really help?

My first goal with Linux is just to get used to it and be able to understand some basic stuff. Get some games running, get the photos from the digicamera, use the printer and stuff like that. Hoping to learn, not just use.

Then in the long run I hope I would be able to setup a Linux firewall with VPN. Set up a web server and MySQL and learn how to manage those.

Maybe even install Linux on all the rest PC's at home, and learn how to "LAN" under Linux. (That be tough as the kids are running win98 for their moomin and barbie games :) )

Wow cant bellive anyone read this far :) Thank you.

Thanks for any help and comments :)


fatrandy13 04-12-2005 04:39 PM

to be honest, as a beginer, using slackware probably wasnt the best idea. its a great distro, but it does require skill. i would recomend trying a more 'user friendly' distro of linux and then once you feel more comfortable running it, try a more advaced OS like debian or slackware. Ubuntu is great for beginers. Its debian based and is available as a live cd or as an install disk. Also knoppix is always good to start with.

As for your specific problem, it most likely is a complicated problem involving multiple steps to fix. the description seems too broad, and without more specific detail, your not going to get many replies on it.

hope i helped in some way.

Komakino 04-12-2005 04:51 PM

I concur. Whilst I love slackware and will probably never now leave it, it isn't the easiest choice when trying to start out. Fixing the sort of errors you're talking about could well be hidden in some tiny text file somewhere, or just be a system setting that's not quite right to do with permissions that a more new-user oriented distro might go over twice just to check :)

I just put SuSE9.2 on my bro's computer, and while YaST is a good setup tool, I found that even finding the development packages (needed for compiling from source) and the kernel-sources was a challenge! There didn't seem to be a development section for packages and I eventually had to search in YaST.

I tried Mandrake on his computer and thought it lacked polish. I guess it's too RedHat like and I've never liked that.

I like Knoppix, it has the advantages of Debian's lovely apt-get package manager.

I was thinking of trying Ubuntu but don't see the need as I know my slack system inside out (slack is one of the few to use simplified BSD style init scripts and configuration directories - I much prefer that to the sysV style)

The real answer is get a hold of a few distros and try them all until you find one that suits you :)

fipeso 04-13-2005 01:03 AM

So in principle when one wants to add a user to a Linux system, it should be enough to "adduser" & "passwd", and then this new user should, on a correctly installed system, be able to run startx ?

No permissions or other "standard" stuff one would have to do to get X working for the new user ?

jonaskoelker 04-13-2005 06:43 PM


So in principle when one wants to add a user to a Linux system, it should be enough to "adduser" & "passwd", and then this new user should, on a correctly installed system, be able to run startx ?
In principle, sure. In principle, I should also be able to download a .tgz, type ./configure && make and be happy.

Now for the reality: it's often somewhat more hairy than that. I'm taking a wild guess here--there's some group you need to add bob to, so he can use the display/network/some other priviledged resource (`audio' is one such group on my box--but that of course doesn't influence x). I could be wrong.

hth --Jonas

jonaskoelker 04-13-2005 06:47 PM

I forgot about the games:
for supertux, $ find / -name 'supertux'
for dangerdeep, you need an openGL package. If slack differs between development packages and `ordinary' packages, development is what you need. Another possibility is that you didn't tell gcc to look in the directory where the GL library is (google GCC environment variables).

I don't know about the others.

fipeso 04-14-2005 02:17 AM

Thank you, I look into it when I get home from my booring job :)

I dont know anything about the groups, or basic file commands, so I am starting to think I need to find an easier distribution than SlackWare though, as meny tells me...

Maybe its easier to learn the basics with ubuntu or some other distribution?

Though I have to say that SlackWare 10.1 did install like a dream, and the programs that was in the distribution works as they should do.

trey85stang 04-14-2005 02:28 AM

You should break this post up into multiple posts.. you have way too much to read up there ;)

As for alien invasion.. you need to either disable (or enable) DGA, you will need to edit /etc/x11/xorg.conf

Im not at a linux box so I dont know this off the top of my head, at the top section there is a line for enable or disable DGA... you need to change it to the opposite of what is there. (I forget which it needs to be set to) that will fix the mouse issue.

fipeso 04-14-2005 03:11 AM

Thank you, I try this DGA thing when I get home :)

I had to google "linux dga" because I have no idea what DGA is. I think its some kind of debug thing?

Yes the post should maybe be breaked to multiple posts, but I guess the main question is just how to get started here :)

Quess what I really need is a newbie distro that comes with a newbie course manual :study:

jonaskoelker 04-14-2005 05:30 AM

what I think you need is just the newbie course manual, you have a fine distro. Okay, you might have more to learn before it purrs like a kitten, but oh well...

here's a few links:

hope these help --Jonas

fipeso 04-14-2005 11:05 AM


Originally posted by trey85stang

As for alien invasion.. you need to either disable (or enable) DGA, you will need to edit /etc/x11/xorg.conf

I put a # in front of the "Option "omit xfree86-dga" and restarted the computer.
It did not help the laggy / slow mouse in UFO game :(
Did I do this wrong?

--------------------------- snip -----------------------
Section "Module"

# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
# Option "omit xfree86-dga" # don't initialise the DGA extension

# This loads the font modules
Load "type1"
Load "freetype"
#Load "speedo"

# This loads the GLX module
Load "glx"

------------------------------- snap --------------------------------------------

I managed to get the mouse moved over the EXIT button and back in X I could read in the console window a error UFO

"LoadLibrary(""): can't open /etc/quake2.conf "

Can this have anything to do with the laggy slow mouse ?

Here is the whole text from the console window:

--------------------------- snip -----------------------

root@peppe:~# cd ufo
root@peppe:~/ufo# cd UFO-AlienInvasion_Xmas-demo_Linux
root@peppe:~/ufo/UFO-AlienInvasion_Xmas-demo_Linux# cd ufo
root@peppe:~/ufo/UFO-AlienInvasion_Xmas-demo_Linux/ufo# ./ufo
execing default.cfg
execing config.cfg
execing keys.cfg
Console initialized.

------- sound initialization -------
sound sampling rate: 44100
------- Loading -------
LoadLibrary(""): can't open /etc/quake2.conf
ref_gl version: GL 0.10
Initializing OpenGL display
...setting fullscreen mode 6: 1024 768
Using XFree86-VidModeExtension Version 2.2
GL_VERSION: 1.5.3 NVIDIA 71.74
...allowing CDS
...enabling GL_EXT_compiled_vertex_array
...using GL_EXT_point_parameters
...using GL_ARB_multitexture
...using GL_EXT_texture_env_combine
...GL_SGIS_multitexture not found
CD Audio Initialized
Shared Client/Server Info loaded
Couldn't open file 'current'.
====== UFO Initialized ======
------------------------------- snap --------------------------------------------

fipeso 04-14-2005 11:24 AM


Originally posted by jonaskoelker
for supertux, $ find / -name 'supertux'

Yes, I found it :)
Turns out it was in :

So all I have to do is run "supertux" :o

Thank you :)

jonaskoelker 04-14-2005 12:07 PM


trey85stang 04-14-2005 09:29 PM

remove the comment, and remove omit from the quotes. then you should be good to go :)

All times are GMT -5. The time now is 12:51 AM.