LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   New Questions (https://www.linuxquestions.org/questions/linux-newbie-8/new-questions-4175418862/)

CarltonH_ 07-26-2012 07:48 PM

New Questions
 
I'm a college student right now learning Linux. Everyday I'm getting more and more comfortable with it. Right now we're just learning commands. But I have 2 questions:

1. If I get a Linux+ Cert what kind of jobs can I get? I never thought I'd want to get a Linux job but after talking to my teacher I changed my mind lol.

2. Just getting some practice in and I was wondering what I am doing wrong in this senario:

I already have a user account created called Carlton. I create a new user account called Wanda. I create a new group called Marketing. I log into Carlton and create a file called File1. The UMASK is set to 002 so it comes out like:

-rw-rw-r-- Carlton Carlton 0 Jul 26 1800 File1

I put Wanda in the Marketing group

usermod -G Marketing Wanda

I also change the primary group from Carlton to Marketing

chgrp Marketing File1

So now it comes out:

-rw-rw-r-- Carlton Marketing 0 Jul 26 1800 File1

Now when I log in under Wanda I still cannot write to the file even though she is part of the Marketing Group and the Group permissions is read/write. What is causing me not to be able to write to the file?

chrism01 07-26-2012 08:22 PM

1. could be down to the file location; need to be able to get into the dir
2. try the 'id' cmd on Wanda ie login as Wanda & run 'id' to check groups.

Re jobs: you'd prob start as a junior admin, unless you want to be something else eg DBA, programmer etc

CarltonH_ 07-26-2012 09:46 PM

Yep that solved it. Problem was the directory that the file was in I didn't have the permissions needed to go to the directory. So even though I had permissions to write to the file I didnb't have permission to go to the directory. Kinda like I have permission to drive my car but I can't get in the car. If I cant get in then I can't drive. Same thing in this case with the files. But I appreciate that my teacher will be impressed once i tell him

grail 07-26-2012 10:24 PM

Please remember to mark questions as SOLVED once you have a solution.

chrism01 07-27-2012 01:11 AM

No worries; you learn something everyday in this profession :)


All times are GMT -5. The time now is 10:09 PM.