Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-21-2002, 10:54 AM   #1
LQ Newbie
Registered: Jul 2002
Location: VA
Distribution: suse 8.0
Posts: 2

Rep: Reputation: 0
new, need help mounting ntfs to fix dualboot

I installed suse 8.0. Went well except for Suse wanted to del my ntfs (hda) and install there instead of the empty drive (sda) so I changed it. Lilo comes up it gives option for windows when selected it says "ntloader not found"
Mounting the drive (hda) I get "no mount point" errors. If I type mount -t ntfs /dev/hda / it works but where the hell is it, it can be /. I'm just linux challenged I'm sure. Oh also my dmesg says "NTFS: Warning! NTFS volume version is Win2k+: Mounting read-only"? I though suse 8 had r/w access to ntfs.
Old 07-21-2002, 11:32 AM   #2
LQ Addict
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
Nope, the ntfs support in kernel is read-only, it is unsafe to write to ntfs partition - you can dump it by doing so. As for mounting problem, create under / windows partition and issue command
mount -tntfs /dev/hda /windows if you want just issue
mount /windows you need an appropriate entry in /etc/fstab
/dev/hda /windows ntfs ro,user, <other options if you wish> 0 0
As for your dual-booting problem you better look through one of the numerous howtos for dual booting I just pick this one in a random fashion
doing googling you can find a howto regarding SuSE and win2k dualboot setup.
Old 07-21-2002, 10:39 PM   #3
LQ Addict
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
As neo77777 said, create a mount point for it. Run mkdir /windows to create the mount point. Then run mount -t ntfs /dev/hda1 /windows -o ro. Note I used hda1 because you need to specify the partition windows is installed in and it's probably hda1. Using hda, the mount command will try to mount the whole drive.

In the /etc/lilo.conf file, the section for windows should look something like this:


After any changes that you make to the /etc/lilo.conf file, you need to run /sbin/lilo so that the changes will take effect.

Last edited by linuxcool; 07-21-2002 at 10:54 PM.
Old 07-22-2002, 12:10 PM   #4
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Boot W2k 4-floppys or full CD. Pick Recovery Console. fixmbr.

And do

reinstall SuSE. Put lilo on /dev/hda2

dd if=/dev/hda2 of=boot.lnx bs=512 count=1
cp boot.lnx /mnt/floppy
Boot Windows
copy boot.lnx c:\
edit boot.ini
After multi(0)..., add
Old 07-23-2002, 09:43 AM   #5
LQ Newbie
Registered: Jul 2002
Location: VA
Distribution: suse 8.0
Posts: 2

Original Poster
Rep: Reputation: 0

I did end up sticking in my win2k cd and running recovery console/fixmbr and lost everything execpt the win2k partition. I had other drivers and it removed all the partitions from them. The reason I needed to mount in r/w access is because most of the explanations on dual booting require me to write data to the boot sector which is on the win2k drive? I reinstalled linux and it noticed the win2k partition and set it up automaticaly this time?
Not sure what happened the first time. Thanks
Old 07-29-2002, 05:33 AM   #6
Registered: Jul 2002
Location: Los Angeles
Distribution: RedHat 7.3, SuSe 8.0
Posts: 71

Rep: Reputation: 15
SuSE 8 Mounting of NTFS XP Partition is not cutting it.

Hello all, once again I've got mount problems and this time it's in SuSe. I tried out Suse, because everyone was telling it has NTFS support of the bat. Some said it was Suse and Mandrake. Well I tried Mandrake and NTFS was there. Now that I've installed Suse, it sees the partiton, but when I try to mount it in kwikdisk, it gives me this error:

D:\drive NTFS XP partition.
Called: mount -tntfs /dev/hde5 /windows/D -o ro,noauto,user,umask=000
mount: mount point /windows/D does not exist

and this for C:\drive

Called: mount -tntfs /dev/hde1 /windows/C -o ro,noauto,user,umask=022
mount: mount point /windows/C does not exist.

I checked in my fstab file and the lines were apparent if they weren't they wouldn't be showing in Kwikdisk. Anyways I tried to console the command and this is what I get

linux:~ # mount -t ntfs /dev/hda5 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

The lines in fstab were automatically generated by suse,

but check this out, when I console this in

nt -t ntfs /dev/hde5 /mnt

then it works, what am I missing here?

I'm sure it has somthing to do with fstab, but I don't understand it if SuSe generates the line itself. Anyways I re-edited the line to this:

/dev/hda5 /mnt/windows ntfs ro,noauto,user 0 0

and it still didn't work. keep in mind that I also created a windows dir just for testing purposes. This is so wierd, I had it working fine in RH7.3 after I had made a moudle for NTFS support, but now it's in Suse, I'm sure this is not distro related. Just a minor error somewhere.

Anyone have ideas?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ntfs Mounting sri_hassan Fedora - Installation 2 11-24-2005 03:16 AM
Fix corrupted MBR on dualboot Machine Jingle Linux - Software 12 07-10-2004 04:13 PM
dualboot fix challenge Peterius Linux - Software 2 06-01-2004 04:13 PM
dualboot win2k w/ntfs & fedora w/grub? bewildered Fedora 2 12-19-2003 10:33 AM
DualBoot RedHat/Win98SE, HD Mounting Q? bannie Linux - Hardware 3 09-05-2003 02:20 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration