LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   New kernel not booting (https://www.linuxquestions.org/questions/linux-newbie-8/new-kernel-not-booting-116652/)

palanisaravanan 11-16-2003 09:26 AM

New kernel not booting
 
I am using SUSE 7.0 on my system which is using kernel 2.2.16.recently i have got a DSL connection and for using my DSL modem in Linux I installed 2.4.18 kernel.New kernel configuration,compilation everything went off smoothly.I copied that image of my new kernel (bzImage) and put it in to my boot directory and add that image in the lilo configuration also.the problem is my new kernel is not booting it can not mount the root file system.but my old kernel is booting.
My lilo(I ma using 22.5.6 version)
configuration file is as follows
__________________________________________________
# LILO configuration
boot = /dev/hda
prompt # always expect prompt
timeout = 150 # wait 15 seconds
vga = normal # force sane state
lba32 # 'linear' is deprecated
delay = 30 # delay 3 seconds if there is a stored command line
#serial = 0,1200n8 # uncomment to use COM1 too
read-only # initailly mount roots r/o
root = /dev/hda9 # use "current" root
image = /boot/vmlinuz#old kernel
label = linux
image = /boot/bzImage#new kernel
label = test
other = /dev/hda1
table = /dev/hda
label = windows

_______________________________________________

When i tried to boot my new kernel the messages is

kernel booting ......
request_module[blockmajor-3] root fs not mounted
VFs can not open root device "309" or 03:09
please append a correct "root=" option
kernel panic:VFS :unable to mount root fs on 03:09
--This is the message i got.I don't know why it can not mount root file system.But My old kernel is mounting the same root file system.
Is there any thing went wrong with my kernel compilation(like i didn't enable any flags).I don't know.Please help me to fix the proble.Thanks in Advance.

teval 11-16-2003 10:23 AM

It's either something wrong with your LILO config, don't know what since I haven't used Lilo in over a year.
It's probably that the ATA drivers in the kernel aren't properly installed.
Any disk-type driver should not be M, unless you know exactely what you are doing. Make sure they are compiled right into the kernel
And make sure that the appropriate filesystems are also compiled into the kernel (not modules)
That probably will fix it :)
Also check the roo= in lilo and make sure it's exactely the same as the one for the other kenel

MartinN 11-16-2003 02:00 PM

Very similar to this one:

http://www.linuxquestions.org/questi...hreadid=112937

It's probably some setting in your Kernel configuration. Look at the other thread and come back here if that didn't help.

Good luck!
Martin

palanisaravanan 11-18-2003 05:46 AM

Thanks for the answer.But still i am struggling at this point.I enabled file system in the kernel configuration.I enable UMSDOS ,FAT,ISOFS,ext2,ext3,
MS_DOS,minix and loaded others as module.Intial RAM disk everything is ok.But after reaching
lec.c NOV 18 2003 intialized
end_request :I/O error
dev 03:09(hard disk) sector 2
Ext2-fs :unable to read the super block
minix-fs unable to read the super block
FAT :unable to read boot loader
UMSDOS :unable to read boot loader
ISOFS:unable to read boot loader
kernel panic:unable to mount the roort file system
-This is the message I got.I am able to boot my old kernel.
my root file system is mounted on /dev/hda9 and /dev/hda7 on /boot
(ext2 file system)
.Please help me to come out of this problem.

MartinN 11-18-2003 04:27 PM

Hi again

Sorry to have kept you waiting.

Looks like you have enough file systems compiled in ;)

What is your settings for IDE devices? It seems to me that the file system(s) fails to communicate with the disk controller. I'm no expert at this, so it's just a wild guess.

If you use "make xconfig" for the configuration, then there should be a tab named "ATA/IDE/[...] support". First make sure that you have it compiled in at all (not as a module). After that you may (horror, horror) have to look at the sub-menu for the Block devices. I'm afraid that you're on your own then.

Good luck
Martin

palanisaravanan 11-18-2003 10:25 PM

I enabled ATA/IDE support .But still i am getting the same errors.I am struggling at this point for the past 4 days.Help me come out of the blue

bencl5 11-19-2003 12:50 AM

hey i ran into that problem as well only i was using grub as the boot loader. to fix it i think you would have to edit your /etc/lilo.conf file and where you boot your kernel should be a section that says root=/dev/hda1 or whatever just comment that out. for some reason that fixed it on mine but i don't know if that will work for lilo...:Pengy:

palanisaravanan 11-19-2003 03:32 AM

Thanks for the answers.At last it is working now.Only some problem with the fram buffer drivers(X server is not working).Otherwise it is working fine.

MartinN 11-19-2003 03:44 AM

Good to hear. May I ask what the problem was?

Regards
Martin

cellist 11-19-2003 09:15 AM

Yeah, how did you fix it as I'm having the exact same problem? Thanks


All times are GMT -5. The time now is 04:12 PM.