-   Linux - Newbie (
-   -   new kernel installation & loop back devices? (

fbarre 10-08-2003 11:00 AM

new kernel installation & loop back devices?
can somebody give me a hand please... I'm trying to install a new kernel, 4.2.22, and I properly went thru all the compilation process but when I tried to buid the image as follows:

/sbin/mkinitrd /boot/initrd-4.2.22.img 4.2.22

it says:

All of your loopback devices are in use.

what does this mean and what are the loopback devices?

thanks in advance.

hussar 10-17-2003 05:39 PM

OK, haven't seen this before, so you'll have to give me some more info.

What distro are you using?
How did you build the kernel? (make menuconfig, make Xconfig, or a distro-specific method)?

What modules are you tyring to load in order to boot? initrd is primarily used to load modules that are required for the boot process. If you don't need them, you might not need initrd.

Loopback devices are usually used to support mounting CD images and encrypted file systems.

fbarre 10-18-2003 02:14 PM

It appears few people faced this problem before.. to learn more about it, google "All of your loopback devices are in use".

I built the kernel using "menuconfig" and I 'm not trying to load any modules as I didn't build the kernel with any loadable modules.

I'm building 4.2.22 distribution and the one I'm currently running is 4.2.21.

Hope you can help further.

hussar 10-19-2003 05:06 AM

Did you compile the kernel with loopback support compiled in? The selection for it is under the "Block Devices" section of menuconfig's display.

You mean kernel 2.4.22, right?

Ok, wait a minute. The coffee has begun to kick in. You are having problems with the kernel you have, not the kernel you compiled. Different problem set. It is possible that you do not have the loopback module loaded. Try 'insmod loop' or 'insmod loop.o' as root. See if that does the trick. If not, we'll scratch our heads for a little while longer.

fbarre 10-19-2003 08:56 PM

Gosh, yes... I mean 2.4.22!!!
Sorry, I've been stressed lately but will try your suggestion and let you know.

Thanks for your help.

fbarre 10-21-2003 01:40 PM

Ok, I finally got it working after days and days of dragging this problem.

Hussar, as you said, the problem was with the kernel I had 2.4.21(ie. not the kernel I was compiling 2.4.22). I recompiled my old kernel, 2.4.21, after adding the support of "Loopback" under "Block Devices" section and here's the trick that worked for me:

I added Loopback support as a LOADABLE module and NOT built-in. Then once past module compilation step (ie. make modules), I loaded Loopback.o before even re-installing my old kernel and it worked! Why before re-installing? simply because I couldn't even re-install my old kernel and kept saying "All of your loopback devices are in use" after a /sbin/mkinitrd.

To find "loopback.o" location enter "locate loopback.o").

Hope all this make sense..

thanks again Hussar!

All times are GMT -5. The time now is 04:08 AM.