LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   New ext3 partition doesn't mount on boot (https://www.linuxquestions.org/questions/linux-newbie-8/new-ext3-partition-doesnt-mount-on-boot-597225/)

asininity 11-05-2007 05:01 AM

New ext3 partition doesn't mount on boot
 
I've been stuck on this one for ages can't seem to find the solution. I've blized my vista partition and using gparted turned it into a ext3 partition I can mount the partition manually fine but wanted it to mount on boot. I deleted the vista section from the grub menu I then changed the fstab file correcting the UUID and with the option "auto" which I assumed would now mount the partition when I started the laptop, but no.

Heres my fstab file the underlined bit is what I'm having trouble with:

Code:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
#

proc /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=8e45368b-ca34-43f6-a5c0-3eb9f28939db / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda1 :
UUID=5C6C052B16D9B5D2 /media/sda1 ntfs umask=222,utf8 0 1
# Entry for /dev/sda2 :
UUID=1c5e974e-6386-4f80-96dd-ba67da68b609 /media/Storage ext3 auto 0 1
# Entry for /dev/sda4 :
UUID=1ddb49d5-157b-44a9-9f95-050ad2481da6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

Can anyone shed some light on how I can get this new ext3 partition to mount automatically on boot?

colucix 11-05-2007 08:30 AM

Why don't simply use defaults, which usually comprises auto? Check man mount to see which options are referred by defaults.

asininity 11-05-2007 03:48 PM

Thanks for the reply but its working now I've added some more options:

UUID=1c5e974e-6386-4f80-96dd-ba67da68b609 /media/Storage ext3 rw,user,auto 1 1

I tried the "defaults" option and it didn't work for me, however, that was possibly my own fault. I have an a suspicion it might have had something to do with permissions but can't say for certain which is why I put "user" in the options. Thanks again.


All times are GMT -5. The time now is 08:17 AM.