LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   New CDRW/DVD combo drive not working! (https://www.linuxquestions.org/questions/linux-newbie-8/new-cdrw-dvd-combo-drive-not-working-94776/)

Derrick 09-20-2003 05:56 AM

New CDRW/DVD combo drive not working!
 
Installed new LITEON CD-RW/DVD combo drive on secondary IDE channel.

mount -t auto /dev/cdrom /mnt/cdrom

get error: can't read superblock

what have i missed??

Using Redhat 9

any help thanks.

kev82 09-20-2003 06:03 AM

secondry master or slave? if master replace /dev/cdrom with /dev/hdc else /dev/hdd. also make sure its got a readable disk in it.

to get cd burning working you'll need a kernel with scsi emulation enabled and you'll need to specify the drive as ide-scsi at boot time.

Derrick 09-20-2003 06:25 AM

Thanks Kev82,

Drive is attached to secondary master (hdc) and i tried /dev/hdc still get same message. How do check for scsi emulation?. I tried lsmod which shows a list of stuff but dont know what i'm looking for!. Also I know i need something in my /etc/grub.conf here it is at prsent:-

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdc2
# initrd /initrd-version.img
#boot=/dev/hdc
default 0
timeout 1

splashimage=(hd0,0)/grub/splash.xpm.gz
fallback 1
title Red Hat Linux (2.4.20-20.9)
root (hd0,0)
kernel /vmlinuz-2.4.20-20.9 ro root=LABEL=/
initrd /initrd-2.4.20-20.9.img / hdc=ide-scsi


title Red Hat Linux (2.4.20-19.9)
root (hd0,0)
kernel /vmlinuz-2.4.20-19.9 ro root=LABEL=/
initrd /initrd-2.4.20-19.9.img


As you can see i have added hdc=ide-scsi is this in the right place??

Also here is etc/fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,kudzu,ro 0 0

How someone can help as this is now driving me INSANE!

kev82 09-20-2003 06:37 AM

oh youve already done hdc=ide-scsi, in that case try /dev/scd0 instead of /dev/hd?, if that doesnt work run cdrecord -scanbus to test if scsi emulation is picking it up.

Derrick 09-20-2003 07:14 AM

/dev/scd0 gives out not a valid block device

when i try cdrecord -scanbus i get:

cdrecord no such file or directory. cannot open '/dev/pg*'. cannot open scsi driver.

Derrick 09-20-2003 07:45 AM

Problem now solved!!, hdc=ide-scsi in the wrong place!. now iam able to mount under root cd & dvd data now just need to try writing cd's & playing DVD's.

What software is there for playing DVD's under redhat 9?. also how do i make all users able to mount CD/DVD's?. I have changed 'owner' to 'users' in /etc/fstab but when i tried to mount cd in shell as user it said only root can do this.

Thanks for your help Kev82.

kev82 09-20-2003 09:07 AM

assuming the device is /dev/cdrom then the fstab line you have above should work fine. i wouldnt bother with the owner option, its only useful if you have people logging in remotely.

as for playing dvd's i would go with mplayer.


All times are GMT -5. The time now is 12:19 PM.