LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2013, 03:01 AM   #1
lolatyou
LQ Newbie
 
Registered: Jul 2013
Distribution: Crunchbang (Waldorf)
Posts: 3

Rep: Reputation: Disabled
Networking issues, can't connect to the internet at all


I'm running a fresh install of Crunchbang (Waldorf) on my X301, and I am unable to connect to the internet with both wired and wireless options. The LiveCD does let me connect, and so does my windows partion. I've tried it on both my routers (WRT54G/RT-AC66U) but still unable to connect, I have no problems with any of my other wifi devices. So I think I can rule out hardware issues And yes, the hardware switch for my wifi is on.

Here are some commands I have run to diagnose my issue. Was run with my WRT54G (was done a few weeks ago, was very busy in the interim period)
  • lspci | grep net -i

gives me:
Code:
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
03:00.0 Network controller: Intel Corporation Ultimate N WiFi Link 5300
I then ran:
  • tail -f /var/log/syslog

when everything is at default:
Code:
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) starting connection 'BJROX2'
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0/wireless): connection 'BJROX2' has security, and secrets exist.  No new secrets needed.
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Config: added 'ssid' value 'BJROX2'
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Config: added 'scan_ssid' value '1'
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Config: added 'psk' value '<omitted>'
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Jul  5 02:32:12 crunchbang NetworkManager[1988]: <info> Config: set interface ap_scan to 1
    Jul  5 02:32:12 crunchbang wpa_supplicant[2057]: wlan0: Failed to initiate AP scan
    Jul  5 02:32:13 crunchbang wpa_supplicant[2057]: wlan0: Failed to initiate AP scan
    Jul  5 02:32:14 crunchbang wpa_supplicant[2057]: wlan0: SME: Trying to authenticate with 00:1a:70:db:c9:81 (SSID='BJROX2' freq=2462 MHz)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.523442] wlan0: authenticate with 00:1a:70:db:c9:81 (try 1)
    Jul  5 02:32:14 crunchbang wpa_supplicant[2057]: wlan0: Trying to associate with 00:1a:70:db:c9:81 (SSID='BJROX2' freq=2462 MHz)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.525212] wlan0: authenticated
    Jul  5 02:32:14 crunchbang kernel: [ 4553.527886] wlan0: associate with 00:1a:70:db:c9:81 (try 1)
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> (wlan0): supplicant interface state: inactive -> associating
    Jul  5 02:32:14 crunchbang kernel: [ 4553.531164] wlan0: RX ReassocResp from 00:1a:70:db:c9:81 (capab=0x431 status=0 aid=3)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.531172] wlan0: associated
    Jul  5 02:32:14 crunchbang wpa_supplicant[2057]: wlan0: Associated with 00:1a:70:db:c9:81
    Jul  5 02:32:14 crunchbang kernel: [ 4553.544195] cfg80211: Calling CRDA for country: DE
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> (wlan0): supplicant interface state: associating -> 4-way handshake
    Jul  5 02:32:14 crunchbang wpa_supplicant[2057]: wlan0: WPA: Key negotiation completed with 00:1a:70:db:c9:81 [PTK=CCMP GTK=TKIP]
    Jul  5 02:32:14 crunchbang wpa_supplicant[2057]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:1a:70:db:c9:81 completed (reauth) [id=0 id_str=]
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556223] cfg80211: Regulatory domain changed to country: DE
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556231] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556240] cfg80211:     (2400000 KHz - 2483500 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556248] cfg80211:     (5150000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556255] cfg80211:     (5250000 KHz - 5350000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    Jul  5 02:32:14 crunchbang kernel: [ 4553.556262] cfg80211:     (5470000 KHz - 5725000 KHz @ 40000 KHz), (N/A, 2698 mBm)
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'BJROX2'.
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> (wlan0): device state change: config -> ip-config (reason 'none') [50 70 0]
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> dhclient started with pid 4619
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Beginning IP6 addrconf.
    Jul  5 02:32:14 crunchbang avahi-daemon[1962]: Withdrawing address record for fe80::221:6aff:fe19:5ef6 on wlan0.
    Jul  5 02:32:14 crunchbang avahi-daemon[1962]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::221:6aff:fe19:5ef6.
    Jul  5 02:32:14 crunchbang avahi-daemon[1962]: Interface wlan0.IPv6 no longer relevant for mDNS.
    Jul  5 02:32:14 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
    Jul  5 02:32:15 crunchbang NetworkManager[1988]: <info> (wlan0): DHCPv4 client pid 4619 exited with status 0
    Jul  5 02:32:15 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) scheduled...
    Jul  5 02:32:15 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) started...
    Jul  5 02:32:15 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv4 Configure Timeout) complete.
    Jul  5 02:32:16 crunchbang ntpd[1875]: Deleting interface #5 wlan0, fe80::221:6aff:fe19:5ef6#123, interface stats: received=0, sent=0, dropped=0, active_time=3384 secs
    Jul  5 02:32:16 crunchbang ntpd[1875]: peers refreshed
    Jul  5 02:32:16 crunchbang avahi-daemon[1962]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::221:6aff:fe19:5ef6.
    Jul  5 02:32:16 crunchbang avahi-daemon[1962]: New relevant interface wlan0.IPv6 for mDNS.
    Jul  5 02:32:16 crunchbang avahi-daemon[1962]: Registering new address record for fe80::221:6aff:fe19:5ef6 on wlan0.*.
    Jul  5 02:32:18 crunchbang ntpd[1875]: Listen normally on 6 wlan0 fe80::221:6aff:fe19:5ef6 UDP 123
    Jul  5 02:32:18 crunchbang ntpd[1875]: peers refreshed
    Jul  5 02:32:20 crunchbang ntpd_intres[1898]: host name not found: 0.debian.pool.ntp.org
    Jul  5 02:32:20 crunchbang ntpd_intres[1898]: host name not found: 1.debian.pool.ntp.org
    Jul  5 02:32:20 crunchbang ntpd_intres[1898]: host name not found: 2.debian.pool.ntp.org
    Jul  5 02:32:20 crunchbang ntpd_intres[1898]: host name not found: 3.debian.pool.ntp.org
    Jul  5 02:32:25 crunchbang kernel: [ 4564.400110] wlan0: no IPv6 routers present
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> (wlan0): IP6 addrconf timed out or failed.
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) started...
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> (wlan0): device state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <warn> Activation (wlan0) failed for access point (BJROX2)
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <warn> Activation (wlan0) failed.
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> Activation (wlan0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> (wlan0): deactivating device (reason 'none') [0]
    Jul  5 02:32:35 crunchbang kernel: [ 4574.008923] wlan0: deauthenticating from 00:1a:70:db:c9:81 by local choice (reason=3)
    Jul  5 02:32:35 crunchbang wpa_supplicant[2057]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
    Jul  5 02:32:35 crunchbang kernel: [ 4574.057497] cfg80211: Calling CRDA to update world regulatory domain
    Jul  5 02:32:35 crunchbang NetworkManager[1988]: <info> (wlan0): supplicant interface state: completed -> disconnected
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065629] cfg80211: World regulatory domain updated:
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065634] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065639] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065644] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065649] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065653] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    Jul  5 02:32:35 crunchbang kernel: [ 4574.065658] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
The connection would then just keep trying and failing to connect in a loop.
 
Old 07-26-2013, 04:33 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,558

Rep: Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862
If networkmanager won even interactively put you on, it's odd. Have you run system-config-network, and fed it all the correct stuff? If not, do so.
 
Old 07-26-2013, 05:07 AM   #3
lolatyou
LQ Newbie
 
Registered: Jul 2013
Distribution: Crunchbang (Waldorf)
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
Have you run system-config-network, and fed it all the correct stuff? If not, do so.
how do I do that? the terminal didn't have that command
 
Old 07-26-2013, 11:26 AM   #4
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,558

Rep: Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862
Open a terminal or console, and in it type
Code:
sudo system-config-network
. Then press return - The biggest key.
 
Old 07-26-2013, 11:32 AM   #5
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,211

Rep: Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612
Quote:
Originally Posted by business_kid View Post
Open a terminal or console, and in it type
Code:
sudo system-config-network
. Then press return - The biggest key.
My space bar takes this title.
 
Old 07-26-2013, 12:39 PM   #6
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,558

Rep: Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862
Misread your last post.
Most things with networkmanager also have system-config-<this, that, & the other>
These are python scripts to do the setup work for you. Try

ls /usr/bin/system-config*

Failing that, your distro will have siome way of configuruing the network, and I would start there.
 
Old 07-26-2013, 12:58 PM   #7
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,677

Rep: Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485
If you had a connection with the live disk but lost it after installation, it suggests to me that the installation went wrong. I'd re-install, but you might want to try some tactics found here:
http://wiki.debian.org/Network

As far as I know, system-config-network is a Red Hat thing. The lack of decent configuration tools is one reason I've never used a Debian-based distro ...
 
Old 07-26-2013, 02:29 PM   #8
lolatyou
LQ Newbie
 
Registered: Jul 2013
Distribution: Crunchbang (Waldorf)
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
Open a terminal or console, and in it type
Code:
sudo system-config-network
. Then press return - The biggest key.
Quote:
Originally Posted by business_kid View Post
Misread your last post.
Most things with networkmanager also have system-config-<this, that, & the other>
These are python scripts to do the setup work for you. Try

ls /usr/bin/system-config*

Failing that, your distro will have siome way of configuruing the network, and I would start there.
Nope, command not found. Don't think it's on the distro.


Quote:
Originally Posted by DavidMcCann View Post
If you had a connection with the live disk but lost it after installation, it suggests to me that the installation went wrong. I'd re-install, but you might want to try some tactics found here:
http://wiki.debian.org/Network

As far as I know, system-config-network is a Red Hat thing. The lack of decent configuration tools is one reason I've never used a Debian-based distro ...
will try a reinstall tomorrow.
 
Old 07-27-2013, 01:47 AM   #9
Devyn
Member
 
Registered: Oct 2004
Posts: 97

Rep: Reputation: 15
What does ifconfig -a show? Try ifdown eth0 then ifup eth0 if that is your interface. There's a ton of other solutions on this page as well. Try these and post what you get using the informational commands:

Device eth0 does not seem to be present

Have you tried these Wireless Networking configuration options (if possible for your system)?

Cheers,
 
Old 07-27-2013, 09:50 AM   #10
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,558

Rep: Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862Reputation: 862
Quote:
Originally Posted by DavidMcCann View Post
As far as I know, system-config-network is a Red Hat thing. The lack of decent configuration tools is one reason I've never used a Debian-based distro ...
Agreed - it is a red hat thing. But itś bought/used by Mandriva, all RHEL clones,some others, and even slackware has/had system-config-printer.
When I did LFS, I found out how easy most of this configuration stuff was. A few lines in a few files and you have things doing exactly what you want. There are exceptions, and some config files are a lifeś work (e.g. sendmail.conf, apache.conf on busy servers).

Let's do this by hand.
Code:
ifconfig eth0 down
ifconfig wlan0 up
iwlist wlan0 scan |less
can you see your own router? If not, post the error. If so, note your essid, run the mouse over your router's mac address (00:11:22:33:44:55:66) and continue
Code:
iwconfig wlan0 essid <your_essid> ap <paste that mac address
iwconfig wlan0
Line 2 will either have your access point (you're good) or 'not associated'. In the unlikely event that you're good, type

dhcpcd wlan0 or
dhclient wlan0

and then you can surf. Presuming this goes down in flames, detail exactly where and show us the errors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any command to know what networking interface am i using to connect to internet tirengarfio Linux - Networking 1 02-02-2010 07:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration